Jump to content
Sign in to follow this  
Followers 0
geo4cache

Etrex 30 stopped time issue?

Recommended Posts

My Etrex 30 worked fine until I upgraded to 4.30 of the firmware. Before the upgrade it would show my average speed at 3mph but now it is reporting close to 5mph. Running 4.30 the unit is classifying moving time as stopped time on a random basis. I reset the unit to factory defaults but that didn't make a difference. Is there a way to down grade to earlier versions of the firmware?

Share this post


Link to post

No idea whether 4.30 is your problem, but yes, you can grab the previous firmware (4.20) at http://www.gawisp.com/perry/etrex/eTrex_10_20_30/eTrex20_30_Webupdater__420.gcd

If you need to back even further, there's http://www.gawisp.com/perry/etrex/eTrex_10_20_30/eTrex20_30_Webupdater__410.gcd

 

You may find this a useful repository for all kinds of old Garmin firmware and apps.

Share this post


Link to post

Just drag and drop the appropriate *.gcd file onto the Garmin Webupdater icon with your device connected and powered up.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  
Followers 0

×
×
  • Create New...