Jump to content

Garmin 62stc waypoint issues

The Geo-Goldenz
Followers 1

Recommended Posts

My new 62stc feels like a DOWNgrade to my 60csx. Garmin just keeps sending me canned responses that do not fit my issue. Right now, I am trying to get ALL the waypoints that I have downloaded to it to show, with their labels. I can only make a waypoint appear when I select it individually from the list. Now Garmin is telling me that the new 62stc doesn't work with Mapsource, which seems ridiculous to me. Anyone able to offer some help with the waypoint labeling/showing issue? Many thanks!

Link to comment

Where do you want all the Waypoints to show, on the map or in the list of waypoints?


I don't think there is a problem with the 62STC working with Mapsource. But i do know Garmin is dropping Mapsource in favor of Basecamp.


On the screen of the 62stc when zoomed all the way out and with their labels when zoomed in far enough. Thanks for helping.

Link to comment

I don't think waypoints can be displayed on the map like that. AFAIK Geocaches are the only ones that show up on the map all the time. Try moving your waypoints to the GPX folder on the unit and see if that makes them appear how you want them. I don't have a 62 so i'm not vary familiar with the unit.


I'll give that a try, although I wanted to take advantage of the 2000 waypoints on the new 62. So far I am NOT impressed with it.

Link to comment

I have an oregon and an astro 350 which is supposed to be based on the 62, my waypoints show up.


What do you have the map setting on? You can change how you have to zoom to see them, or something.


THere should be a gpx file in one of your garmin folders that waypoints are stored in. Are they in the wrong folder?


I used basecamp to transfer my waypoints that I had stored on my computer to my new units when I first got them. I had a couple of duplicate waypoints, I fixed it but I don't know why it happened. I usually use easygps. It doesn't have some of the special icons though, so when I downoad them into the new ones the symbol is differant.


I don't know how to use basecamp to just download new waypoints. Maybe I will get used to it but right now I don't care for it. I like to clear my gps's sometimes and load region specific waypoints and geocaches. Of course my vista didn't hold as many so I had to do that.

Link to comment

Try restoring your map default settings. You do this by pressing "Menu->Restore Defaults" on the map page. It that doesn't work, you might try changing the detail level to "more" by pressing "Menu->Setup Map->Advanced Map Setup->Detail->More" on the map page.

If that still doesn't do what you want, press "Menu->Setup Map->Advanced Map Setup->Zoom Levels->User Waypoints" and try different values. As you increase the value, then the waypoints will continue to be present as you zoom out to that level. You might also try changing your detail level to "More".


The GPSMap 62 series is like the Oregon series. They don't play well with MapSource, but are intended to be used with BaseCamp. BaseCamp has some nice features, but takes some time to get used to. Also, it is a bit buggy compared to MapSource. BaseCamp uses more of a drag-and-drop approach to exchanging data between the program and GPS.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Followers 1
  • Create New...