Jump to content

Software version 4.0 for GPSMap76CSx?


Crid
Followers 2

Recommended Posts

I've just run WebUpdater on my 76CSx and it says there is new software. I'm currently on 3.70 and it says 4.00 is now out. I did a quick search of this forum but can't see any mention of it (presumably it's been out for more than a month). Can anybody tell me if this release is OK to install (no big issues), or am I best to hold back?

Link to comment

Greetings! I know the 4.0 upate thread was listed, probably under the alias of the GPSMAP 60 CSx. I uploaded this version about 2 months ago, and have no complaints nor have seen any. Really like the upgraded capability to 4 GB memory cards. IMHO, this one is good to go. HTH

Link to comment

Greetings! I know the 4.0 upate thread was listed, probably under the alias of the GPSMAP 60 CSx. I uploaded this version about 2 months ago, and have no complaints nor have seen any. Really like the upgraded capability to 4 GB memory cards. IMHO, this one is good to go. HTH

 

Right after it came out there were a number of complaints on the Yahoo 60CSX group that it was crashing. The general consensus was that folks with problems were using poorly compiled third party maps. I've never had that problem myself, and I run a mix of CityNavNT and maps I've compiled using cgpsmapper and mkgmap. Still, if you use a lot of third party stuff, you should be aware of possible problems.

Link to comment

There will probably be a newer version out soon. People who have received repair exchange units from Garmin have been reporting that they are loaded with unit firmware 4.10 since at least August 26. Reference: http://groups.yahoo.com/group/Garmin_GPSMa...Sx/message/8543 A colleague of mine had the same experience. It has been seen in both SiRF and MediaTek equipped units.

 

It isn’t available to the rest of us yet, but it seems likely that it will be soon. Might just want to wait until it is and load that if you don't have an immediate need to load more than 2 GB of maps.

Link to comment

Thanks for the responses. I loaded 4.00 this morning (and the GPS update - I'm guessing that's a firmware update for the GPS bit rather than the interface). All booted up OK afterwards, so hopefully I'm good to go.

Edited by Crid
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 2
×
×
  • Create New...