Jump to content
Sign in to follow this  
Followers 0
davidloew

If Auto Detect Gps Doesn't Work

Recommended Posts

When the Wherigo Player starts up for the first time, it will try to auto detect the gps port. This, on some devices, either never detects or simply locks up. In the latest version of the player, there is code to override this behaviour and make the system use a certain communications port. Here are the instructions:

 

Check to see if you have a wigconfig.config file in you device's \Program Files\Groundspeak\Wherigo\Player folder. If you do, you can copy it to your desktop and change the settings there. In the file, there is a line called AutoDetectGps. It probably has a value of "True". Change that to "False". Then you'll see "BaudRate" and "CommPort" values. Here is what the whole file looks like:

 

<configuration>

<appSettings>

<add key="AutoDetectGps" value="False" />

<add key="BaudRate" value="9600" />

<add key="CommPort" value="COM4:" />

<add key="CartDirectory" value="My Documents\Groundspeak\Wherigo\Cartridges" />

</appSettings>

</configuration>

 

This will cause the player to not to try to auto detect and to try to use the com port instead. To repeat, the file on your device is/should be:

\Program Files\Groundspeak\Wherigo\Player\wigconfig.config

 

If you don't have this file on your device, you can create it exactly as above with your settings and then copy it to your device to the folder mentioned above. Make sure you have the latest player program installed.

Share this post


Link to post

I just bought a used mio 168 and have tried everything I can find and still cannot get the Wherigo software to launch the gps. In the tutorial I get to where the captain says my signal is weak but it never gets better. In the whack-a-lackey I never get to actually start a game. I think I am doing things correctly but still having no luck.

Please help

Share this post


Link to post

Both cartridges use a Wherigo function call to ask the GPSr its position accuracy. If the value is too high, the cartridge will not continue. It's an odd function call because my Colorado always seems to return a zero foot accuracy. I wonder if your GPSr is reporting a value too high? Anything over 45 meters and the cartridges won't run.

 

Unzip and load the attached cartridge on your GPSr. When you start the cartridge, it'll tell you the accuracy, in meters, your GPSr is reporting to the Wherigo Player. What does it say?

accuracy.zip

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

×