Jump to content

Bug in Garmin 60csx firmware?

Bos T

Recommended Posts

Hi all,


I've had my GPSmap 60csx (Atlantic version, loaded with Topo GB maps V2) for just a couple of weeks, and I'm pretty impressed with it. However, I've noticed some odd behaviour, which I originally took to be a faulty unit and got it exchanged. With my brand new unit in hand I've now found the exact same problems, so I wondered if anyone else has found, or can replicate, this problem.


When routing A to B with the Follow Road option, the unit occasionally switches itself off at the 'Working' dialogue. If the backlight is on, that goes first, then the screen fades to blank, and I need to press the power button to get it working again. This happens with new batteries, and even when powered by USB cable.


If the route calculates OK, switching to the Active Route screen and choosing Menu/Profile is more likely to cause the same effect - power off either immediately or part way through when 'Working'. With some routes this happens every time, with others only sometimes, and with others again not at all. I can't work out what the common denominator is, but I'm thinking maybe it's the number of turns - long routes that use motorways for long stretches are OK, other shorter ones that have lots of turns (e.g. through towns) seem to initiate the problem.


I phoned Garmin support, who had never heard of this problem and suggested I send the unit back. I phoned the retailer, who had also never heard of this problem, and very promptly replaced the unit. I've searched long and hard and found no reference to this problem on the internet, although similar 'screen fade' problems seem to exist on the 60csx (e.g. the day view calendar bug). Apologies if this is a well known problem and I've just not found any reference to it - as I say, I've only had the GPS for a couple of weeks.


For the record, I've got the latest software installed (software 3.30, GPS 2.90), all GB topo maps on a 2 Gb card (although even a few on the 64 Mb card causes the same effect). I've tried reinstalling the maps a couple of times, in case there's a problem there... It's not even really a problem for me because I have a Nuvi 350 that I use in-car anyway!! I'm just curious to know if I've had 2 duff units, or if there is a bug that Garmin need to consider in their next firmware update.


Can anyone else replicate this??


Bos T

Link to comment

I run the same unit as you with TOPO GB V2, though it is nearly a year old now.


I experienced similar shut-off problems as you have described when I first had the unit. It turned out that it was always shutting off at the same place geographically, and that was at a join between two map tiles. I had firmware 2.9 (I think) and when I re-loaded it with web updater to version 3.1 it cured the problem.


Since then, firmware has been updated by Garmin a couple of times to version 3.3 (I think) but I have read about problems people have had with the updates. So I haven't updated from 3.1, and my unit continues to work fine.


It must be worth a go at trying a retrograde update to, say, version 3.1 to see if it makes a difference. Not sure where you'll find that version of the software, but somebody posted a link to it recently so I know it is out there somewhere!

Link to comment

Thanks for suggesting this. I tried installing several older firmware versions - I found a useful archive of GPSmap 60xx firmware here. Going back to firmware 3.1 solved one of the problems - the option to show the route altitude profile seems had not to have been implemented until v3.2! - but the routing screen-fade problem occured in all versions of firmware I tried with longer routes. The altitude profile is quite useful, particulary for bike rides (which are shorter, and thus don't seem to cause the error), so I'm back to v3.3 which otherwise seems to be very good.


I've also since found discussion of this (and very similar) problem(s) elsewhere, and GB topo maps seem like it might be as much part of it as the GPSr. It's not the resolution I was hoping for, but at least it seems it's not just my copy of the 60CSx.


I'm surprised the Garmin support guy hadn't heard of this problem and I'll email them to see if there's potential to do something for the next firmware release. Who knows...?




Bos T

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...