Jump to content

Opening saved .lua file w/ builler

Followers 1

Recommended Posts

I worked for a couple hours, and now I get this error when I try to reopen and continue working on


Error message:


Error Reading Cartridge.

System.ApplicationException: Exception of type 'System.ApllicationException' was thrown. at Groundspeak...

...at ZonesAuthor.frmMain.OpenCartridgeFile()


What is up?



Link to comment

Maybe some error in your custom code (if you have any) or even in the builder generated code.

Try downloading urwigo (or if you have an account earwigo) and import the LUA file there and see if that works.

If it also throws an error you should check the .lua file itself for errors

Link to comment

If you have a 64-bit Windows OS, this is a well-known problem. If you do, you can test this by creating a blank cartridge (no zones, no nothing), saving it, and trying to open it; you should get the same error message.


This is the answer to the problem, but you have to install the .Net SDK (I think that link will do) before you can apply the fix.


Or, yes, you can use Urwigo. It's difficult for me to endorse Urwigo, though, because its lua output is more difficult to read since it tries to obfuscate text and variable names. As a builder application, it's fine.

Link to comment

Haven't had any luck opening my original file, but I was able to cut and paste my data from a notepad file and start another one. Do be honest, I believe that until "Wherigo for Dummies" book is published they are out of my league. I now know who they are so few and far between. Not like building a Geocache at all. Thanks for help

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Followers 1
  • Create New...