Jump to content

Just about had it !


Turtle Team
Followers 1

Recommended Posts

I couldn't wait to shell out the money to get an Oregon 400t just to play caching AND Wherigo. I wanted to experiment with building a cartridge. Played around and saved alright.

Wanted to load it up and BadImageFormat error. I've done everything in these forums.

 

I tried to install the 2.0 .Net software and it says doesn't install on 64 bit systems.

Tried older versions of Windows -nothing.

Installed here... uninstalled... install that way... nothing....

 

I can create, save but never load a cartidge.

What the heck.

I'm at my minds end here.

What a let down!

Someone get me working ..

 

Windows Vista Home premium ...

 

AAAARRRRRGGGGGHHHHH !

Link to comment

You may want to try a new version than 2.0. I remember reading some posts in the forum in which others installed 2.0 but it did not work and they had to install a version newer like 3.0 or 3.5. I can not remember the version they used but it is worth a try.

Link to comment

You may want to try a new version than 2.0. I remember reading some posts in the forum in which others installed 2.0 but it did not work and they had to install a version newer like 3.0 or 3.5. I can not remember the version they used but it is worth a try.

 

Have you tried reading http://forums.Groundspeak.com/GC/index.php?showtopic=212622

Updating the builder may sort your problems out. I still run an XP Virtual machine on my Windows Vista - the whole OS is geared around Wherigo building - bit of a hassle, but it works.

Link to comment

I am using 3.5 already.

Yes, i read those forums.

They didn't work.

That's what is really aggravating me.

I haven't loaded the windows 7.

Seems like too much to do just for the latest gadgets.

I would have thought since Wherigo is the latest experiment from Groundspeak, it would be a little more capable of running on the latest operating system.

My dreams were let down, darnit !!!

Link to comment

Try starting with a very simple cartridge. Nothing more than displaying a message when it starts up. No zones. Nothing. See if that works.

 

Make sure you are selecting the right player (Colorado, PocketPC) when you are creating the executable.

 

Start really small and build up.

 

Hope that helps.

 

Post a copy of your source code here. Lots of people are willing to help.

Edited by Tequila
Link to comment

A BadImageFormat exception usually occurs when the Builder doesn't recognize an image you're using in the cartridge. Are you only using small JPG images? Are all your images present in the cartridge's folder (i.e. did you delete one from the folder and not the cartridge)?

 

I agree with Tequila; if you'd like specific help, you may zip the cartridge directory (so we have both the code and images) and post it here. Alternatively, if you'd rather not post your code publicly, you can contact someone from the forum and ask for help privately. If you elect to go this route, I'd like for one helping you to post the answer, and what was wrong, to the forum so others can learn.

Link to comment

I haven't even tried anything yet. No images JPEGS, zone, nothing.

I just created the (i guess) the cover page with basic address and then it saves it (LUA). Then I close it. Try to open cartridge, click on the file and then BOOM ! Errors...

Shouldn't i be able to at least load a file of nothing?

Link to comment

Alright. I downloaded Whack a lackey.

Renamed to .zip. Unzipped.

 

Tried to open in Builder but BOOM.

The same thing again.

 

Error reading cartidge.

System.BadImageFormatException: An attempt was made to load a program with an incorrect format. (exception from HRESULT: 0X800700B)

At Groundspeak.Wherigo.ZonesEngineDll.InitializeEngine(Byte[]

szDeviceId, Byte[]szLogFolder)

at Groundspeak.Wherigo.ZonesEngine.ZonesEngineDll.InitializeEngine(String

strDeviceId, String strLogFolder)

atZonesAuthor.LuaFunctions.ReadLuaCartridge(String luaFileName)

at ZonesAuthor.frmMain.OpenCartridgeFile()

 

Copied for you.

So what does all that mean.

I am still hoping for an ' A HA' moment to come.

Link to comment

Installed the >NET framework (Had 3.5 - downgrade to 2.0?)

 

So where do i put the ..

C:\Program Files\Microsoft.NET\SDK\v2.0 64bit\Bin\CorFlags.exe" /32BIT+ "C:\Program Files (x86)\Groundspeak\Wherigo\Builder\WherigoBuilder.exe

 

Or what do i put, where?

Link to comment

I downloaded the builder.zip attachment at the bottom of another forum. installed and went to open whack a lackey and it said an unhandled exception has occurred.

When is Groundspeak going to make a version we can download then play with?

Instead of downloading the builder, downloading a program to dumb down the computer, modify it to work and then change something.

Will i ever get to create a Wherigo cartridge?

Like the forum states, I've just about had it. I get lead to the same forum topics and follow and nothing is working.

AAArgh!!

Link to comment
So where do i put the ..

C:\Program Files\Microsoft.NET\SDK\v2.0 64bit\Bin\CorFlags.exe" /32BIT+ "C:\Program Files (x86)\Groundspeak\Wherigo\Builder\WherigoBuilder.exe

 

Or what do i put, where?

If you have a 32-bit computer, this won't work. To tell, right click "Computer" on your desktop or start menu, go to "Properties", and look at "System type". If it says, "64-bit Operating System", then try what I'm suggesting. If not, forget it.

 

You'd have to run that line at the command prompt or make a batch file. For your convenience, I included with this post the batch file within a zip. Please check the file paths (by right-clicking the file and choosing "Edit") to make sure they match up with your computer. Also, as a point of personal security, never run a batch file from anyone without checking it first.

 

By the way, .Net 3.5 is the .Net 2.0 engine with a lot of new stuff thrown in. If you have 3.5, you should have 2.0.

WherigoFix.zip

Link to comment

Yes, i have 64 bit.

I know 3.5 is better than 2.0 but i thought i was loading to 'dumb down' the computer to run the forgotten-about-research&development Wherigo builder.

 

I tried the zip file file and now i got an unhandled exception occurring in zones.

 

I know I'm not this stupid with computers. But I just can't this working.

I am SOOOO disappointed.

 

I will uninstall everything i downloaded to get this to work including the stupid Wherigo builder and just forget about ever creating a cartridge.

I am so p!$$#d off.

 

I will just wait until things seem to get developed better.

 

So much for bringing Wherigo to the local area.

My nearest Wherigo is over 50 miles away.

 

I really appreciate everyone's help, but this has frustrated me enough.

Thanks sincerely to everyone.

Sorry, but I'll be back at the speed of development.

Link to comment

Alright, I lied.

I can't take it anymore.

can someone please explain to me EXACTLY, in a simple manner what to do, from the begining.

I have sat around this keyboard , going thru forums, getting to the same topics, doing the same things over and over, with no progress.

I played around with the builder, figuring that out. Learning from tutorials but now is the time for 'field practice' and i can't do it if i can't load what anyone saved.

 

What the heck is wrong with me (or the computer)?

Link to comment

First of all, please do watch your language and do maintain a tone of respect. I know you're frustrated.

 

Reading through this thread, it doesn't seem like anyone understands your situation all too well. All right, let's take it from the top and we'll both communicate better. Let's figure out where you are and what you are doing:

  • First off, you are able to run the Builder program, right?
  • You can make a new cartridge and create a few zones and stuff.
  • You save the cartridge and can still make changes.
  • You then close the Builder and, later, come back and try opening your cartridge.
  • The Builder errors with a BadImageFormatException.

Is this what is happening?

 

Please try this: Go into the Builder and create a new cartridge. Do not add zones or items. Save the cartridge. Now, go into the File menu and try opening the cartridge you just saved. It should still give you an error. That's fine; it should if I'm guessing right. From now on, I would like you to use that file to test to see if the Builder is working when I'm walking you through things. Since it doesn't have zones or anything else, that cuts down the possibility something else could cause the same problem. Understand?

 

I believe this is the same problem I had with my Vista 64-bit computer. Did you double-click and run the batch file I attached in my previous post (after unzipping it, of course)? If you did and you're still having problems, right-click on the file and click "Edit". Go to the end of the first line, press [Enter], and type "pause" (without the quotes). Save the file and close it. Now, double-click on the file. What does the black window say? It is important I know this so we can continue to solve your problem. If you know how to take and post a screen shot to the forum, that would be very helpful. If not, no problem; please type out what it says so I can see.

 

We'll get it working on your computer. If everyone else (with Windows) can run the Builder and you're the only one who can't, we can solve the problem. Just stay with it, communicate well, and we'll go back and forth until it is fixed. If anyone else in the community would like to help as well or has some suggestions or ways to clarify what I said, please feel free to contribute.

Link to comment

And if it's just one cartridge you're having problems with, please post that to the forum and we'll fix it. It seems, however, you're having that problem with everything. But if you can create a "blank" cartridge and open it, your problem is something else entirely, so you will definitely need to post your cartridge here for us to look over.

Link to comment

Sorry for the language.

I am frustrated.

 

But you are correct.

I can open the builder, do everything, save it .

When it comes time to load, OOPS.

I open a new cartidge (with no zones or nothing involved) save it.

Try to open and OOPS.

I did everything in this forum and others and still nothing.

Thank you for helping. I really do appreciate it.

 

This is from the 'black box'

 

'C:\Program' is not recognized as an internal or external command,operable program or batch file.

Link to comment

All right, now that the Builder works on your computers, let's see your creativity! Good luck, Team lite_rod.

 

Remember: of all the fancy programming tricks out there, the most important thing isn't programming or how you use the Builder. Instead, it's the ability to create an experience people truly enjoy and look forward to playing, whether it's an engaging storyline, educational walk, or freestyle game.

 

Above all else, have fun!

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 1
×
×
  • Create New...