Jump to content

triton upgrade trouble (serious help...Triton Bashers need not apply)

Recommended Posts

Has anyone sucessfully fixed a "Failed to create UDS Manager" error on a Triton?


I have a new Triton 400 and it worked great. I really liked it. It was rugged, easy to use, VERY accurate and in general lots of fun. It's my first GPS and I was surprised at how easy the 'basics' were to figure out.


Anyway, I connected to vantagepoint (my computer uses Vista 32 bit) properly after setting the connection setting to 'vantage point' in the triton unit. It then it said that I had Firmware 1.30 and that the 1.31 upgrade was available. I accepted the upgrade but partially through the upgrade, it suddenly stopped recognizing my Triton and said the GPS wasn't connected. Since it was stuck there, I cancelled the upgrade.


I then disconnected my triton, powered it off and on and got a "failed to create UDS manager" error. It wouldn't do anything else. So I pushed a bunch of random buttons, removed the batteries for a while, reinstalled them, pushed around on it and somehow I fixed it.


Then, I checked and it had reset the 'connectivity' to something else other than the vantagepoint option, so i thought that was the problem. So I hooked it back up and it was working again, then vantage point again said the 1.31 upgrade as available. Since I thought I had found the problem earlier, I thought it would work this time...so I accepted the upgrade again. The same thing happened, and now it just gives me the "failed to create UDS manager". I cannot figure out which random button things I did before that reset it.


So i called customer support and they had me do a reset (holding the escape, enter and power buttons at the same time). That didn't fix the problem so he wants me to send it in for repair.


I told the guy that I was a bit afraid to send it in for repair because I had heard many people having problems getting their repaired units back and I didn't want to send mine in and never see it again or have to wait 6 weeks without a GPS. He said he understood so he gave me a fax# and a case# and told me that if I faxed my proof of purchase to with the case#, they would send me a new Triton 400. He said I would then send mine back, but not until I got the new one first.


I am ok with that since that way I will get one before I give this one up, but it still seems stupid that I would need to send this back because of a software issue. It worked PERFECT before I tried to upgrade. I KNOW I fixed it the first time this happened but I don't know how!


Has anyone else had this error and fixed it themselves?


And please, Magellan bashers, I don't really need a bunch of replies of "Magellan sucks", or rants about their customer service. That isn't helpful, its really a broken record, and only makes people roll their eyes and wonder how much Garmin stock you own.

Link to comment

First: I don't have the answer you need.

You might want to try asking your question on tritonforum.com to see if anyone there might be able to help.

I have the Triton 400 and my computer is also running Vista 32 bit. I updated to 1.31 without any problems, so if it's any consolation, it is possible.

In order to get VantagePoint to see my Triton with Vista initially, I had to replace the MUD.sys file that VantagePoint installs, with the one that comes on the cd that came with the Triton. I'm guessing, but maybe that will help with your communication issue.

I'm sorry, but I don't how to clear your error.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...