Jump to content

Lowrance iFinder GO2 will not boot up


pictom

Recommended Posts

I purchased a Lowrance iFinder GO2 from ebay and used it for a while. I downloaded the Advanced Users manual to understand the unit.

 

The unit will turn on, meaning the primary GO screen shows up on the LED screen. When the unit was working, a "pop-up" warning message would come up on the screen and I had to press the Exit button to exit the message and start using the unit. The "pop-up" message screen never arrives and pressing the buttons seems to do nothing.

 

Any idea how to reset this unit or get it in working condition again?

Link to comment

any luck? my unit just crapped out today, just like yours did :o

 

i've had my unit for a couple of years, medium use, never abused or dropped. it's even kept inside an old see-through cellphone case while in use.

 

today i was out in 20°F for about 90mins - i've done this plenty of times. i am already used to the lag when switching screens due to the cold temps. i did notice the battery gauge was only half depleted.

 

i've put in a fresh set of batteries - still no boot up...

Edited by ginoe
Link to comment

No, I had no luck. Someone told me what buttons to press while booting it up but it did not work. I finally went back to ebay and purchased another GPSr. Different brand this time.

 

Right now I can not recall what the buttons were that I was to hold down while turning the unit on. Or where I got the information. I went to every iFinder forum I could find.

 

FOUND IT:

iFINDER GO2 Reset

 

Soft Reset (Does not delete GPS Data)

1. Turn unit OFF

2. Press and hold the PAGES key

3. Press and hold the PWR key

4. Release both buttons when the Status Page appears

 

Hard Reset(Deletes stored GPS Data such as Waypoints and trails)

1. Turn unit OFF

2. Press and hold the ZIN&ZOUT Keys at the same time

3. Press and hold the PWR key

4. Release both buttons when the Status Page appears

 

(and yes, I realize it says to release both buttons when you are supposed to be holding down three buttons)

 

PLEASE let me know if this helps you out and how long you held the buttons down.

Edited by pictom
Link to comment

i applaud your diligence - very cool! :o

 

i do remember reading the reset instructions somewhere but for the life of me, i couldn't find it.

 

the soft reset did not work, had to do the hard reset (held the 3 buttons for approx 5sec, the ifinder go splash screen appeared, then the alarm disclaimer screen).

 

she's behaving normally now, luckily i only had a handful of waypoints set - not too much of a hassle to re-input.

 

(interesting - a speedometer & odometer screen appeared. i've never seen it before. now that i switched away from it, i can't get back to it)

 

if you're ever by +41° 5' 29.44", -74° 4' 33.14" - i owe you a beer.

(i was a hair-trigger away from ordering a garmin online to replace this lowrance)

Edited by ginoe
Link to comment

I tried it again and it still will not work for me. But I am glad that my research paid off for getting you the right information.

 

Search the geocaching boards for a undocumented way to use those four exposed contacts to connect directly to your computer. That would be great if you could figure out a way to download directly to your GO2.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...