Jump to content

Help - My new etrex Legend is defective (?)

Followers 0

Recommended Posts

Sorry for the duplicate post but I figured more people read this section...


I just got a brand new eTrex Legend yesterday and took in on a field test today (and found my first cache!) My unit turned off a few times while I was walking on the trails with the unit hanging on my neck with the lanyard. After I discovered this problem, I tried giving the unit a light tap at the back while it was on and it turned off sometimes too. I figure the batteries/terminals are loose inside the compartment.


Is this still a common problem with the Legend? Is this a problem with all etrex models? If I exchange my unit for another Legend would I most likely encounter the same problem? Should I just look into another model or brand of handheld GPS?

Link to comment

Try updating the software before you take it back. My friend had a similar problem and the updated software fixed it. Currently most Legends are shipped with 3.2 and on July 30, 2003 3.4 came out that addressed the following issues:


icon_smile.gifUpdated French translations.

icon_smile.gifImproved WAAS/EGNOS satellite selection algorithm to select the satellite with the most beneficial corrections given the unit's current position. A unit will not use a WAAS/EGNOS satellite if the unit's current position is outside of a given WAAS/EGNOS satellite's service volume.

icon_smile.gifImproved external power detection.


The last one could be your issue. When external power is detected (as via a cigarette lighter) and then pulled off from external power, you only have 30 seconds before it shuts down. There is a message that says you must press a button within 30 seconds if you want to go to battery power. Evidently, Legends were having problems knowing whether or not they were connected to external power which is why they were shutting down so much. Give it a try, if it doesn't work, I would take it back! Go to:




Then select eTrex Legend. Hope this helps...I love my Legend. I upgraded as soon as I got it and before I used it so I don't know if it helped or not.


CraZy Cache! icon_cool.gif

Link to comment

Thanks for all the responses.


I did upgrade the software to 3.40 yesterday (before taking it geocaching this morning) since I was having that "external power loss" problem right out of the box. I don't think I get that message anymore. I was playing with my unit for 2 hours yesterday at home after the software upgrade without getting the shutting down message.


I really think it is a case of the batteries losing contact when it gets slightly bumped.


I'm kinda disappointed to hear that there is a possibility that all etrexs have this loose battery problem. I mean a outdoor hiking/navigation product like this should withstand slight bumps while hanging on a lanyard!

Link to comment

I was starting to have that problem after a year of pretty heavy use. I ended up giving my old Legend to my mom to use, and bought myself a new one (another Legend). I still think it's a great unit.


I would recommend returning it for a new one if the update to the firmware didn't solve the problem.




I thought I was wrong once, but I was mistaken.

Link to comment

I had the probelm, and was told about the battery connections. I just give them a little bend now and then, and it's fine. When I got it I got it from Circuit City and bought a lifetime warranty on it. If those battery terminals go I certainly hope it's covered. They said even if I run it over with my car they'll give me a new one. The warranty came not from Garmin, but from Circuit City.


Cache you later,



So many caches, so little time.

Link to comment

Ok, I have returned my unit during my lunch hour and I now have another new Legend. It is obviously from a different batch cause this one has an older software 2.38 compared to the first one that I got which had 3.20. I guess I got last years stock but still NIB though. I'll ugrade my software to 3.40 first thing when I get home.


Hopefully this unit does not fail me! If this one still has the power problem, I think I'll just get a refund from the store and get myself a GPS V Deluxe.


Just a side note: I got an email from Garmin tech support suggesting the use of Brand Name alkalines instead of "possibly smaller" generic ones. I used a pair of generic alkalines on the first unit (I don't see why I have to pay 2x for batteries that don't last 2x compared to generic ones). I'll use the same batteries on the new unit. If the problem happens again, I'll switch to the copper top before deciding to return the Legend again.


Thanks again for the replies!

Link to comment

Hi All,


I Have the Legend and I love it. I have not had any problems at all. I have noticed though (not just with the Legend, but with everything that takes batteries) that you get what you pay for. I prefer Duracell (no, I am not a salesman icon_wink.gif ). You will also notice that as the batteries "wear" a bit, your accuracy will drop.


Have a great day!!




Dive Down, Dive Deep

Link to comment

Never had the problem with my Legend, but my Vista has shut off on a few occasions. But I stress a few. Maybe 3-4 times in several hundred hours of use.


"You can't make a man by standing a sheep on his hind legs. But by standing a flock of sheep in that position, you can make a crowd of men" - Max Beerbohm

Link to comment

I noticed this problem with mine sitting on the dash while driving. I'd look and it would be off. It might be the connection, it's only done it 3-4 times in 40+ hrs of use.


Anyone know how to check which version I have? Is the upgrade easy? I haven't even thought about hooking it up to my Win2K machine yet. I've only had it 5 days now.




Firehouse16 (Dave)

Link to comment

The upgrade to 3.40 (Legend) is easy to do. takes a few minutes only and the download file is pretty small. I upgraded my replacement unit from 2.38 to 3.40 successfully. I even upgraded the first unit from 3.20 to 3.40.


You can check your software version by going to the main menu -> setup -> system -> (drop down menu) software version

Link to comment

i had this problem with my venture. i corrected it by putting a small piece of foil under the battery to create a tighter connection. It only did this when i was using nimh batteries (which are smaller), not when using alkaline. i heard somewhere that garmin will send you a spacer thing to put in the battery compartment if you call them.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Followers 0
  • Create New...