Jump to content

Condensation Fix?

Followers 0

Recommended Posts

I've had my emap for almost five years now. Last week I accidentally left the unit in the car, in the garage. Now, I don't know what was different with it this time compared to all the other times I've left it in a vehicle, but for some reason when it was brought in, there was quite a bit of condensation on the screen. I took the batteries out and let the unit dry, now for a few days. However, when I try to turn the unit back on, I can't get any indication of power, there's absolutely nothing on the screen. I was wondering if anybody has any suggestions. Thanks!

Link to comment

I would be inclined to turn on the oven for a little while to bring it up to 100 degrees or so. Turn it off and pop the GPS in to dry out some more. I did this with a cell phone that went in the drink, and it returned to serviceable use with no known damage.


(I'd also wait for a host of other comments so someone can advise you if this is one of the worst things you could do!)

Link to comment

I had a cellphone which took a dunking one time. Ended up taking the battery out and using a blow dryer on low heat & high fan speed to move as much air as I could around the circuit board to dry it out (it was also dead and came back to life after about 10 minutes of blow drying time).


If there is any gap which would give you access to get air moving in the board and display area with the batteries out, you might try it.

Link to comment

No offense to the previous poster, but I would skip the plastic bag and just put the gps on/over/near a radiator (assuming you're in a northern climate and the furnace is still running regularly).


Otherwise, find the nearest craft/hobby shop and pick up a quantity of silica gel sufficient to engulf the gps. NOW put the gps in a plastic bag w/ the silica gel and leave if for a couple of days untile the s.g. has absborbed the moisture.


Sort of like drying flowers, except completely different.

Link to comment

Not familiar with that unit but if it has screws holding the case together, I would loosen the screws and open the case slightly and use a hair dryer to gently blow warm air inside.


Also, the contacts for the screen may be corroded from moisture. This means opening the case and using a contact cleaner, sprayed on a Q-Tip to clean the contacts. (Use something like De-Ox-Id, cleaner and lubricant.) I did this with a cell phone that was dropped into water by my son. I poured alcohol on it, then blow dryed it. The Li ion battery shorted and was ruined but the cell phone works fine.

Link to comment

Hmmm...just a thought but a very safe way to -try- to remedy this would be to get a few silica gel dessicant packets (those little packets shipped with electronics that look sorta like sugar packets) and put the eMap along with the packets in a small ziplock bag for a few days. These packets absorb moisture...the trouble is trying to find them since they get tossed into the garbage along with any packing materials. :) Aside from this idea (which I'll admit is not a very good one :) ) the food dehydrator sounds good if performed with care...

Link to comment
Hmmm...just a thought but a very safe way to -try- to remedy this would be to get a few silica gel dessicant packets . . .


Actually, if you go to an arts and crafts store, you can buy a couple pounds of dessicant. People use it for drying flowers. My daughter had some once and I poured it in a plastic bag along with a pair of binoculars that had been under water after I flipped my canoe.


Of course the binoculars aren't electronic, but the dessicant did dry things out so the field glasses are usable again.

Edited by RubberToes
Link to comment

Thanks for the suggestions everyone. I don't know if I have the capability to dismantle the eMap, there aren't any screws holding it together...I think it's simply two halves glued to each other. I'm not too sure about that though. Either way, I'll probably give it a shot here. I would really really like to at least get it running so I can recover my coordinates from past adventures. We'll see how it works.

Link to comment

I'm also beginning to wonder if something else is the problem. The condensation from a couple days ago is now gone, at least from the screen. As far as I can tell, the unit looks completely normal to me. It just seems like something's bungled up inside and it's causing it not to power up. I don't know, I'm clueless with portable electronics. Maybe given its age, it was just time for it to die.

Link to comment

Sorry I'm not letting this post die. I just wanted to say that so far, still no luck on getting anything to show up on the screen. However, today I hit the power button and then the backlight button, and the light came on. So...I'm just curious if this might bring about any other suggestions now that this is happening.

Link to comment

Having the backlight come on is at least an encouraging sign that it's going through some kind of power-up. Do you get any beeps (assuming they were enabled before)? I'd also try hooking it up to a PC and checking if any communication is possible. It's possible that only the screen connection is messed up in which case either further drying or a reseating of the connector cable might bring it back to life.


BTW, a previous description of disassembly of an eMap indicated that the case is just snap-fit together, with no glue or other sealant. But both of mine still work so I haven't been sufficiently motivated to investigate.

Link to comment

If the unit has one, try a hardware reset. Moisture [ water ] on the circuit board can cause shorts that can confuse the brain [ computer ] inside. The unit may simply be 'thinking' that it is displaying something and it is not, or it could simply be frozen. The GPSr version of a PCs BSOD. :laughing: Simply turning it off and on won't fix this. You will loose any data in the unit, but you can't access it anyway with the unit in this state. :rolleyes:


It is also possible that the unit's firmware could have been corrupted by this same process. Try uploading the current version of the proper firmware.

Link to comment

Just wanted to add an update and thank everyone for their assistance and suggestions. Today, as i was digging around for some batteries on top of the refrigerator, I saw the emap sitting in the same spot it had been for the bast 2+ months. Just for kicks, I hit the power button expecting the same result. To my ecstatic surprise though, it turned right on, and functioned perfectly, as if nothing had ever happened. Betsy said "It must have just needed a vacation for a little while since we were using it so much." Either that, or it took that long to completely dry out, which is surprising to me.


Now I'm going to sound a little cynical, but I was actually a little depressed that it turned on, since I have spent the last week doing research on getting a new unit, and was probably going to commit to a new gpsmap 60cs. Would have been a sweet unit to have, but now I think I'll just hang tight with the tried and true emap.


Anyways, thanks to everyone for the help. I really appreciated all the suggestions!

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Followers 0
  • Create New...