Jump to content
Sign in to follow this  
Followers 4
Neo_Geo

Custom Waypoints Now In Mapsource Beta Update!

Recommended Posts

This only pertains to Garmin units which support custom waypoints, such as the color eTrex models, the GPSMAP 60C/S, 76C/S and the Quest.

 

Couldn't find anything in MapSource help to explain how the custom waypoint support feature works in MapSource. I spent a few minutes playing with it and here is what I've learned:

 

First of all, it will only work on waypoints that you upload into the new 6.5 Beta MapSource. If you open a file with waypoints that were created from an earlier version, then you're S.O.L. - they will still have the generic waypoint symbol.

 

That said, after you get things setup, you CAN edit the waypoints and change them to one of your custom icons and then save the file. You will have to save it as a "Garmin GPS Database Version 2 (*.gdb)" file. If you save it as a version 1 or *.mps file, you will lose the custom icon formatting.

 

So, after you install the new 6.5 Beta update, you send your waypoints from your GPSr to MapSource. At that point, if you look at your waypoints on the map, the custom ones will be represented by a familiar blue circle.

 

Here's the tricky part. When the customized waypoints are downloaded to the computer, new folders are created in the "My Documents" folder for whichever profile you're logged onto the computer as. In my case, having Windows 2000 and logged on as "Administrator", the waypoint icon bitmaps are stored in

 

C:\Documents and Settings\Administrator\My Documents\My Garmin\Custom Waypoint Symbols

 

In xImage, the custom waypoints are named "Waypoint Symbol xxx.bmp". For some reason, Garmin has named the corresponding waypoint filenames for the MapSource side as simply "xxx.bmp"

 

So, after I sent my waypoints to MapSource, I found the following files in my C:\Documents and Settings\Administrator\My Documents\My Garmin\Custom Waypoint Symbols folder:

000.bmp, 001.bmp, 002.bmp, 003.bmp, 004.bmp, 005.bmp, 006.bmp and 007.bmp

I only have 8 waypoints using custom waypoint symbols in my GPSr right now.

 

Each of those eight files were simple blue circles.

 

So I deleted those eight files, and replaced them with copies of my xImage "Waypoint Symbol xxx.bmp" files. Then I had to rename each of those files as simply "xxx.bmp".

 

Example: I copied my "Waypoint Symbol 001.bmp" from xImage and put it into C:\Documents and Settings\Administrator\My Documents\My Garmin\Custom Waypoint Symbols folder, and then renamed it as "001.bmp"

 

Now, when I open a MapSource .gdb file, that was created with data uploaded into MapSource AFTER it was updated with the new 6.5 Beta version, I see my custom waypoint images!

 

So if you have separate multiple user profiles created in Windows, each different user will have their own custom waypoints. If I save my waypoints in a new MapSource file and log off the computer - and then my wife logs on under her profile and opens that same MapSource file, she would see the waypoints I created, but with HER OWN custom waypoint symbol.

Edited by Neo_Geo

Share this post


Link to post

Neo Geo,

 

Thanks for the help - I've loaded ximage and it's working great.

 

The thread you pointed me to was EXTREMELY helpful.

 

I use a 60c in my job as a forester on the west coast of Oregon and will be making custom symbols specific to my work.

Share this post


Link to post

Huh? You lost me at "Hello".....

 

I have a V and Mapsource 6.5. Are u saying I can import custom symbols into my V?

If so, could someone explain in very simple lanquage how to do so? I'd be very grateful.

Share this post


Link to post

Quoting Neo_Geo's first line in his original post:

 

This only pertains to Garmin units which support custom waypoints, such as the color eTrex models, the GPSMAP 60C/S, 76C/S and the Quest.

 

So no, the GPS V is not supported.

Share this post


Link to post

I'm getting closer! I've implemented the procedure above and can now display my custom waypoint symbols on Mapsource 6.5. I've also loaded them to the Legend C thru ximage. They show in both the Mapsource and Legend C waypoint symbol tables. My problem now is in the transfer. Custom symbols will transfer from the Legend C to Mapsource but not from Mapsource to the Legend C. What I get is a default symbol (small marker square) that I get when I try to transfer a standard symbol from Mapsource that is not in the Legend C table (like letters and numbers). Any help would be appreciated - thanks

Share this post


Link to post
Custom symbols will transfer from the Legend C to Mapsource but not from Mapsource to the Legend C. What I get is a default symbol (small marker square) that I get when I try to transfer a standard symbol from

Firmware bug. Allegedly fixed in the current beta.

Share this post


Link to post

Downloaded beta version 2.11 for the Legend C. Everything is cool. ;):) Thanks to the contributors to this forum. I wouldn't have had a prayer of getting this to work without them.

Share this post


Link to post

probably a dumb question but dose the xImage program work on the gpsmap 60 I only the 60c/cs was listed and just wanted to be safe.

Edited by Mr-brownie

Share this post


Link to post

The custom waypoints and xImage came out before the GPS 60 And GPSMAP 60 came out.

 

If you see the following waypoint symbols on your GPS 60 or GPSMAP 60, then it is supported. If you don't have the blue circle icons, then custom waypoints are not supported on that model. If the custom waypoints are not supported, then you can still use the xImage program to get screen shots of your GPSr's display.

 

88f68977-ac20-4f5c-b6a1-b7ae081b30f7.jpg

Share this post


Link to post

Any way to accomplish this without ximage?

 

Is there a folder on the GPS memory card where these are copied to?

Share this post


Link to post

Any way to accomplish this without ximage?

 

Is there a folder on the GPS memory card where these are copied to?

Nope, that data is loaded to main memory, not the card.

Share this post


Link to post

wow, people reply to threads that have been dead for more than two years?

Edited by hogrod

Share this post


Link to post

To be fair, jchiar did exactly what we yell at nubes for NOT doing. He (or she) did a search, hit this thread, and tacked on a reply. It appears that jchiar is a Mac user who can't use ximage. He asked for a work-around, and got an accurate rely from the venerable Prime Suspect.

 

Nothing to see here, folks. Move along.

Share this post


Link to post

Just customised my mapsource icons - dead chuffed as could not figure it out.

 

Thanks! - found this forum post via google.

Not sure if they will work on my garmin vista or nuvi yet though.

Share this post


Link to post

Just customised my mapsource icons - dead chuffed as could not figure it out.

 

Thanks! - found this forum post via google.

Not sure if they will work on my garmin vista or nuvi yet though.

They won't. You need to use xImage to change the custom icons on your GPS unit.

Share this post


Link to post

I was able to get the custom icons into Mapsource 6.16.3 AND ALSO my 60CSx

 

The files had to be in a certain manner that is well documented, and I had to use the xImage program to get them into the 60CSx. The files were .bmp, 8-bit only, and magenta background to act as transparency. For xImage, the files were called "Waypoint Symbol 000.bmp" and ### up through 024. You could put them wherever you want, because xImage asks you for the location.

 

To get the same files into MapSource 6.16.3, the exact same files were put into C:\Users\USERNAME\Documents\My Garmin\Custom Waypoint Symbols - on my Windows 7 64-bit machine. On a Windows XP box, I think it would be something like c:\Users\USERNAME\My Documents\My Garmin\Custom Waypoint Symbols

 

If anybody wants a copy of the files that I used, let me know through a private message and I'll send em to you.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  
Followers 4

×
×
  • Create New...