Jump to content

Gsak (geocaching Swiss Army Knife)


ClydeE
Followers 15

Recommended Posts

GSAK version 3.04 is now ready for download.

 

If you haven't already done so, don't forget you can now register GSAK. Please see www.gsak.net/Register.htm for details.

 

Download here: www.gsak.net

 

Cheers

Clyde

 

Changes this release:

 

Offline HTML "Cache Master Index" tidy up for PDA screens

New option to sort waypoint name removing special characters

HTML location indices selection is now "sticky" and shows full detail of the location

You can now stop the logs showing in HTML view (Tools=>Option=Html, set Log Limit to 0)

Added option to automatically load generated file into MapSource.

Added "Total waypoints processed" to summary on GPX load

Added %lat, %lon, %gcid to special tags

Custom HTML tags can now use all the special %tags

HTML index by bearing now has N, NE, NW, S, etc... links

When column sort changes, cursor now stays on current waypoint (configurable)

UK post codes now available for setting centre points.

Fixed Ozi Explorer "show online" option problem

Added "Between" for distance filter

Added TomTom POI support

Added Basic GSAK Automation (more info: Help contents, "Miscellaneous Features=>Automating GSAK")

"Found by Me" index now only includes your finds.

Added "smart name" field override

"Existing Only" option on GPX/LOC file load to only update existing waypoints

"Update user flag" option on GPX/LOC file load to set the user flag if waypoint added/updated

Delete.txt file sync when Repair/Defrag done

Fixed incorrect UTM calculation

Changed default value of cachemate logs to 5

Added waypoint (using %tags) to cachemate dialog

Fixed sorting of Lat and Lon (Database=>Repair/Defrag to fix pre 3.04 databases)

Added register option

Converted filter.cds to dbf to fix filter stability problems

Added debug to gps send

Edited by ClydeE
Link to comment

I saw on the download page that this should take the place of GPXSpinner (among others). How do I do that with GSAK?

Sax

 

"File" "Export" "HTML"

Is that just for Pocket PC's or will that work with my Palm, too?

You will then need to convert the HTML to a format compatible with your palm.

 

I use Plucker. The desktop version. I think there are other programs out there.

 

If you do a search for plucker here in the forums I am sure you will get the full description of what to do.

 

BTW GSAK 3.04 is great! Clyde added some great features!

Link to comment

Hello Clyde,

I just dl'd GSAK 3.04 - thanks.

 

I was thinking of registering GSAK, for all the good reasons you provide.

 

Just wondering though. I've lived 51 years without resorting to taking out a paypal account, and I'm determined to live life without it. 'Specially when their privacy policy is two pages of 8pt font (you should tell them to just answer the straight forward questions "Will we spam you? Yes or no. Do we be acknowledge liability resulting from irresponsible management of information you provide? Yes or no").

 

Anywho. Is there another way to get you your loot? I'll mail you a check if it ain't too technologically obstructive.

 

Thanks again for a great product. Looking forward to being a registered user.

 

- Pen

 

PS - I paid Groundspeak by check. I think they're on to 'em. I'm sure paypal was the backer of the spammer on the grassy knoll!

Link to comment
Hello Clyde,

I just dl'd GSAK 3.04 - thanks.

 

I was thinking of registering GSAK, for all the good reasons you provide.

 

Anywho. Is there another way to get you your loot? I'll mail you a check if it ain't too technologically obstructive.

 

Thanks again for a great product. Looking forward to being a registered user.

 

-

Answered offline

Link to comment
I've been using GSAK with Cachemate and have been very happy with both. If I started using plucker, would I get pix as well? If not, is there a good way to do that?

Yes, you would get pics too.

I have a T3 and it is great to be able to see the page with pics and I have it set to also pull pictures linked in the cache description.

Pics that are in logs are not included (probably not in the .gpx file).

Link to comment
I've been using GSAK with Cachemate and have been very happy with both. If I started using plucker, would I get pix as well? If not, is there a good way to do that?

Yes you can get pictures with plucker - though it can take a bit of tweaking to get it right.

 

On the subject of pictures, don't forget you can include your own pictures in GSAK (this can be your own photos on your computer or the internet) these pictures will show up in all forms of offline HTML (including Plucker and Isolo)

 

How? - User notes!

 

The user notes section in GSAK supports HTML, so just add as many img tags as you like. Example <img src="file://C:\gsak\images\mypic.jpg">

 

To add a user note in GSAK, from the menu Waypoint=>Add/change/Delete notes... or just use Ctrl-T from the keyboard :D

Link to comment

GSAK 3.0.4 PROBLEM FOUND

 

The Mapsource product creates files with a .MPS extention. Unfortunately, this is also a media type, so GSAK when trying to "auto-start MapSource" starts up a player (RealPlayer, Windows Media Player, whatever) on the file!

 

Could you please explicitly run MapSource somehow vs. using the default file type handler?

 

-Jif

Link to comment
GSAK 3.0.4 PROBLEM FOUND

 

The Mapsource product creates files with a .MPS extention. Unfortunately, this is also a media type, so GSAK when trying to "auto-start MapSource" starts up a player (RealPlayer, Windows Media Player, whatever) on the file!

 

Could you please explicitly run MapSource somehow vs. using the default file type handler?

 

-Jif

Unfortunately this is one of the "Gotchas" I did mention in my previous post on this subject. The current fix would be to associate MPS files with MapSource.

Link to comment
Unfortunately this is one of the "Gotchas" I did mention in my previous post on this subject. The current fix would be to associate MPS files with MapSource.

MediaPlayer grabs the association again each time you change it to MapSource, at least on my system. I had to mess around with the options in MediaPlayer to tell it that MediaPlayer wasn't the default handler for any file format to get it to stop overriding my MapSource association.

Jon

Link to comment

Which Media Player is associated to MPS? I looked in my Windows Media Player and didn't see any. I launched it (WMP 9) and then click on Tools / Options / File types tab and don't have a MPS extension listed. If you do, you can likely just uncheck it there.

 

I'm sure other media players provide the same type of ability.

Link to comment

I am currently looking for work arounds for this, but not owning the software it is difficult for me to test out.

 

For Users that do not have MPS associated with MapSource (or it keeps getting overridden) I was thinking of allowing them to enter a path to the main Mapsource Executable (this would be sticky so they would only have to do it once). That way I could pass the GSAK generated file to the MapSource exe as a parameter and therefore getting over the association problem.

 

So GSAK would do something like "c:\Program Files\MapSource\MapSource.exe" "c:\some folder\myfile.mps"

 

What I don't know is if MapSource allows you to invoke it this way and if passing the file name as the first parameter will work.

 

Could someone give this a bash and let me know the results.

 

Thanks

Clyde

Link to comment

In case my mail gets delayed, I responded privately via email, but MapSource works the way you describe and has a registry entry to the MapSource directly if you want to trust that or use it as a basis.

 

Programs shouldn't hijack extensions unless you tell them to. If you don't need MPS for the media player but the program is taking it anyway, my guess is you can disable that option in the media player (and if not I'd say throw that media player out!!) and get on with the new option by associating it to MapSource and not having to worry again. I know I have WMP, RealPlayer, and QuickTime and nothing is hijacking my MPS file extension.

 

David

Link to comment

Version 3.04 difference in smart tags.

 

Playing around with the final version 3.04 I found out that the smart tags seem to be case sensitive now. At least in Street Atlas export. I had my export set up to do %Typ1%Con1 %Code %smart

 

After doing an export I saw "%Typ1%Con1 %Code GeneralG" on the map. Went WHAT?? It can't be broken! Changed all the tags to lower case and now works as it did before.

 

Just a heads up to others that may have the same setup.

 

Gary

Link to comment

Yes, please let the user enter a string for the mapsource.exe executable. Also, default the value of that string to the registry entry (if any) for

 

HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/CurrentVersion/App Paths/MapSource.exe

 

...but let us override it (if the registry is broken).

 

If you do the above, you'll probably work on 99%+ of the installations without the user doing a thing.

 

Depending on having ".MPS" go to MapSource is not as good, as it DOES seem to be used for media types by lots of applications.

 

Thanks!

 

Jif

Link to comment
Version 3.04 difference in smart tags.

 

Playing around with the final version 3.04 I found out that the smart tags seem to be case sensitive now. At least in Street Atlas export. I had my export set up to do %Typ1%Con1 %Code %smart

 

After doing an export I saw "%Typ1%Con1 %Code GeneralG" on the map. Went WHAT?? It can't be broken! Changed all the tags to lower case and now works as it did before.

 

Just a heads up to others that may have the same setup.

 

Gary

Bummer. You are right. It should NOT be case sensitive but obviously something I changed in 3.04 has made it so. Not hard to find and fix, but I will wait to see if there are any more "bugs" before rushing out a fix. If Anyone specifically wants a fix for this, send me a private email and I will provide a special build for you.

 

However as you have pointed out the immediate fix is to change your %tags to all lower case.

Link to comment
Version 3.04 difference in smart tags.

 

Playing around with the final version 3.04 I found out that the smart tags seem to be case sensitive now.  At least in Street Atlas export.  I had my export set up to do %Typ1%Con1 %Code %smart

 

After doing an export I saw "%Typ1%Con1 %Code GeneralG" on the map.  Went WHAT??  It can't be broken!  Changed all the tags to lower case and now works as it did before.

 

Just a heads up to others that may have the same setup.

 

Gary

Bummer. You are right. It should NOT be case sensitive but obviously something I changed in 3.04 has made it so. Not hard to find and fix, but I will wait to see if there are any more "bugs" before rushing out a fix. If Anyone specifically wants a fix for this, send me a private email and I will provide a special build for you.

 

However as you have pointed out the immediate fix is to change your %tags to all lower case.

No problem here! It was just a shocker to find it not doing what it did before. I should have used the same case anyway. I will admit that having both lower and upper case in my tags allowed me troubleshoot this one very quickly though, since the Uppers weren't translating and the lowers were. If it doesn't effect anything else,...just leave it alone. I have always been, "Don't fix it if it ain't broke". I don't consider this broke, just a matter of following the rules.

 

Gary

Link to comment

HELP!

I have sent my registration fee and received confirmation and a serial number back from Clyde. Where do I find the 'Help=>Registration'. I can't figure out where to register on line or in GSAK.

When I go to the GSAK web site all I can find is version 3.03 to download not 3.04.

 

I'm sure the solution is obvious, thanks in advance

 

Dan

Link to comment

Clyde,

 

I have a pocket query that is at it's maximum records(500). If I do an import with settings of - Existing Only, I get 500 waypoints processed and 499 waypoints updated.

 

I made the assumption that the 1 waypoint not processed may be a new one.

 

So, I then open the same file with settings of - Newer Only AND Set User Flag for Records Updated/Added.

 

I then show 500 Waypoints processed and 0 updated/added. I then filtered on User Flag for set and there were 0.

 

Where is that "one" record if it isn't new?

 

Just in case this makes a difference, I DID import that gpx into a seperate test database first to see how many records it had, then deleted them. I then went through the above steps on my default database that I use all the time.

 

Gary

Link to comment
HELP!

I have sent my registration fee and received confirmation and a serial number back from Clyde. Where do I find the 'Help=>Registration'. I can't figure out where to register on line or in GSAK.

When I go to the GSAK web site all I can find is version 3.03 to download not 3.04.

 

I'm sure the solution is obvious, thanks in advance

 

Dan

The website is http://gsak.net/

 

5 paragraphs(some just one liners) down is

Download Version 3.04 here

 

Click on the link and it should give you the download box.

 

If you have been to the site before, you may want to hit "Refresh" on your browser. It may be pulling the old page up from your history file.

 

Gary

Link to comment
HELP!

I have sent my registration fee and received confirmation and a serial number back from Clyde. Where do I find the 'Help=>Registration'. I can't figure out where to register on line or in GSAK.

When I go to the GSAK web site all I can find is version 3.03 to download not 3.04.

 

I'm sure the solution is obvious, thanks in advance

 

Dan

Registration is only available in 3.04

 

Sounds like the GSAK main home page is being "cached" somewhere for you (perhaps by your ISP) and you are getting the old page.

 

If you are using Internet Explorer, Try holding down the shift key then click on the refresh button. This seems to fix 90% of problems I have seen of this nature.

Link to comment
Clyde,

 

I have a pocket query that is at it's maximum records(500). If I do an import with settings of - Existing Only, I get 500 waypoints processed and 499 waypoints updated.

 

I made the assumption that the 1 waypoint not processed may be a new one.

 

So, I then open the same file with settings of - Newer Only AND Set User Flag for Records Updated/Added.

 

I then show 500 Waypoints processed and 0 updated/added. I then filtered on User Flag for set and there were 0.

 

Where is that "one" record if it isn't new?

 

Just in case this makes a difference, I DID import that gpx into a seperate test database first to see how many records it had, then deleted them. I then went through the above steps on my default database that I use all the time.

 

Gary

I did a similar test and the numbers matched exactly, so I am curious to know why you are 1 out.

 

First thing you could check is if that 1 cache is in your permanent delete list.

 

If not then I can't see why the numbers don't match exactly.

 

So I can get to the bottom of it could you please:

 

1. Zip up all the files in the database you are loading the GPX file into (this is a folder with the same name as the database and it is located in the "data" folder of the install folder of GSAK

 

2. email me this zip file, the GPX file you are loading, and your GSAK.ini file (which is in the install folder of GSAK)

Link to comment
fantastic - now i can see the date i found the caches......apart from 3 caches (the first ones that i found). Filtering on found caches shows the caches, but the found by me date is blank. Ideas?

The "found by me date" is not included in the GPX files from geocaching.com

 

GSAK overcomes this by interrogating all the logs in your database looking for your found logs - it then uses the date in the found log as the "found by me date"

 

As your first found caches are probably quite old, I suspect you do not have the find logs loaded into GSAK and that is why there is no "found by me date"

 

You can of course update this date manually via Waypoint=>Edit

Link to comment
The "found by me date" is not included in the GPX files from geocaching.com

I just saw some without dates and it seems the Found By Me date isn't displayed in the grid if the cache is marked as archived. It's there when I click on Edit to see the details so the date has been entered.

 

Is this an issue or to be expected? I also have some marked as archived which are showing the dates, but all the ones that aren't showing the dates are archived.

 

EDIT: SORRY!!! Wrong column. I was looking at Last Date Found. Sorry!!! It seems to be working fine!!!!!!!

Edited by Team DEMP
Link to comment
The "found by me date" is not included in the GPX files from geocaching.com

I just saw some without dates and it seems the Found By Me date isn't displayed in the grid if the cache is marked as archived. It's there when I click on Edit to see the details so the date has been entered.

 

Is this an issue or to be expected? I also have some marked as archived which are showing the dates, but all the ones that aren't showing the dates are archived.

Now that does sound rather strange - and I can't see any in my database that behave this way.

 

Could you please:

 

1. Zip up all the files in the database you see this behaviour (this is a folder with the same name as the database and it is located in the "data" folder of the install folder of GSAK

 

2. email me this zip file, and your GSAK.ini file (which is in the install folder of

GSAK)

 

Let me know the codes or names of the caches that you have this problem on

 

Thanks

Clyde

 

***Woops - forget it. I din't see your updated post until I made this one ***

Edited by ClydeE
Link to comment

Re: registration

I tried 'refresh' and 'shift refresh' - no joy,

I deleted my history file, cookies etc - no joy.

Is there a way to force my ISP or wherever the old page is being stored to refresh?

 

I realise this is a provider problem, not GSAK but I appreciate your help.

Thanks

Dan

Link to comment
Clyde,

 

I have a pocket query that is at it's maximum records(500).  If I do an import with settings of - Existing Only, I get 500 waypoints processed and 499 waypoints updated.

 

I made the assumption that the 1 waypoint not processed may be a new one.

 

So, I then open the same file with settings of - Newer Only AND Set User Flag for Records Updated/Added.

 

I then show 500 Waypoints processed and 0 updated/added.  I then filtered on User Flag for set and there were 0.

 

Where is that "one" record if it isn't new?

 

Just in case this makes a difference, I DID import that gpx into a seperate test  database first to see how many records it had, then deleted them.  I then went through the above steps on my default database that I use all the time.

 

Gary

I did a similar test and the numbers matched exactly, so I am curious to know why you are 1 out.

 

First thing you could check is if that 1 cache is in your permanent delete list.

 

If not then I can't see why the numbers don't match exactly.

 

So I can get to the bottom of it could you please:

 

1. Zip up all the files in the database you are loading the GPX file into (this is a folder with the same name as the database and it is located in the "data" folder of the install folder of GSAK

 

2. email me this zip file, the GPX file you are loading, and your GSAK.ini file (which is in the install folder of GSAK)

Problem solved, or should I say the mystery is solved.

 

I re-loaded the gpx file into my default database with "Flag updated records" and "newer" checked.

 

I then exported the "flagged" records to a gpx test file. I then created an empty test database and imported the test.gpx file.

 

I then imported the gpx file I seemed to be having problems with de-selecting the "flag updated records".

 

Doing a filter on "Not Set" showed me the offending waypoint.

 

Went back to my default database, found that waypoint, and saw that I had it flagged as "Stops GPX/LOC from overriding data".

 

So, bottom line is that it is all working perfectly,...just the user needs a little tweeking once in a while.

 

Thanks!

 

Gary

Link to comment
its marked some of the caches that I found on the same day as found by me....

What is the date in the 'last UPDATE' column for the caches that are not showing the 'found by me' date? If it is not the same as the other caches in the area then you may need to run a .gpx that includes the caches you found.

 

If when you go online to gc.com and find that those caches have been archived then you will need to manually click on the icon to download the .gpx file on that cache page and import it.

 

When I moved everythign over to GSAK I downloaded all these archived caches' individual .gpx files into a temp directory then ran GSAK import on the 80 gpx files in that directory

Link to comment
fantastic - now i can see the date i found the caches......apart from 3 caches (the first ones that i found).

Jeez - I have so many that are blank. Time to go and fix those!

Wow, that took a while! Kind of makes you wish your found date was a field in the GPX file!

Link to comment
Version 3.04 difference in smart tags.

 

Playing around with the final version 3.04 I found out that the smart tags seem to be case sensitive now.  At least in Street Atlas export.  I had my export set up to do %Typ1%Con1 %Code %smart

 

After doing an export I saw "%Typ1%Con1 %Code GeneralG" on the map.  Went WHAT??  It can't be broken!  Changed all the tags to lower case and now works as it did before.

 

Just a heads up to others that may have the same setup.

 

Gary

Bummer. You are right. It should NOT be case sensitive but obviously something I changed in 3.04 has made it so. Not hard to find and fix, but I will wait to see if there are any more "bugs" before rushing out a fix. If Anyone specifically wants a fix for this, send me a private email and I will provide a special build for you.

 

However as you have pointed out the immediate fix is to change your %tags to all lower case.

Thanks for this post GLM - I just noticed the same thing in the Streets&Trips export. It always pays to have a look here when a person runs into problems. :):)

Link to comment
GSAK overcomes this by interrogating all the logs in your database looking for your found logs - it then uses the date in the found log as the "found by me date"

OK, how does gsak know my handle? I downloaded each of my finds (gpx) and gsak shows the correct ones as 'found' but does not list 'date found by me' even for caches I found 2 days ago. What am I missing?

Help please :)

Link to comment
fantastic - now i can see the date i found the caches......apart from 3 caches (the first ones that i found).

Jeez - I have so many that are blank. Time to go and fix those!

Wow, that took a while! Kind of makes you wish your found date was a field in the GPX file!

Sounds like a request we might want to post over on the Geocaching Web site forum.

Link to comment

Thanks for a great product!! :) What I find amazing is your time spent helping us with questions here.

I have a garmin 60c and upload via a USB cable. Are there any plans for allowing direct uploading from GSAK to the GPSr via USB in the future?

The 60c has its own geocaching page, does anyone know how to load waypoints in the GPSr as geocaches? Is it worth the effort?

Link to comment
OK, how does gsak know my handle?

 

What am I missing?

Help please  :)

Tools/options/general

 

has a place to put in your handle.

 

(And yes, Clyde can send my "secondary support staff" payment.) :)

Yes, GSAK uses the "Method for matching placed/hidden" caches to track down your found logs as well. There are 3 methods to use and you can find help on this subject here

Link to comment
Thanks for a great product!! :) What I find amazing is your time spent helping us with questions here.

I have a garmin 60c and upload via a USB cable. Are there any plans for allowing direct uploading from GSAK to the GPSr via USB in the future?

The 60c has its own geocaching page, does anyone know how to load waypoints in the GPSr as geocaches? Is it worth the effort?

Yes, but when it will happen is very much dependant on USB users themselves.

 

For more information please see my post in the previous GSAK thread here

 

I have now donated twice to this project and will continue to do so while the GSAK registrations come in, but it is really up to the USB users if you want it to happen.

 

As for the Geocache icon, you can set that now in GSAK. Both the export to to MapSource and to your GPSr (if you have a serial cable for your 60c) support changing found/not found to the corresponding geocaching "treasure chest" symbol. So for now in your case, just export to MapSource (changing the icons as you would like them) then you can upload via USB to your GPS.

Link to comment
Went back to my default database, found that waypoint, and saw that I had it flagged as "Stops GPX/LOC from overriding data".

Might not be a bad item to be listed in the 'import box' along with the other counts of what was/wasnot imported?

 

waypoints ignored: xx

I must admit, I completely forgot about that possibility - a good reason to include this count in the final summary. That way you should always be able to reconcile your GPX load.

Link to comment
Re: registration

I tried 'refresh' and 'shift refresh' - no joy,

I deleted my history file, cookies etc - no joy.

Is there a way to force my ISP or wherever the old page is being stored to refresh?

 

I realise this is a provider problem, not GSAK but I appreciate your help.

Thanks

Dan

OK, I would prefer users go to the site to download but as you are obviously still having problems you should be able to download from this direct link here

Link to comment

As I explore GSAK further, I'm wondering if someone can help me enter in some custom URLs for LostOutdoors.com? I would like to access http://www.lostoutdoors.com/newmap.html, and be able to do one click mapping of both topo (1800x1800, 2m resolution) and NAAP image (1800x1800, 1m resolution). Actually I know that would be two separate operations, but hopefully you know what I mean.

 

I'm not up on the smart tags or how to cause the necessary fields to be automatically entered. Probably easy and simple, but then I always say, nothing simple ever is.

 

Thanks,

-Pen

Edited by Pen&Card
Link to comment
As I explore GSAK further, I'm wondering if someone can help me enter in some custom URLs for LostOutdoors.com? I would like to access http://www.lostoutdoors.com/newmap.html, and be able to do one click mapping of both topo (1800x1800, 2m resolution) and NAAP image (1800x1800, 1m resolution). Actually I know that would be two separate operations, but hopefully you know what I mean.

 

I'm not up on the smart tags or how to cause the necessary fields to be automatically entered. Probably easy and simple, but then I always say, nothing simple ever is.

 

Thanks,

-Pen

Not sure if these are the exact ones you want but YeOleImposter posted his URL's for LostOutdoors in the old GSAK thread here

 

It should at least give you some idea and get you started

Link to comment

another hopefully easy to fix bug is in (uK) postcodes. if you don't enter them in upper case it complains about postcode not being in the database.

Can we also have the ability to enter postcodes into the boxes, similar to code search, name search etc. That would give a quick, one-click filter option.

Link to comment
Guest
This topic is now closed to further replies.
Followers 15
×
×
  • Create New...