Jump to content

Gsak Choked!


Recommended Posts

That is a biggee. I combined the four or five dat files for the counties around be and ended up with a database which exported a gpx file a little of 11MB. I was able to re-import that file, but it took nearly two minutes for GSAK to sort it out.

 

Unfortunately, I don't think we'll learn anything about limits until Clyde (GSAK's author) gets back from a vacation. In the meantime, you could try as an experiment to break the gpx file down into smaller chunks with a text editor and see if you have better luck taking smaller [kilo]bites. :D

Link to comment

Sounds like you are planning a fun trip - and benchmarks to boot B)

We will be going to Victoria, BC for our 25th Anniversary - so will do some caches but alas - no benchmarks :D

 

YeOleImposter (proud to have found a pen&card that was given to my wife last year).

 

<offtopic>

PS. If you can get away from WallyWorld on Thursday drop over to the Tri-Cities for our GeoCachers Get Together - maybe we can have a discussion for those of us that also benchmark.

 

East Cascades Geocaching Society Meeting

 

</offtopic>

Link to comment

We've thought about getting over to one of your get-together sessions, but it never coincides with a moment of adequate energy! One of these days we will though - maybe even this Thursday.

 

Text editing the dat file is probably beyond my talents, but then again, I've never tried. Only took me two weeks to master the basics of going paperless, and as you can tell, still working the bugs out on that.

 

The only reason I went after the Anchorage dat file in the first place is to find out how many benchmarks we drove by when we placed our cache "Mostly Walla Walla" in the Alaska interior (gad, is there an abbreviation for benchmarks other than BM? I just have a hard time writing about BMs!).

 

Now it's a puzzle and challenge to get that data!

 

- Pen

Link to comment
This morning I dl'd the NGS benchmark archive for Anchorage AK file (ak005.dat) from http://www.ngs.noaa.gov/cgi-bin/ds_archive.prl

 

The dat file was 20,335kb, and after being spun by bmgpx, it was a 29,553kb GPX file. That's a whopper, no doubt about it :lol:

 

GSAK choked when I tried to set up a new database for this file. Is there a known file size limit for GSAK?

 

Thanks, Pen

In theory the maximim file limit for GSAK is 1 billion records, so it shouldn't be a problem.

 

Not quite that much but I have a couple of users with 50,000+ waypoints without any problems.

 

Try breaking the the GPX file down into smaller chunks as it may be a problem with an individual record and we can then try to pin point the problem.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...