Jump to content

Gpxview Problems

Followers 1

Recommended Posts

Hello fellow cachers, we are looking for some advice to help solve our problem.


I own a COMPAQ PocketPC which has always served me well for running pocket queries. I simple receive the .gpx files, send them to the PocketPC and open them in GPXView. Unfortunately, out of no where, I began receiving a new message when I go to open the files in GPXView on the PocketPC. It tells me the "Load Failed".


I tried completely uninstalling and reinstalling the PocketPC and all files on it. I even did a hard reset on the system. Still, it will not open the pocket queries.


Is anyone else having this same problem? Does anyone know how to fix the problem? Any suggestions out there?


It does not seem to matter if the files from the pocket queries are in zip files or not. No matter what I try, I cannot get them to open.


I hope someone has an idea to help us with our problem!


The above post was placed in the "Getting Started" forum and has had very few responses. I thought this forum might be a more appropriate place to ask the question.


I am having the exact same problem with GPXView. Old PQs, received more than 2 weeks ago, open just fine. Any new PQs, even those I have sent regularily whose settings I haven't touched for months, will sync, but when I try to open them in GPXView on the iPaq 3955 I get a "Load Failed" message.


I downloaded and installed GPXSonar and the very same pocket queries that won't open in GPXView open just fine in GPXSonar.


Ok, I LOVE my GPXView and I want it to work again. Anyone have any ideas on what I can do? I've even tried upgrading to the latest verson of GPXView and is doesn't help.


I'm all ears!! :(

Link to comment

It would seem that way, however, GPXSonar has oddball characters that appear in the cache page sometimes, often when parking coordinates are given. It looks like hieroglyphics. It doesn't happen on every page or around all numbers but it happens often enough to be a bit disconcerting when you are attempting a difficulty multi and every number counts! The other features of the program are great though!


On a different note, I found a post in the GPXView page that indicates this "Load Failed" has happened before when odd characters are imbedded in a cache page. The site owner had the cacher send him the problem query to determine which cache(s) were the problem and was then going to contact the cache owner to fix the page.


I've registered on the page but as of yet have not been "accepted" as a member of the GPXView forums. As soon as I am I'm going to post to them and see if he will look over my problem queries and see what he can find. I did try this. I made a pocket query of my own 20 caches and synced to my PDA. I was able to open the PQ in GPXView with no problem, hence I can only deduce that the problem is definitely with one of the PQ files!!

Link to comment

SerenityNow ...


It would seem that way, however, GPXSonar has oddball characters that appear in the cache page sometimes


That's not an issue with GpxSonar but with Pocket IE. In order to fix it, try this in PIE:


Tools \ Options \ Advanced -> Unicode UTF-8


You should never see funky characters after that.



Link to comment

Unicode is a nightmare. I wrote a program that imported GPX files and I had a lot of problems with Unicode. In the end, I just reencoded the entire file into the windows-1252 code page. After that, everything was fine. However, reencoding may not be easy to do in a Pocket PC program...

Link to comment



Universal Alphabet UTF-8. Is that the same thing?


For all intents, yes. I think you must not have regenerated the cache pages afterwards though...


Switch to UTF-8 (whatever flavor is available) in PIE then close it and regenerate the same cache page. Everything should be ok then.


Internally, all cache pages generated by GpxSonar are UTF-8 encoded just like the GPX data is.


I even specify <META HTTP-EQUIV="content-type" content="text/html; charset=utf-8" /> in the cache pages but I think that PIE ignores meta tags.


Let me know how that goes.

Link to comment
Switch to UTF-8 (whatever flavor is available) in PIE then close it and regenerate the same cache page. Everything should be ok then.


Well, I wish I could say that worked but it didn't. **sigh**. I completely closed out of PIE and when I clicked on GPXSonar and then the PQ, the ones with the funky characters still had their funky characters! Maybe I'm doing something wrong here. Should I delete the PQs from the PDA and then resync them in? Would that make a difference?


As always, suggestions are much appreciated!

Link to comment



Should I delete the PQs from the PDA and then resync them in? Would that make a difference?


Nope, that would not make any difference. GpxSonar regenerates the cache pages on demand according to the content of the GPX file.


Can you zip up that GPX file and email it to me at fabien_royer at hotmail.com? In your email, please add some context so that I can know what I'm looking at :mad:




Link to comment



Ok, I've checked out your file using v1.2. The only cache that contains funky characters is : GCJ30Z. None of the others that you pointed out in your email to me had them.


The garbage characters in the Gpx file for that cache are:




GpxSonar removes the characters from those sequences and leaves the rest which is why you see 'weird' x0; characters. But at least you can load the file.


Such things should -never- be present in XML files in the first place. I make an effort to eliminate the truely illegal garbage but only partially. I'll see what I can do in the future to totally remove such things.


All I can say is that crap in GPX files happens... Pocket Queries or even Cache Pages are not perfect. Fortunately it's not too frequent.


All in all, I don't think you should sweat this too much.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Followers 1
  • Create New...