Jump to content

Hey! I got a Garmin etrex Legend for Christmas!


Recommended Posts

Hey, I just opened up Santa's present, and I got Garmin!!! yay! I am a little confused on how to work it though. I have read the whole manual and i can not seem to understand how to enter a destination, I would appreciate it if someone could help me. I can't wait to go out and try it with my dad. Thanks! icon_smile.gif


"Only two things are infinite, the universe and human stupidity, and I'm not sure about the former."

- Albert Einstein (1879-1955)

"Do, or do not. There is no 'try'."

- Yoda ('The Empire Strikes Back')

Link to comment

To manually input coordinates you need to hold the

"Enter" button down for a few seconds. Then the "Waypoint" screen should appear. Now scroll down to the bottom where you see the coordinates. When they are higlited press the enter button again. Now you should see the coordinates iin another little window. Fron here use the scro;; feature and the Enter button to change the coordinates to what you desire.


Hansel & Gretel

Link to comment

>I have read the whole manual and i can not seem

>to understand how to enter a destination, I

>would appreciate it if someone could help me.


You should have received a Quick Start brochure with your Legend. Follow step 8 to enter a location or...


From any screen, press the Click Stick straight down and you'll get the Mark Waypoint screen. Use the Click Stick to scroll to the Location box and enter your co-oridinates using the data entry keyboard.


You can then either press OK to make the waypoint or you can select GoTo and start heading toward the new waypoint.


To bring up a waypoint after you've entered it, press the Find button and select the waypoint that you want to go to.

Link to comment

You might also want to update your eTrex Legend firmware -- there are some substantial upgrades that are a big improvement to the unit.


To find out what version of firmware you have go to the Main Menu and select Setup.


Click on the submenu (one click to the left with your Click Stick and select Software Version. The latest version is 2.50 -- if you have anything less than this, install the new firmware.


Go to the Garmin website at the following page:


eTrex Legend Firmware Update Page


This will take you to the latest firmware upgrade. Follow the instructions on the page.


Hope this helps.

Link to comment

Thankyou so much! I figured it out with all of your advice, I am planning on going to try it out with my dad in an hour. I really appreciate all of your help. Happy Holidays!


"Only two things are infinite, the universe and human stupidity, and I'm not sure about the former."

- Albert Einstein (1879-1955)

"Do, or do not. There is no 'try'."

- Yoda ('The Empire Strikes Back')

Link to comment

I got one too! These must be all the rage this Christmas...


I tried updating my firmware, but the update executable is not detecting my GPS. I made sure it was plugged in securely and all that. I checked the BIOS (set to PnP compatible OS, with IRQ & I/O addys assigned to the COM ports automatically) and it was ok. Is there some additional software that I need? Or is this a problem that I will have to talk to Garmin about? Oh, btw, "simulation mode".... is that where you tell it "Use with GPS off"? Because they say refer to your manual, but the manual never mentions "simulation mode". Anyway, I've tried tons of different ways and nothing works.


While I'm at it... I added a couple of waypoints to my GPS (like my house, for example). Then I cleared the path I had recorded while driving around. My waypoints were gone. How do I avoid this? (or am I nuts?)


ok last thing icon_smile.gif To find coords for an address, I have to go to terra server, find a photo, click Info, and then it gives me decimal coords which I translate on jeeep.com Is there an easier way to do this? cause my way is annoying icon_smile.gif



Link to comment

WOW - I got a Legend for Christmas as well, and REALLY love it - however, I am totally new to this too - SO - I don't have anything else to compare it to -


From what I can tell, have read, and my own limited experience though, this appears to be a pretty solid unit - 2 caches searched and found so far - I was able to get w/i 5' to 8' of the objective both times, so I figured that was pretty good...


Have a great New Years everyone...



Link to comment

Not as cool as getting it as a gift, but I did get it for myself for Christmas. All previous caches I found were with a map. I downloaded every Waypoint in the area and all of the Benchmarks withing 10 miles. All day I have checked my nearest waypoints and swung by to find 2 benchmarks and 1 new cache. It had me within 8 feet of the cache. Walked straight up to the two benchmarks. The Icon has yet to stay on the basemap road, is there a calibration?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...