Jump to content

Magellan Platinum "driver"?

Recommended Posts

I run a Pentium II with Windows '98. I initially used the original serial port to download/upload info. from EZGps and Mapsend between the PC and the Magellan Platinum. It worked just fine.

I recently installed a dual port USB card in a PCI slot to support a PDA. That action disabled my factory serial port, assigning that Com port to the USB card I/O.

So I bought a USB serial adapter cable for the Magellan, figuring I''d use the remaining USB port for the GPS receiver interface. PDA in one slot, GPSr in the other; sounded reasonable to me.

But, eventhough the PDA installed just fine, Windows recognizes the GPSr as a new piece of hardware and wants to install a VIVO90 Audio driver to support it. I don't believe that's going to do much to make the devices compatable, and I haven't the slightest idea where to find the proper driver or whether I even need one for it.

Anybody got an idea where I might find and download the correct driver to affect this interface between the PC's USB port and the GPSr please?

GPSr software doesn't include any drivers. :D


edit to correct the grammar (at least some of it)

Edited by gallahad
Link to comment

You shouldn't need a driver for the GPSR, although you might need a driver for the USB-Serial adapter which should have come with it or can be downloaded from the manufacturer's web site. My USB-Serial adapter (Belkin) required a driver under Windows 2000 and XP.


It's been a while since I've used Win98, but I think you can tell it to not install the erroneous driver when that pop-up comes up, or go into the control panel and delete the device so it can be re-detected properly.


My memory is fading here...I'm trying to recall if it was Win95 or Win98 that had "issues" with USB support.

Link to comment
You shouldn't need a driver for the GPSR,...

Thanks for the guidance. The USB card is a Belkin and it installed without a hitch. The Pocket PC runs beautifully (GPXSonar, Mapopolis, etc.) using the USB port but for some reason, EasyGPS just can't find the GPSr. If and when I figure this out I'll post something on my website - maybe it'll save someone else the frustration.

System continues to report "Cannot open serial port COM1" and suggests that it may be occupied by another serial device - but there's nothing connected to either USB port except the GPSr and no software running to support any other serial device.

Maybe I'll try jumping into the BIOs and see if I can foul those up. :D

Link to comment

My serial USB adapter is on com5 for some reason I'll never figure out. Your computer is looking for a driver it shoudln't need. The entire drive should of just went into the USB/Serial adpater. It seems like the trick is going to be to convince your computer to not install a driver and use the USB/Serial one like it should be doing.

Link to comment

This "driver" thing is confusing. I agree that a "driver", other than the files that were used in setting up the Belkin USB BusPort, shouldn't be necessary. But Magellan includes a CD with a driver with its USB to Serial Cable Adapter and the system does ask for it when the USB adapter is connected to the PC. But installing the driver, as directed by Magellan's instructions, doesn't change a thing. EasyGPS still looks for the GPSr at COM1 (which is the DB9 serial port that came with the original system and was used exclusively before the USB card came to live here). Mapsend's GPS Settings checks COM1, 2, 3 & 4 it can't find the GPSr either. The ActiveSync software that was supplied with the ViewSonic pocket PC found the USB card and linked to the pocket PC without a hitch. In fact, I can switch COM ports with impunity for the PDA and the ActiveSync finds it no matter where I place it on the system.

I have a complaint filed with Magellan support. Let's see what they have to say about the issue.


edit correcting typos......

Edited by gallahad
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...