Jump to content

How do I get em to talk?


Recommended Posts

See what protocol you are using with your Etrex. If you are using a Garmin protocol (the default for the garmin units) you may have to change your computer software protocol to whatever the Sporttrac Pro uses

NMEA is a common universal protocol but Magellan may have another protocol that accesses more of your Sportrac Pro features...


You can find the protocol in use under the menu settings somewhere under setup...


It is possible the Sportrac Pro might have defaulted to "none" for the protocol, which means it wont even try to communicate.

Link to post

I have had to move my serial cable to the other port. Even after it was already working on the first one.

Make sure the Baud rate is the same with the new GPSr and the software.

Silly question, are you using Magellon software. I have a Meridian. Only Map Send Software loads maps.


Preparation, the first law to survival.



Link to post

What software are you trying to use? Possibly the settings within the software need to be changed. Garmin and Magellan both have proprietary formats that are incompatible and the software needs to be using the correct one. Or using a common format like NMEA.


Another thing to consider is that no other programs are running that use the serial port. For some reason many programs won't relinquish access to the port even if they're not actively using it. So the port may be blocked.


I'm not lost!

I just don't know where I am.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...