Jump to content

Meridian "Blue Spots"


Stunod
Followers 1

Recommended Posts

My Meridian Platinum developed "blue spots" on the screen that could only be seen when the backlight was on. It looked like a fingerprint or smudge on the screen.

 

Magellan has identified a problem with the backlight assembly and corrected it. It seems there was some sort of contamination during production of the backlight sub-assembly. They are now producing units with a redesigned backlight that will not be subject to the same problem.

 

I contacted Magellan thru their website and received an RMA number to return the unit. I sent it in via UPS last Monday and I received a NEW unit today (Monday - 1 week turnaround). They also threw in a windshield mount, cig lighter adapter and a carrying case for my troubles.

 

According to Magellan, not all units will develop this problem. They only received the redesigned units last week, so I doubt any of them are in stock at any of the stores yet. I would suggest that you turn on your backlight and look to see if you have any of the blue spots. If so, Magellan will replace the unit.

 

This is the only problem I have had with my Meridian, and I was very satisfied with the way it was resolved.

 

homer.gif

"Just because I don't care doesn't mean I don't understand."

Link to comment

I had the same problem (x2). I called them a few weeks a go and got a RA number, I then called today and spoke to Brain Oliver. He said they will still fix it even if my warranty is out when the get it (ends on 10/30/02). I then complained about the price of shipping, and they gave me their UPS account number so it won't cost me to ship it.

 

But I am kind of greedy, so I will try to see if they will upgrade my gold to a platnium since I have had it in a few times (enough to be called a lemon).

 

Wyatt W.

 

The probability of someone watching you is directly proportional to the stupidity of your actions.

Link to comment

Stu, did they fix your unit, or did they completely replace it (i.e. a new Meridian)?

 

Also.. I guess I'd have to reload the firmware, since I have my name and address hacked into my lawyer screen.

 

I have the blue spots... but they're almost not noticable enough to worry about it. Actually, I was trying to figure out what it was a while back, but I figured I did something to the screen. I thought maybe I pressed on it too hard or something.

 

Jamie

 

edit: reread your post. You answered my question.

Link to comment

Jamie-

If I were you I would just get an RMA and send it in at your convienence. As I said, it took 7 days round-trip from Chicago (they are in Tulsa), so if you know there is a week that you can be without your toy, get it fixed. I doubt that you caused the problem yourself.

 

homer.gif

"Just because I don't care doesn't mean I don't understand."

Link to comment

Mine was brand new. I sent them only the GPS, yet I got a brand new unit (still in the box with the cables/owners manual/batteries) plus they also sent me a case, windshield mount and a car cig lighter power adapter.

 

homer.gif

"Just because I don't care doesn't mean I don't understand."

Link to comment

quote:
Originally posted by Stunod:

Mine was brand new. I sent them only the GPS, yet I got a brand new unit (still in the box with the cables/owners manual/batteries) plus they also sent me a case, windshield mount and a car cig lighter power adapter.

 

http://www.rowwindow.com/images/homer.gif

__"Just because I don't care doesn't mean I don't understand."__


 

did you not just get your unit from shop harmony? they must have a production run in stock with this issue

 

SR and dboggny.

9372_2600.jpg

Link to comment

I don't remember a discussion on whether or not the blue spots tend to get worse over time or not. My MeriPlat has a couple of minor blue spots that do not bother me now. If they do get worse later, then I will do something about it; otherwise, I will not worry about it. Does anyone have any experience with the blue spots getting worse over time? Thanks.

Link to comment

Got mine shipped from Sunnyvale Fry's via the telesales line. No telling how long they were there. The earlier version had only one little smudge, the later one had about 4, but in no way were they unusable. I doubt I will take the time to return them for it. Already sent one to my sister in Ohio. Don't reckon they'll be using it much at night.

 

Don

Link to comment

My buddy picked up three MeriGreens from the Fry's store in Sunnyvale, CA. I called him after reading about the problem on this forum. He opened them and checked them out and sure enough, two units have the problem. Grrrrr! At least it is good to know that Magellan will swap them out. One of those puppies is for me; backup for my MeriPlat.

 

Imagine life in a cacheless society!

Link to comment

This upcoming week, I plan to call Magellan about getting the blue spots fixed, but I'm a bit confused about what they do about it.

 

I've read some folks experience that they've gotten brand new units back, Stunod even says he got a cable and vehicle mount with his, while it seems other folks just got their unit repaired.

 

Are they doing some sort of inconsistent fix for this? Those of you that have sent in your blue spot receiver, what have you gotten back?

 

Jamie

Link to comment

quote:
Originally posted by Jamie Z:

This upcoming week, I plan to call Magellan about getting the blue spots fixed, but I'm a bit confused about what they do about it.

 

I've read some folks experience that they've gotten brand new units back, Stunod even says he got a cable and vehicle mount with his, while it seems other folks just got their unit repaired.

 

Are they doing some sort of inconsistent fix for this? Those of you that have sent in your blue spot receiver, what have you gotten back?

 

Jamie


 

jamie, from what i have heard in this and other forums, in the begining, when they had no "spare" screens, they were sending people new units plus a gift of like a cord and case or a vehicle mount. as they received in "unatached" screens, they began replacing screens and returning your unit to you with a new screen and adding a gift. for example, they shippid mine back to me with data cable, case, manual and cd rom manual. hope that answers your question...

JUST an aside. i think if you argue with them a bit, maybe you can get them to pick up the shipping. icon_mad.gif

 

also here is the picture of the blue spots, taken from the yahoo magellan maridian group site.

 

9372_3300.jpg

SR and dboggny.

9372_2600.jpg

 

[This message was edited by SR & dboggny on December 22, 2002 at 06:37 AM.]

Link to comment

quote:
Originally posted by SR & dboggny:

jamie, from what i have heard in this and other forums, in the begining, when they had no "spare" screens, they were sending people new units plus a gift of like a cord and case or a vehicle mount. as they received in "unatached" screens, they began replacing screens and returning your unit to you with a new screen and adding a gift. for example...blah blah blah


Cool, thanks. That makes sense. I suppose I can't argue either way, as long as it's fixed. I was hoping to score a new unit... but I guess a screen fix would be fine with me.

 

As for shipping... I'll have to talk to 'em about that.

 

BTW, the posted pic of the problem is very much what mine looks like. Good pic.

 

Jamie

Link to comment

I have not sent my unit in yet (they probaly get pissed at me again when I call and asked them to renew my number because its been more than 45 days), but I mentioned that shipping was gettin expensive (not my first time to send it in) and they gave me their UPS account number so they can pick up the shipping. They also mentioned that they will fix it even if the unit is out of warranty (like mine is).

 

Wyatt W.

 

The probability of someone watching you is directly proportional to the stupidity of your actions.

Link to comment

As Jamie mentioned earlier, I got a NEW unit and some freebies (case, windshield mount, cig lighter cord). I had known about the blue spots for some time, and was aware that they were in the process of "redesigning" the backlight (read about it in the yahoo groups forum). So I contacted Magellan and told them I wanted to be on a "waiting list" for a redesigned unit...I did not want to recieve a different unit that may also have the same problem. When the new units arrived, I was contacted by e-mail and sent my Meriplat in to be exchanged. So far I have had no problems with the replacement (knock on wood).

 

Everyone I spoke/emailed with at Magellan was very helpful.

 

homer.gif

"Just because I don't care doesn't mean I don't understand."

Link to comment

Thanks for the heads-up on this. I have a Platinum on the way - should be here tomorrow. Hopefully with no blue spots.

 

Cracker - cool to see a fellow TTORA person here icon_wink.gif

 

I'm new to posting on the forum here - and thanks to everyone for the helpful info that I gained from this site. It helped me to research and make a decision on my new GPSR.

 

BAJATACO.COM

Vibram or BFG - getting there on rubber and seeing it all!

Link to comment

Well, as I was waiting on hold for the second time, I checked my inbox and saw an email from Stunod, who suggested I simply go through the Magellan site and email them my problem, so I promptly hung up and did that instead.

 

I'm very skeptical about sending a company unsolicited email... but we'll see.

 

Jamie

Link to comment

quote:

 

I'm very skeptical about sending a company unsolicited email... but we'll see.

 

Jamie


 

You're not trying to sell them a subscription to a magazine, you're trying to get their attention about a problem for which they have a legal responsibility to address.

 

BTW, I love your avatar. I hope that's not a self-portrait! icon_smile.gif

Link to comment

quote:
Originally posted by Jamie Z:

Well, as I was waiting on hold for the second time, I checked my inbox and saw an email from Stunod, who suggested I simply go through the Magellan site and email them my problem, so I promptly hung up and did that instead.

 

I'm very skeptical about sending a company unsolicited email... but we'll see.

 

Jamie


 

jamie, that is how i got my return number... i sent them an email and they sent the RA number by email just a few hours later.

 

SR and dboggny.

9372_2600.jpg

Link to comment

There's a form on the site to request an RMA. I got mine within 24 hours and got my unit shipped back to me very promptly and in like-new condition...with free gifts. icon_smile.gif BTW - this was not for the spotting problem. My unit's backlight broke after 11 months (a few too many times dropping it, no doubt) and I sent it in before the warranty ran out.

Link to comment

Wow, good timing Stunod.

 

No.. no problem at all. I filled out the form, got two verification emails within a few minutes, and then a response from Brian Oliver within four hours with an RA number.

 

I just this morning (about 30 minutes ago) mailed my Meridian to Thales. I'll update the thread when something happens.

 

Jamie

Link to comment

quote:
Originally posted by Jamie Z:

Twelve days ...

 

Jamie


 

Jamie, you're going to give engineers a bad name ... it's only been eleven days.

 

I'm waiting patiently right along with you. My merigold works great, but the blue spots are an irritant ... can't decide if I want it fixed or not. So, waiting for a positive review.

 

If it ain't broken, keep fixing it until it is broken.

 

Jeepster

- We did not inherit the land from our parents; we are borrowing it from our children.

Link to comment

quote:
Originally posted by Jeepster:

Jamie, you're going to give engineers a bad name ... it's only been eleven days.


Here's how I arrived at twelve days: (only an engineer would check to see if I was right icon_rolleyes.gif )

 

December 27 7:53am PST post: "I just this morning (about 30 minutes ago) mailed my Meridian to Thales."

January 7 3:01pm PST post: "Twelve days and no GPS yet."

 

We can both agree that December 28-January 6 (inclusive) count. That's ten days.

 

December 27 was counted in my total since I mailed it early in the morning. In fact later that day I had USPS confirmation that it left Memphis that day. That makes 11 days and counting.

 

I also counted January 7 since I posted in the afternoon after when I was sure it was too late for the UPS man to come around. Therefore, I knew I wouldn't get the unit that day. Count that one, too. Twelve days.

 

If course, New Years was in the middle of this time, which may be the reason for the longer-than-(I)-expected turnaround.

 

Jamie

Link to comment

Do the blue spots get progressively worse the more you use the backlight (in this case on a Merigreen)? Right now there is a blue area right along the right side of the screen -- not yet bothersome. Do the spots "grow" or "multiply" or will it stay like this?

 

TIA

 

bvgps

Link to comment

I never noticed the spots on mine "growing". They might have been there from day one, I'm not sure.

 

No problems with the replacement they sent me, though.

 

Keep looking out the window for the brown truck, Jamie!

 

homer.gif

"Just because I don't care doesn't mean I don't understand."

Link to comment

Jamie,

 

Did you supply your email address in your RMA? I got an email when Thales received my old MeriGold and shipped the replacement unit - the emails were only a few hours apart, and on the day that my package was delivered (FedEx). The shipping email included a UPS tracking number. UPS took 5 days to get from Okalahoma to Minneapolis, back in November (before Thanksgiving). That was 9 days, inclusive of the shipping and receiving dates, with only 1 weekend and no holidays involved.

 

If you haven't gotten an email by now, I would call...

 

-Craig/TeamCNJC

 

... Two roads diverged in a wood, and I--

I took off through the thorns, chest high, ...

Link to comment

Just like TeamCNJC said, I received automatic e-mails from "Magellan_Repair@ThalesNavigation.com" telling me my shipment had arrived there and another 3 hours later saying the replacement had shipped out (with the UPS tracking number).

 

homer.gif

"Just because I don't care doesn't mean I don't understand."

Link to comment

Yes, I'm sure my email was included in the package I sent. I even enclosed a letter describing my problem.

 

I haven't gotten any confirmation emails from Thales, although I got delivery confirmation of the package from the USPS.

 

I'll call tomorrow. Thanks for the heads up, guys.

 

Thirteen days without a GPS.

 

Jamie

Link to comment

Got it! Woo hoo!

 

At first I thought they'd sent me a new unit, despite what the rep told me on the phone. I'd mailed them my unit in the box it came in, and when I opened the parcel, I saw the (same) box with a new GPS inside. As it turns out, it's my old unit with a completely new front. New buttons, new screen, the whole deal, but the back is the old one. As a matter of fact, they packaged a manual, CD, computer cable, batteries, and lanyard (what am I gonna do with that?) in my old box, as though it were a new unit.

 

I also got a vehicle mount (which solves my dilema about where I'm going to get a Magellan cradle to attach to my RAM mount), a 12-volt cable, and the Magellan case. I guess it wasn't a bad deal.

 

Before I sent my unit to Thales, I'd loaded 4.02. When I got it back, the invoice says "Repaired your unit by uploading the latest software..." Guess what... it's loaded with 3.12. Heh.

 

I'm happy again.

 

Jamie

Link to comment

quote:
Originally posted by Jamie Z:

Got it! Woo hoo!

 

...

 

I'm happy again.

 

Jamie


 

Not too bad - 13 days with a holiday and extra weekend in the mix over my 9 days, and they actually did something to yours (mine was an out-and-out replacement - I checked the serial numbers).

 

Welcome back to your MeriPlat.

 

icon_biggrin.gif

 

-Craig/TeamCNJC

 

... Two roads diverged in a wood, and I--

I took off through the thorns, chest high, ...

Link to comment

Someone had claimed that the blue spots were due to humidity/condensation. If you're reluctant to send it back in, Jamie, I'm wondering if it would be worth a try to open the battery compartment and put the unit in a warm (not hot...maybe 100-125 degrees F) oven for a while to see if thoroughly drying it out helps.

Edited by embra
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 1
×
×
  • Create New...