Jump to content

My Vista is sick

Recommended Posts

Ever since the last update my Vista is acting funny. I used it (tried to anyways) for the first time since the update and it seemed to think the North Pole was actively moving around me. The cache I was looking for also seemed to be moving around me.


Do I need to reload the latest software?

Maybe do a master reset? Um, how do you do one of those anyway...I couldn't find it in the manual or on Garmin's site.




Let my heart be still a moment and this mystery explore

Link to comment

A master reset is performed by holding down both the page key and the click-stick (center click) at the same time while powering up the unit. Be sure and save all your waypoints, routes and tracklogs. You will lose all of your user settings (how your Vista is setup like map preferences etc). You can't save these settings so make note of them before the reset. Your uploaded maps should remain untouched. After the master reset, do the following (this is blatantly cut and pasted from Joe and Jack's GPS Information website


Go visit this page anyways...and the whole website. icon_biggrin.gif


begin cut and paste


If you have to perform a full reset using one of the sequences shown above you will need to allow the unit to collect a full almanac before normal operation can be resumed. First a fix will need to be obtained which can take from 5 to 10 minutes of leaving your unit outdoors, stationary, with a good sky view. After the first lock you will need another 12.5 to 15 minutes to get the almanac reloaded. Check the date to insure that the information was reloaded properly. Time will be shown as UTC time since your local time offset was lost in the reset.


Re-establish all of your preferences such as time zone, daylight savings flag, etc. Reload all your waypoints and saved routes from your backup. I do hope you have a backup. WAAS capable receivers will have to re-establish the WAAS alamnac as well.


end cut and paste



Link to comment

Has is properly re-acquired the almanac, so that it's using all possible satellites? Otherwise, geometry may be very poor, which could lead to bad accuracy and the position jumping around more than normally. This in turn could lead to erratic bearing pointer near the target.


Not calibrating the compass can give the same result, provided it's enabled.


I've updated three different Vistas to 3.10 without any problem.



Link to comment

Installing 3.10 on top of anything older than 3.02 beta will clear the unit, including the calibration information. Installing 3.10 on top of itself will not clear that information.


There is a checksum control when loading a firmware. That it was loaded incorrectly but still worked more or less is extremely unlikely. But you do loose your calibration when doing a master reset, which this upgrade may have forced the unit to do.



Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...