Jump to content

Macintosh computers, Virtual PC and my GPSV

Recommended Posts

I had to share this.


For about six months I've struggled with using my G4 Titanium Laptop with Virtual PC to upload maps to my GPSV.


Using a Keyspan USB to Serial adapter I've been able to transfer waypoints and upgrade the firmware on my GPSV but uploading more than 3 megs of maps was virtually impossible.


Well, I finally solved the problem. A friend told me to toss my Keyspan Adapter in the trash and buy an IOGEAR USB to Serial Adapter (model GUC232A).


Finally, FINALLY I was able to upload 19 megs of maps to my GPSV using my Macintosh (took 52 minutes and 38 seconds). Works flawlessly. No lock ups or sudden loss of signals.


The trick is to NOT install the Mac drivers. Rather you should install the Windows Drivers through VPC.


I knew there were enough people struggling with Macs, VPC and thier GPS units that this would be welcome news.


The IOGEAR adapter transferred at a hefty 115,200. I can't recommend this adapter enough.

My Kepspan High Speed adapter is going up for sale.


Jolly R. Blackburn


Link to comment

Thanks, oh jolly one! I just ordered an iogear adapter based on your recommendation.


I'm a newbie who just received my GPSV and have tried to transfer City Select map sets for hours. I was using a Keyspan High-Speed adapter, and things would download smoothly for a bit, and then I'd get a notice saying that the software couldn't find the Garmin. I was running VPC 5.0 on my G4 Sawtooth. I updated VPC to 5.0.3, but still got the same problem. Now, based on what you said, I hope it's the Keyspan.


"When the chips are down, the buffalo are empty."

Link to comment



Exactly the same problem everyone else has been having. I was reading the forums on Connectix last night and apparently others are having great success with the iogear adapter as well.


Good luck. And remember -- don't install the driver on the mac side. Install the Windows driver via VPC5. That seems to be the trick.


Jolly R. Blackburn


Link to comment

Hey, Jolly One!


Just got my IOGEAR adapter, fired up VPC, downloaded the PC drivers to it, fired up City Select, downloaded maps to my GPSVr...AND IT WORKED LIKE A CHARM! I'm junking that wretched Keyspan!


So thanks again for the advice.


Also, perhaps you could answer this question from a newbie (since you are obviously both a Mac whiz and a GPSr owner/user [yeah, butter him up!]): The first cache I found had a multi-leg component. How do I manually enter the coordinates of each subsequent leg into my GPSVr? I was stumped, and didn't do the legs. I re-read the manual, fiddled with many screens, and for the life of me, I can't figure out how to add a waypoint by manually entering coordinates. Am I having a senior moment here, and the solution is as obvious as the poison ivy blisters on my legs?


Thank you for any advice you can bestow.


Please pass the Calamine lotion,



"When the chips are down, the buffalo are empty."

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...