Jump to content

Platinum + 256MB SD card (Sandisk)

Followers 0

Recommended Posts

Howdy.. Ok I did my duty to search and read many great posts about sd memory and the Platinum. However, I am having a few wierd things happening and I need advice from others.


I have a the gps and a 256MB SD card that had gone bad and SanDisk replaced with a brand new card.


I went into my Mapsend and created about 10 regions for the different states I travel to and named them in the 8.3 format. oklahoma.img, kanasas.img, etc.... I used two methods to get the data on the SD card. First I tried mapsend and uploaded to card.. then re-named. Last I just copied with explorer.



When I turn on the GPS and go to card options it tells me the card is not formatted. If I remove the card and put it back in the reader.. Windows tells me the same thing. So I tried detail00.img, detail01.img, etc.

Same problem. So.. Now I'm creating a 4 state area and will upload via serial cable.



I have a 8MB card..that has detail00.img and deail01.img and it works fine.


Question: is there something wrong with my platinum? or could I have another bad 256 card?






Link to comment

If you are doing the same processes for both cards, and it works for the little one but not the big guy...well, I wonder about the card, too.


I've not heard of any problems with Meridians and larger cards; I believe people have used up to the 512MB successfully. Trying a serial upload next makes sense.


A couple of questions:


What firmware version are you using?

How large are the regions and files you were trying to use?


(grasping at straws here a bit, but this might be relevant...or at least rule out a thing or two).



Often wrong but seldom in doubt

Link to comment

I've used a 256MB with no problems in the MeriPlat. By any chance did you format the SD card using WinXP? I remember someone saying that the MeriPlat will not recognize the FAT32 file system that WinXP defaults to. If this is the case, try re-formatting the card with the standard FAT file system.



"Just because I don't care doesn't mean I don't understand." - Homer Simpson

Link to comment

Lets see if I can hit all the questions..


Firmware: 4.06


Each region is under the 16k limit. The average size is about 12k, with the 4 region limit of course.

Format: it came formatted to start. I used card utils to format it next. Last I tried XP, which using the graphical tool, would NOT format the card. So I have been using the gps to format the card. After which my card reader opens it properly.


OFFthe wall idea: I don't have USB2.0 and my sandisk reader is only USB1. Could this card need a higher speed reader/writer? I know thats far fetched but its acting wierd.



Link to comment

I don't know about XP, but in Win2k you have to eject the card using File Explorer before removing it from the reader or the file system can get screwed up. I think it has to do with "write caching" or mount and unmounting of drives. I think its like popping out a floppy while the activity LED is still on.

Link to comment

Hmmm. Your firmware is current (I think older firmwares had a problem with big cards) and you're using small files (I think you meant all regions were under 16MB, not 16k). Super large files can be a problem sometimes. So you look good on that.


I doubt very much that the USB is a problem; I'm using USB 1.1 with my SanDisk (though it's only 64MB) in a SanDisk reader. It seems like a rather remote possibility that you got two skunks in a row, although it is possible.


Forresth's suggestion is an important one to bear in mind, but it wouldn't explain the weirdness on the GPS.


You said that you get the card not formatted message when you go to card utilites. Prior to that, does the card work ok? I.e., does a detail map load properly?


This is unusual behavior.



Often wrong but seldom in doubt

Link to comment

OK.. something caught my eye.. someone said you eject the sd card first...???????? is this true for all y'all? When I try to rt click eject.. I get a message that an error was encounterd while trying to eject removable disk drive e:.. I'm guessing that is not a normal thing?


And to answer Embra, No..it does not look like any maps load. My Serial upload test was a bomb because my batteries ran out at 67%.. Guess I'll try one state or two... That should be quicker...



Link to comment

Ok with a single map.. I was able to upload to my SD card via GPS. even at 115200 this took quite a long time. Must figure out why my card is acting up.. I really suspect my windows XP. I'll take my reader to work and try it on my laptop.. (98)




However.. BY uploading it this way I have no control over the name of the file. I edited the mapsend.ini file and changed the name I wanted priort to starting the software... But it still uploaded as detail00.img..

Link to comment

I have had limited success!!!


Here is what I know now. ( And I hope this helps someone else in the future..)


I borrowed a friends laptop and tried the eject test. it also runs XP and would not eject it.


I used my reader to rename my DETAIL00.IMG to OKLAHOMA.IMG and put it back in the GPS..

It Worked!


Now my brain kicks in...and it go back to my computer and RENAME all the lowercase names to uppercase NAME.IMG files.. and put these on the card. The GPS comes up with the them all onboard. I am now wondering if it is a matter of file name CaSe ...

I'm doing one last test I have backed up my SD card and I am going to rename a file lowercase and see if it works or chokes.. Looks like all the file names are Uppercase.. Could it be that simple..



Link to comment

OK.. last one I hope.. I'm back to my computer is hosed... after I messed with the card in my computer with the reader...and went back to the GPS I got the same errors...


I put all my image files onto the laptop and used it to send them over..and I have map files on my GPS now.. YEA!!!!


So I guess it's getting time to blow up my computer and re-install everything.. OH joy..



Link to comment

Are you closing the Mapsend program before trying to eject the SD card? If not the file on the card may still be in use by the program. Make sure that no programs are using the SD card, Even Explorer can't have the directory listed. I usually left click on the C drive and then right click on the E (for me the SD is E) and choose Eject. Every once in a while even that doesn't work and I have to use the Plug and Play manager to Stop the USB mass storage device, and start over.



Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Followers 0
  • Create New...