Jump to content

2.11 Beta - Well, It's Beta


RB_Nielsen
Followers 0

Recommended Posts

I just got back from a trip to Chicago using Garmin's latest/greatest ver 2.11BETA firmware in my Garmin V. The trip out went without incident with the exception the "arrow" screen that pops up before an up-coming turn was off considerably in terms of showing location of the car. The next day was more disasterous with the unit locking up throughout the day. I had to power down several times in order to get it functional again. Of course, it IS a beta release. I'm re-loading ver 2.08 just as soon as I finish this post.

Link to comment

I've been using the 2.11beta since the day it came out. I've exploited all features fairly extensively: long trips, short trips, routing, tracking, on-road, off-road. No problems to report.

 

Oops, I take that back. I had one situation where it popped up a turn warning 50 miles early. I've heard about lockups, but I have never seen it.

 

-- It's from aliens. I seen um. --

Link to comment

quote:
Originally posted by eahousley:

Oops, I take that back. I had one situation where it popped up a turn warning 50 miles early.


 

This is a know bug, if this happened crossing a map boundary. I've been working with Garmin on this one, which popup up in 2.09beta (went away in 2.10beta and reappeared in 2.11beta).

 

I have another couple of bugs in 2.11beta:

- when starting a find while not having a 3d fix yet, the V does calculate a route, but forgets to change the moving sat icon into the moving route calc icon. While that is no problem, it also keeps moving the map while I drive... which consumes CPU, so calculation takes considerably longer. And this is confusing... it took me a few days testing to figure this out (did resets, power cyucles, etc...).

 

- the ETA time display can sometimes stay at --:-- when at 0m from a turn and being stationary. Not a nice thing when indoor and you want to know how long a route will approx. take.

 

Other than that, no major problems and very happy with Garmin beta's. icon_biggrin.gif

 

--

Robert Elsinga =8-)

geocaching (at) elsinga.org

Link to comment

I for one have always downloaded/installed the beta releases on my Garmins (2 GPS V's, Vista, GPSMAP 76S) and have personally never had problems. In the event that I do (or will), I always have the last release (beta or final) to revert back to. I like being able to see what new items/features/fixes/bugs have been introduced in the betas. Magellan on the other hand has never publicly released betas (although there have been beta "leaks") and you have to wait literally months and months for a new release. This is one reason why I choose Garmin units now over Magellan (have a GPS 315, a MAP 330 and a Meridian Gold)...it's good for the company and the consumer when you can see that the company is continuously releasing new software updates that add new features, even though they periodically introduce a few bugs in the process....that's the nature of software; nothing is ever totally bug-free.

 

That's just my opinion. Both brands are great, but I'm just swayed over to the Garmin side.

 

And I have also not run into any problems so far with 2.11 beta for the GPS V.

Link to comment

I once had 2.06b loaded, which always recalculated, even if you aborted the recalc. This was Not Nice , when on vacation... so I reloaded 2.05.

 

Overall, I don't have much problems with beta's. I do provide lots of feedback to gpsvbeta@garmin.com and were asked for more info on various occasions. This has resulted in some "private" beta's to test the bugfix some times.

 

--

Robert Elsinga =8-)

geocaching (at) elsinga.org

Link to comment

Must be a Chicago thing. After one trip in all detail area using the beta with good results, I poked in one of our Chicago stores that was out of the detail and at the first off route calculation, it did a continuous beep. Had to pull the batteries to reset it and on the next missed turn the screen went blank with a line along the bottom and then other lockups. I think it was to due to not having Chicago detail loaded in. As I hate to miss turns in the windy city, I loaded 2.08 back in along with the Chicago detail, or at least as much of it as I can fit. icon_frown.gif Did report such to Garmin.

 

Steve Bukosky N9BGH

Waukesha Wisconsin

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 0
×
×
  • Create New...