Jump to content

Dead Magellan Platinum


isleskipper
Followers 0

Recommended Posts

Got a brand new Platinum, it worked fine out of the box. Then, after reading the manual, decided to upgrade to 4.02 off the Magellan site. Did so, unit worked fine after the upgrade. Next, decided to install the 256MB SD card. Carefully followed directions, now the unit is dead - will not turn on, blank screen. Have tried fresh batteries, all to no avail. Also tried taking the card out, still the same result.

 

Has anyone encountered such a problem? Is there a fix, other than returning it for another one?

 

Thanks.

 

John

Link to comment

quote:
Originally posted by isleskipper:

Has anyone encountered such a problem? Is there a fix, other than returning it for another one?


 

There are several ways to attempt to revive a dead meridian outlined in the Meridian FAQ.

 

The one that isn't listed, however, is to hold down the power button for a few seconds. Sometimes a quick button press doesn't get it.

 

Hope this helps!

 

alex

Link to comment

Call Magellan, get a return authorization number they will fix it without any questions. If they cannot fix it they will replace it

 

I tried to load V4.02 also, killed it dead. . .It took the entire internal map base out of my Mag-Gold. Send it to Magellan next day mail, got it back in 6 days with a new case, manual, and PC cord. Very happy with service. I bought my unit on E-bay, they didn’t care were I got it. Magellan wants to keep your business what ever it takes.

Link to comment

I did exactly the same thing you did:

 

  • * Bought MeriPlat

* Updated

* Bought 256mb card

* Loaded maps on card and installed into GPS

* Meriplat went dead in the water

Wouldn't turn on, wouldn't do squat. It would beep and the screen would flash, but would not come up.

 

I had loaded the wrong file onto the 256 card and it locked the reciever up.

 

My fix was as simple as:

 

  • * Take the card out of the GPS

* Insert it into the writer and erase the offending file

* Place the card back in the GPS (which now worked again) and format the card (heeding the warning not to format the card with the writer)

* place the card back in the writer and follow the instruction on the FAQ page EXACTLY and now I'm sitting pretty with the entire SE USA and Southern California to Las Vegas detailed maps loaded in my GPSR. icon_biggrin.gif

 

Couldn't be happier. icon_biggrin.gif

 

[This message was edited by Hollister on March 31, 2003 at 09:35 AM.]

Link to comment

It sound like a problem I had with my gold over a year ago. My gold all sudden stoped working with AA batteries, but it would still work with external power. So I think it was somthing to do with the battery contact points. I sent the unit into magellan and they sent me a repaired, new, or refubished unit.

 

Wyatt W.

 

The probability of someone watching you is directly proportional to the stupidity of your actions.

Link to comment

After playing with the firmware and basemaps, I had a dead Merigreen the other day.

When I pushed the PWR button, I would get one beep, with no change on the screen. Then it would go into a continuous tone about 5 seconds later.

The only key sequences I could get to work with it powered off were the ones to get the unit into software upload mode, and the force off sequence.

 

Ended up calling Magellan to get an RA# to send it back.

While the tech was on the phone, he had me hold the Nav & Pwr buttons, which got me into the hidden menu.

The list of codes that is floating around shows you need to hold the NAV, GOTO & PWR buttons to get into the menu....

 

Anyway, by being able to get into the hidden menu, I used code 32 to clear memory, went back in, used code 95 to clear the map memory, then used code 99 to go back to software upload mode, and tried reloading the firmware and the basemap using magup expert mode and the serial cable.

 

Amazingly, it worked, and I revived my completely dead Merigreen... icon_smile.gif

 

Art

 

www.yankeetoys.org

www.BudBuilt.com

http://www.ttora-ne.mainpage.net/

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 0
×
×
  • Create New...