Jump to content

How much memory in a Legend?

Followers 0

Recommended Posts

The manual for my Legend says "The eTrex Legend accepts up to 8 MB of map data from (Garmin CD Roms)"


I have tried to download maps from the Roads and Recreation CD but I don't get anywhere near 8 MB. I can't even get 6 MB.


Why is this? Are they including the basemap in that 8MB? If they are, they are being dishonest about it accepting 8 MB of data!



Link to comment

Hmmmm, something doesn't sound right here at all. I get the may not fit warning at right about 8MB, and have found that if you ignore it, you can sometimes actually get slightly more than that to load.


I don't really have a guess however as to what might be going on here. Have you gone to Garmins website, and downloaded the latest updates for both your Legends firmware, and mapsource?


Good luck

Link to comment

I have the 3.1 firmware and have had no problems, so I'm not going to upgrade the software when Garmin's website says that the new version (3.2) only: "Corrected problem that potentially rounded northing/easting values when entering or editing waypoints in UTM-based grids."


I learned long ago with computers that if it ain't broke, don't fix it! Although now it sounds like it is broke, I don't think upgrading the firmware will do anything.


I am using a version of Mapsource that is a few years old that I bought used. Perhaps the older version of Mapsource has a difficult time calculating the exact size of the maps that I am downloading.

Link to comment

Do update.

Frequently, more small bugs than are listed in the upgrade information are actually fixed.


Upgrade your MapSource program too. The current version is 4.13. It's available for free from Garmin's site.


The Legend has 16 MB map memory, where the basemap resides in 8 MB and you can use the other 8 MB. A Vista has 32 MB, which leaves you with 24 MB for your maps.



Link to comment

I never have any trouble filling my Legend right up to 8 meg.


I agree with Anders about getting the newest softwares for Mapsource and for your unit.


How are you calculating how much memory your maps need? In Mapsource on the left side of the screen are 5 tabs, make sure that you have the "Maps" tab selected. As you add maps, they will show up in the map tab. One of my map sets includes 44 map segements and uses 7.91 MB of memory.


The top of the map tab says "Maps(44)". The bottom shows "44 Map(s) - 7.91 MB".


If you still can't get 8 MB in your unit, send it back. Garmin is good about fixing what's broke.

Link to comment

10,000 tracklog points and 1,000 waypoints might be a factor in your having problems. Have you done a complete reset of the legend?


Have you tried to force a map upload of around 7.5 megs??


You may have to try the Firmware upgrade again and a reset, before sending in the GPS to Garmin.



My Old posts as Geoffrey

My Current Post as GOT GPS?

My profile

My Home Page about what is GPS


[This message was edited by GOT GPS? on May 20, 2003 at 08:14 AM.]

Link to comment

10,000 tracklog points and 1,000 waypoints might be a factor in your having problems. Have you done a complete reset of the legend?


I've been led to believe that those reside in a seperate memory space.


Case in point: At one time I had 9 saved tracklogs, a nearly full active log, and over 830 waypoints. I was still able to upload 7.94mb in maps to my Legend. I did the same sort of thing with my Vista once.


Based on my experience, tracklogs, routes and waypoints do not impact map memory. If you fill it to the brim with maps, the memory status indicator on the Setup/System screen can still display little or no memory used.


To the original poster: I vaugly remember that I had to delete a pre-installed map before uploading the topos that I use. Try retrieving the maps from the unit with Mapsource to see what's already in there.

Link to comment

Here is what happened:


I transferred an 8MB mapset to the Legend without a problem. When I tried to go over 8MB it said that there was no more space but I WAS able to transfer 8.1MB. BUT then when I panned around the downloaded map on the Legend I found a couple of "holes" in the map where counties that were part of the mapset were missing! So I figured that the thing had run out of memory during transfer. I kept lowering the number of counties in the mapset and transferring until I got no more "holes" in the map. I had to go all the way down to 5MB.




Then just out of curiosity, I transferred an 8MB mapset to the Legend and then transferred it back to the computer. The transfer back created different "holes" or missing counties than were on the Legend! In other words, after I transferred the mapset back there were 3 missing counties out of the mapset out of 38 but these were not the same missing counties that were on the Legend!


Bizarre enough?



Link to comment

No offense Dave. I really mean that. But...


This really sounds like user error to me. Your problem sounds way to bizarre for a receiver malfunction. I myself has issues with my receiver when I first got Mapsource, not knowing how to use it and all.


I think maybe the unit was full when you tried to transfer the the second time. The 5mb you were able to get in there were maps that were already in the unit hence they were either overwriten or bypassed. When it ran into one that wasn't there it tried the upload it and ran out of memory. This could give the illusion that it accepted only 5mb.


If I were you I'd clear ALL the maps out of it and start from scratch, making sure not to go over the 8mb.


Let us know how it goes. I am by no mean saying that it's NOT the fault of the unit, but at this point I wouldn't give up quite yet.


Good luck.

Link to comment

User data like waypoints, routes and tracks share the same memory as the firmware. Maps, however, are in another IC in the Legend. Hence, there is no impact on the map memory from how many waypoints you have.


I've loaded more than 24 MB of MetroGuide maps in my Vista. The maps looked OK, but the find function didn't work. Couldn't locate a single street.



Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Followers 0
  • Create New...