Jump to content

Uploading photos failed.


terratin

Recommended Posts

Posted (edited)

I'm currently logging a larger number of caches from a vacation, and it's super frustrating. I'm uploading photos, partly because ECs and Virtuals, partly just because. More often than not the upload fails, and once I resize the image from 4-5.3mb to around 3 it works. My internet connection is stable and fast, thus no idea what's wrong. Btw, when I change from browser (win11, firefox half recent) to cachly and upload the image, not resized and on the same connection it works. Thus I guess the solution is not to be found in too big image sizes. But where?

Edited by terratin
  • Upvote 2
  • Helpful 2
Link to comment
Posted (edited)

I've found that when I get "Upload Fail", the size doesn't matter.  It's a site problem, typically clearing up before I can get home to ask about it.

 

I always take pictures at the full resolution of my device, which is often my Canon camera, so I can crop and adjust the photo without restriction.  But I almost never upload a file to the site above 800x600 pixels.  That makes a file less than 50 MB, great for sending from a phone.  And 800x600 is (thus far) below today's threshold where the site re-sizes an image and pixelates it, yet it is quite viewable on Apps and in browsers.  If the upload will work at all, that gives it the best chance to work.  I would never expect a file above 1.5 MB to consistently upload to the site.  I don't press my luck anymore.  Not gonna do it.  Na gah dah.

 

This one is 800x600, and at 50 MB, it's light on my phone data (and compressed by an App).  That's what I send for a cache log photo.

 

IMG7663c.jpg

Edited by kunarion
Link to comment

Ok, thus likely a site problem? Interesting that I don't have the problem via the app, and that uploading is so much faster than via the website. I don't want to resize photos, neither on my phone, nor while logging because I don't have time for that at the moment that I'm logging my caches. The alternative is to not log right away, edit photos when I do have time and then post generic logs because I've forgotten what I wanted to write. Which is not what I want to do.

Link to comment
6 minutes ago, terratin said:

Ok, thus likely a site problem? Interesting that I don't have the problem via the app, and that uploading is so much faster than via the website. I don't want to resize photos, neither on my phone, nor while logging because I don't have time for that at the moment that I'm logging my caches. The alternative is to not log right away, edit photos when I do have time and then post generic logs because I've forgotten what I wanted to write. Which is not what I want to do.

 

Yes, if not sent immediately, a concern is forgetting which photos go with which log.  It can get a little crazy, especially if the photos are from more than one camera.  Good thing I can only manage to hunt a handful of caches at a time, it's easier to keep things straight.  :anicute:

 

But I also tend to not have a reliable phone connection out in the field.  So I plan to do all the compiling/resizing/uploading later, which works regardless.  And I save the logs as drafts and in shorthand (or in even shorter hand on my Garmin), so all of the work is delayed til I'm at a computer at home or hotel.  But ya gotta do what works best for you.

Link to comment
15 minutes ago, terratin said:

I don't have the problem via the app, and that uploading is so much faster than via the website

 

Did you upload this image from the App?

 

75399b02-89f0-4c4a-88ad-ef0d41d3d431.thumb.jpg.fe74c0bce114e8dcc419f494a398fb3f.jpg

 

It is 0.233 MB, yes it is less than one tenth of the size you try to uload from web. I guess that the App resizes images before uploading - a clever desing feature that makes it so fast :D

 

  • Helpful 1
Link to comment

Yes, the image upload feature appears to be somewhat broken right now. Out of 3 photos I've been trying to upload tonight, only one did. The other two won't upload, regardless of how much I shrink the size before upload. The upload feature simply spins forever. Even shrinking to below the size of the one that worked doesn't get them to go, so it doesn't seem to be a size issue. I assume there will be some logs somewhere that show a bunch of errors that can help the devs troubleshoot this. I've probably generated a number of them this evening.

Link to comment
15 hours ago, arisoft said:

 

Did you upload this image from the App?

 

75399b02-89f0-4c4a-88ad-ef0d41d3d431.thumb.jpg.fe74c0bce114e8dcc419f494a398fb3f.jpg

 

It is 0.233 MB, yes it is less than one tenth of the size you try to uload from web. I guess that the App resizes images before uploading - a clever desing feature that makes it so fast :D

 

Thanks for checking. yes, it's one of the images I uploaded via Cachly. Overall I don't care much about the quality of the images. They are rather small on the website anyway. It's more like a memory thing for me while the good-quality photos remain on my phone/backup disks

Link to comment

To follow up, the issue didn't clear up on its own since last night. I also tried uploading with a different browser to see if that makes any difference (Chrome vs. my usual Firefox), but it still doesn't work. It seems like there's something about the images that the site doesn't like, but I don't know what that is or what makes these two different from the one that worked last night.

 

If the site could parse any errors and provide info back to the user, or even just pass any raw errors back to the user, it would help to figure out why an upload fails.

Link to comment
Posted (edited)

If you load the image in GIMP, does it pop a message?

 

[something technical]. Do you want to [foo] it?  Keep Convert.

 

I remember posting roughly the same complaint a few months back, in a release notes thread maybe, being unable to upload even a small file.  Then gave the file to GIMP, saw the message, Convert, and aha, it uploaded.

 

If it's the same issue, I guess they're ignoring it.

 

EDIT: found it.  

 

 

Edited by Viajero Perdido
  • Upvote 1
Link to comment

I’ve had this problem too.   Photos don’t upload on the Geocaching app or on the website for me at the moment.   So I just went onto my iPhone and tried uploading the image from my Photos library with Cachly and it was instantaneous.   I then went onto the website to edit the image and add a title.   👍👍 thanks terratin

  • Love 1
Link to comment

I'm having the same issue. Photos failing to load. I've tried downsizing and upsizing and nothing seems to work.  Good thing they got rid of benchmarking to make the website work better.. lol.. 

I too have tried doing it on my phone and that has failed as well. Although technically I'm still doing it through the website as I don't know of a way to do it on the app when I've already logged the cache.  

I've tried multiple web browswers and nothing works..    

 

Getting really tired of glitches and fails for this premium paid website. 

  • Upvote 1
Link to comment

This drove me absolutely insane last night! What a totally crappy thing to have gone wrong on the website, when loads of us are out caching for the weekend and come home to log a lot of finds and discover it will not accept images. I logged as much as I could with my nameless app, and that was ok but WOW... how did this not get a big priority slapped on it back on Thursday?

 

On 5/16/2024 at 2:53 PM, arisoft said:

I have adjusted my camera to take about 2.5 MB images. I hope that your camera can also take rational size images. I am using Open Camera App just for this reason. Bonus is that I can take more photos before running out memory.

 

There was a LONG thread about photos and the website when they initially restricted us to 5Mb. People were - justifiably - irate. Why? Because unlike the above solution I cannot reduce the size of my photos without editing them. And as was discussed in the thread I haven't dug around for, many many many people are using newer smartphones with higher res cameras and LITERALLY can't take smaller pictures. Mine will let me reduce for a single shot and then reverts to the basic size, which is usually 4+Mb. I'm not happy with it, except for the quality is better... and yes, I have checked settings etc.

Tested uploading photos again today and again cannot upload any on the website!

Bottom line: Groundspeak NEEDS TO PRIORITIZE THIS!

Link to comment

I just thought to try a photo that had worked in the past. I tried uploading a photo that uploaded just fine on May 7, but now it fails. This rules out the possibility of the image itself being the issue. Something has changed with the site and is causing it to fail during the upload process.

  • Helpful 4
Link to comment
Posted (edited)

I was also facing this issue and I found out if I use the "Convert Image" function built into MacOS and choose a size that results in an image size < 1mb the upload works every time. Just a workaround for those who desperatly want to log their virtual and earthcache finds. Groundspeak should fix this nonetheless.

Edited by SpeedCore
  • Upvote 1
  • Helpful 1
Link to comment
Posted (edited)
3 hours ago, SpeedCore said:

I was also facing this issue and I found out if I use the "Convert Image" function built into MacOS and choose a size that results in an image size < 1mb the upload works every time. Just a workaround for those who desperatly want to log their virtual and earthcache finds. Groundspeak should fix this nonetheless.


Holy smokes - LESS THAN 1Mb is very very small!

Edit at 14:28 EDT - I am able to upload a single photo now, not yet tried multiples.

Edited by CCFwasG
update
Link to comment

The issue is obviously not resolved yet. I find it problematic, especially for virtuals and Earthcaches, where a photo is requested as part of the log. My awkward workaround is posting a text log on the Geocaching website, then adding a separate note with attached photo via a third-party app. Not an ideal workaround at all, neither for the CO, nor for me. I'm hoping for a soonish fix, or at least un update.

  • Upvote 1
Link to comment
7 hours ago, DaddyKool said:

The issue is obviously not resolved yet. I find it problematic, especially for virtuals and Earthcaches, where a photo is requested as part of the log. My awkward workaround is posting a text log on the Geocaching website, then adding a separate note with attached photo via a third-party app. Not an ideal workaround at all, neither for the CO, nor for me. I'm hoping for a soonish fix, or at least un update.

Yeah, that's what I do with Cachly. I can attach the photo to my existing log there.

Link to comment

Let's say I am a fairly new cacher with a basic account. I go to do a virtual requiring a photo. I can't upload it. Then I try an earthcache that wants one... same deal. So now, why on earth would I ever pay Groundspeak for premium membership if one of the BASIC functions to log a cache does not work? Honestly, I'm flat out stunned they have not made this a top priority. 

 

Trying again today, cannot upload a single photo on the website. SMDH. Ridiculous.

  • Upvote 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...