Jump to content

Recent change on how Drafts are handled?


Recommended Posts

On 4/8/2024 at 8:13 PM, worrellsquirrel said:


We apologize for any frustration related to this drafts bug. As our engineering team continues to troubleshoot, we would greatly appreciate:

  • Screenshot(s) of the issue
  • Detailed steps to reproduce the issue


Okay... here we go!


PS: Logging on STAGING was throwing an error. This is why is I reproduced the issue on LIVE with an archived cache of an inactive owner

STEP 1 - There are no drafts

STEP 2 - Upload drafts
Let's assume that I have a brand new (Garmin) GPSr and I have found one single cache. The geocache_visits.txt file looks like this:

GC3GKH8,2024-04-03T11:43Z,Found it,"Draft 1"




STEP 3 - Log the cache




-> Result: Cache has a smiley on all maps/lists and the draft entry is gone -> No problems so far 👍

STEP 4 - One day later - we found another cache

Now, the geocache_visits.txt file looks like this:

GC3GKH8,2024-04-03T11:43Z,Found it,"Draft 1"
GC3GFWJ,2024-04-04T10:24Z,Found it,"Draft 2"

-> Yes, the (Garmin) TXT file contains *all* found caches (up to 1000)

PROBLEM 1: After uploading the TXT file, the Drafts section unfortunately contains both (all) caches. This is a real pain because the list is getting longer and longer every day. Until June 2023, the upload process ignored already uploaded drafts.




STEP 5 - Deleting the duplicates

All I can do now is to delete the duplicate entries one by one and then log the remaining (new) ones.

This leads to PROBLEM 2: After deleting the duplicate draft, the smiley is replaced by an exclamation mark (forever):



Hope this helps...

Edited by RCH65
  • Helpful 3
Link to comment
3 hours ago, RCH65 said:

This leads to PROBLEM 2: After deleting the duplicate draft, the smiley is replaced by an exclamation mark (forever):


I've found that if you edit the original log on the cache showing the exclamation mark (even if you do nothing to thg log other than open it for editing and saving it), the extraneous exclamation mark goes away.

  • Helpful 1
Link to comment
13 hours ago, Rustynails said:

Before uploading, there once was a date displayed of the last uploaded date explaining and only new logs would be added. 

Oh, yes! 


That's what it once looked like (taken from a bug report in 2019):

-> These date/time values were automatically set after uploading a geocaching_visis.txt file - based on the most recent (last) timestamp in the file.

  • Upvote 2
  • Helpful 1
Link to comment

So this issue is still with us.
I'm having this occur with my Garmin Dakota20, I've used it for years without problem, but strangely I only noticed this failure to ignore past Draft upload in the last few months.
I concur with the comments above about the Ignore Logs Before... message that was always there:

It worked fine until someone broke it. Why is it so difficult to fix???

  • Upvote 1
Link to comment
On 1/27/2024 at 11:34 PM, Keystone said:


I'm repeating one of the two updates from Geocaching HQ in response to the false claim that there are no updates.


...and no updates since April!

It's obvious you can't speak frankly - otherwise you would have sent us updates, no doubt.
We all see that a lot of other things are *much* more important... like "Sending postcards from adventures" or the "GeoGuessr Challenge"... and whatever else the marketing department comes up with.

I *really love* geocaching since 2007... but currently this company behaves like an arrogant monopolist.

Edited by RCH65
  • Upvote 4
Link to comment

Am einfachsten ist es, die Datei geocache_visits.txt nach jedem Upload zu Groundspeak zu löschen. Das Garmingerät legt automatisch eine neue Datei an, die dann auch nur die letzten Funde, Nicht-Funde enthält. Nach dem erneuten Hochladen wird die Datei auf dem Garmin dann wieder gelöscht. (GSAK macht das übrigens automatisch :P)


Link to comment

Thank You HQ for your procrastination of this issue. I just lost my drafts when trying to filter ones already logged. How much longer before you fix what once worked? Many have been waiting a long time.  Oh, and I rarely use those silly post cards.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...