Jump to content

Any current cache manager programs for Linux systems?


Recommended Posts

I recently switched my computer to Ubuntu/Linux.  The only wall I have hit with programs is geocaching.  I have read through the forums and see there is a program called, "Open Cache Manager" that is similar to GSAK.  I installed it, but it does not run.  In looking at the history, it was last supported in 2018.
I would like a program similar to GSAK to manage my caches.  If that is not available, I would like something (ANYTHING) which would enable me to at least get a GPX file into my GPS (Garmin 60CX). Does anyone know of anything out there that would work? TIA!

PS...yes, I can put the GPS in Mass Storage Mode, but when I do that I only see the contents of my micro SD card.  I cannot seem to access the GPX folder  and place files into it (I pretty much remember doing that years ago on a different laptop).

Link to comment

GSAK + Wine?  I'm not sure of the current state of Wine, but if you search those terms together, you might get an idea if it's worth pursuing.


GSAK + VMWare + Windows?  (Or similar other VM software.)  If you have a Windows license, this combination should be solid.  I've used an old GSAK + VMWare + Windows XP (yes...) on rare occasions with total lack of drama.


I'm not aware of any Linux-native software for caching, and (given I've switched to phone caching with a good Android app) no longer need to involve the desktop at all.  Good luck.


Edited by Viajero Perdido
  • Upvote 1
Link to comment

GPSBabel has been around for over 20 years. It's had geocaching-specific features all that time and it knows how to get things to your 60Cx. It's not a database like the appropriately named GSAK; it (among other things) picks up a GPX and puts it down inside your GPS. I found thousands of caches with that combo, but it's fair to say that it's not a 'cache manager' as much as it's a transfer/conversion tool.  There's only so much data that GPS will hold, but GPSBabel knows, for example, to put letters in the description to indicate the cache type and embed the difficulty and terrain.

Mass storage mode doesn't transfer waypoints in that era of devices. https://gpsfaqs.org/faqs/garmin/xseries/g60cx/waypoints.html#wptsonmem
 You can only transfer tracks via SD.

These units are now 18 years old.  We were always happiest using as little kernel support as we could, but they frequently broke the USB implementation. I haven't tested it personally in years, so it's possible you have some debugging to do. The pieces SHOULD all be there.


This used to be a huge problem. I haven't heard it in a long time, so either nobody's using that combination, the distros finally fixed it, or that page is more easily found via search than our mailing list address. :-)

  • Upvote 1
  • Helpful 1
Link to comment

I think the simple answer is "No" - in terms of "managing" caches but  gpsbabel does work very well for sending /receiving data to/from the GPS. When I still used my Etrex30 I found that when putting it in mass storage mode and connecting to my Linux laptop it would appear as 2 devices, one the GPS internal storage, and the other the microSD card and I could mount and transfer to/from both.


For managing caches I've used Linux for ~20 years, and in that time  I've run 2 caching tools: Geoqo and Open Cache Manager, support for both of those dropped off to the point where they became impractical to stick with - I don't know whether either would even run now.


I tried to  run GSAK under Wine a few years ago but it had quite a few problems, though that may well have changed in the intervening years, and it should be fairly quick to setup and try.


I now run GSAK in a Virtual machine running Windows 10, and that works very well, I only use that VM for GSAK and nothing else.


If you "switched my computer to Ubuntu/Linux" you may find that the license from your original Windows install will be OK to use on a virtual instance and GSAK is now free, so this could be a zero cost option, just the time you need to invest in setting it up, and GSAK is way ahead of any other tool I've used in terms of its capabilities and the support from the community.

Edited by MartyBartfast
  • Helpful 1
Link to comment
8 hours ago, MartyBartfast said:

you may find that the license from your original Windows install will be OK to use on a virtual instance


On that note, VMWare offers a utility, that runs in Windows, that converts that installed  instance of Windows into a virtual machine.  (Crazy idea, but somehow it works.)


Edited by Viajero Perdido
Link to comment

Thanks for all of the information and ideas!   I am really trying NOT to have to run a virtual Windows.  I did download GPSBabel, but could not get it to work.  I guess I need to study it more and see if I can get it operational. I just thought perhaps there was something easier....I forgot just how old the Garmin 60CX is.  I have tried other GPS units, but have always come back to my 60CX as it has never let me down.  Hopefully, I can at least get the GPX file to load even if I cannot manage the caches on Linux.

Thanks again!

Link to comment

The basic pattern should be:
gpsbabel -i gpx -f yourpq.gpx -o garmin -F usb:

That is
[i]nput type gpx 
[f]rom yourpq.gpx
[o]utput of Garmin protocol
[F]ile usb:

If the garmin serial module thingy is installed (it used to not work very well....) you can replace "usb:" with /dev/ttyZZZ where ZZZ is what's reported by modprobe/dmesg when that module is initialized.

As for being easy, it used to be easy to put that in your mimecap and trigger that command when you did a download of the GPX from the site. That was long ago and time/security may make that single click harder to set up now, but it was once possible for it to be easy. This is the approximate recipe https://www.gpsbabel.org/tips/browser.html but that recipe is surely on brown crackling paper with torn edges from age. The main content there probably predates Pocket Queries, but the inspiration should still be in there.

Of course, if you and I have to go debug USB protocol stuff, it's no longer "easy".

Later,  you can do the kinky stuff like: https://www.gpsbabel.org/tips/geocaching.html

If we need to get debugging out of the USB protocol stuff, add -Dn where n is a number from 0 to 9, with 0 being silent and 9 being an explanation for every byte moved. 1 or 2 are less chatty, like "This is a Foo packet and it says Bar, but I'm not going to show you alll 4,092 bytes of it."

If you're getting an error about us being unable to claim the USB port, be aware that https://www.gpsbabel.org/os/Linux_Hotplug.html is a thing on Linux.

If you have the round serial cable and a *working* USB/Serial port (or maybe even a antique motherboard "COM1" port) you can replace the "usb:" above with the serial port name. That should be a completely different set of problems, but it's probably more readily debuggable to the average Linux user that's comfortable debugging, say, a modem than the esoterica of stalled USB control and data pipes.

So let's see the error messages, the details on what you tried and we'll chooe between USB and serial and try to conquer it.


  • Helpful 3
Link to comment

I did not realize that I never updated this post...sorry.  I did eventually get GPSBabel to work and am now able to get my geocaches loaded into my 60Cx using GPSBabel.  I appreciate all of the advice and help I was given here!  Many thanks!

  • Upvote 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...