Jump to content

GPSmap 66s, "Next-Stage"-coordinates won't change

Recommended Posts


I had a problem with my 66s (FW 9.90) last week, that pc-mueller had as well:

Startet a Multi, got the coordinates of stage 2, entered them, GPSr showed the new coordinates, and I went to stage 2. At stage 2, found and entered the coordinates for stage 3, but the GPSmap didnt't show these coordinates, it showed the listed coordinates instead. Tried several times, but everytime I entered the coordinates of stage 3, the 66s changed them to the listed coordinates.

I couldn't find this issue on GPSrchive, or maybe I missed it. Has anyone else ever had this problem with the 66s or any other Garmin GPSr or is this a known issue of FW 9.90 and 9.60? pc-mueller downgraded to FW 7.60, and it works now. But downgrading the FW isn't really what I wanna do, maybe there's another solution.

Thank you!

Link to comment

I know this an old thread but I think I have somehow pin-pointed this problematic behaviour.

As far I see it happens after when one downloads coordinates from geocaching.com. After that the coordinates don't update at all. BUT if I reboot the GPSr the coordinate changes work again. At least so far I have always been able to heal (or rather bu-pass) the problem by restarting the unit.



Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...