Jump to content
Sign in to follow this  
Followers 2
eisi_rs

Invalid option -N in GSAK

Recommended Posts

Hello,

I used GSAK since I began to search caches.

After a little break I wanted to put a PQ on my Garmin Legend HCX via USB.

When I try to send the waypoints to my GPS the program quits with a "Invalid option -N".

The option -N was removed in an earlier version of GPSBabel.

But when I look at the gpsbabel.bat the option -N is set everytime.

How can I change this behaviour?

Share this post


Link to post

Where did you find gpsbabel.bat? I'm a long time GSAK user but don't have that file anywhere. Did you create it yourself?

You can try to rename the batch file and see what happens.

 

 

Share this post


Link to post

It is in the \AppData\Roaming\gsak folder.

The batch:

"C:\PROGRA~2\gsak\gpsbabel.exe" -N -D9 -i xcsv,style="C:\PROGRA~2\gsak\GSAK.STL" -f "C:\Users\eisi\AppData\Roaming\gsak\babel.txt" -vs -o garmin -F usb:

Share this post


Link to post

Nope, no gpsbabel.bat anywhere.

Started my laptop and did a search on all disks... no gpsbabel.bat

 

 

Share this post


Link to post

Please have a look at: GSAK->Tools->Options.

In the field Application Data is the path where the batch can be found.

The RoamingPath is hidden in Windows normaly, but I think if you  copy and paste your path directly into the explorer path line, you can search this path and you will find the batch.

Share this post


Link to post

I can see all folders and file extensions. It's one of the first things I change after installing windows. There is a babel.bat but it only contains 1 line:

echo testing

 

I'm 99.99999% sure I have no gpsbabel.bat anywhere ;)

 

 

BTW, have you tried the GSAK forums?

 

I only found items with gpsbabel.bat in 2012/2013 posts.

 

 

Share this post


Link to post
Posted (edited)
6 minutes ago, on4bam said:

I'm 99.99999% sure I have no gpsbabel.bat anywhere ;)

 

Me too.

 

If I were you  @eisi_rs I would temporarily rename that file to something like gpsbabel-suspect.bat

 

and see if GSAK then works OK, you can always rename it back if necessary.

Alternatively make sure you have the latest version of GSAK (Tools/Check for newer version of GSAK)

Edited by MartyBartfast

Share this post


Link to post

I think that the batch is ony used for some old GPS like mine.

The problem occured after an update of Windows10

Everytime i tried to send my GPX to my Legend i bacame the following message: Unanble to init USB

This problem was not new, but I had to update my Gpsbabel to the newest version.

After this, the problem with the -N occured. If I try to send the GPX manually to the GPS on a commandline,

the caches appear on the GPS but without the right coordinates of the solved mysts.

So I decided to solve the problem with the -N.

 

Share this post


Link to post

@MartyBartfast : 
This batch is written new everytime I send Waypoints to my GPS.

I deleted it, but no change. I made it unwritable and a babel2.bat appeared.

I made this unwriteable too and then GSAK crashed.

Share this post


Link to post

You'll get better (and faster) answers for this on the GSAK forums.

 

  • Upvote 1

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  
Followers 2

×
×
  • Create New...