Jump to content
Sign in to follow this  
Followers 3
HoochDog

Attaching image in Draft mode is broken

Recommended Posts

Steps to recreate... in the official iPhone app...

 

1) create new log entry

2) select draft

3) attach image

4) save draft

5) come back later to the draft, turn off draft and officially post log entry

 

result...

log entry image is not visible in official iOS app (black image appears)

log entry is not visible in a web browser. 

here is a link to a log that had an image uploaded using these steps

https://www.geocaching.com/seek/log.aspx?LUID=dbe3755b-af54-4d9f-aea9-8f76045ab631
 

this bug is very annoying. I like to attach images in draft mode so I don’t have to remember which image went with which cache, but want to type in my full log later. Thank you. 

844FBB51-E646-47D3-9042-A9C4FAC460B5.jpeg

BA2547D9-CC70-4B19-B25C-84594540B950.jpeg

55DE82C3-084D-48B2-9FCE-CFB0855E22CE.jpeg

Edited by HoochDog
Clarification

Share this post


Link to post

It's been a couple of days.  Can anyone confirm this behavior or is it just me?  This one won't crash the app :D, so feel free to test.

Share this post


Link to post
7 hours ago, HoochDog said:

Can anyone confirm this behavior or is it just me?

While I can't confirm the same behavior with an iPhone, I can say that it's also broken in the Android app.  Yesterday and today, I attached an image to a draft, intending to upload and complete my log later at home.  The draft was there, but there was no image attached, even though it showed in the draft at the time I created it.  I had to remember which photo I wanted to attach to that log and go find it in my dowloads from the photos of the day.

 

My workflow:  Log a draft on the phone app while at the cache site, after signing the log, quick timestamp, notes I want to expand on, etc.  Attach photo if desired...save draft and on to the next cache.

At home: Log in to Geocaching.com on my laptop, go to my Dashboard, scroll down to Drafts, open the first one to log, and write my full log.  The photo I had attached (normally there, already attached) is missing.  This seems to happen if I use "take photo" or "select photo" - it doesn't matter.  If I want the photo to appear with my log I need to reattach it, then upload my log.

Once I have completed that, it takes me to the cache page with a button at the top that is a link to "Return to Drafts", where I can then move on to the next draft awaiting completion.

 

Again though, I use an Android phone so there is likely to be differences.  Maybe I should post this in the Android bugs forum....

Edited by CAVinoGal
Clarification

Share this post


Link to post
9 hours ago, HoochDog said:

It's been a couple of days.  Can anyone confirm this behavior or is it just me?  This one won't crash the app :D, so feel free to test.

I have iPhone and was able to load an image to my draft log with no problem. Just added photos to 3 drafts today.  Have you tried restarting your phone?  Or logging out and back into the app?   Or deleting the app and reinstalling?  If you still are having trouble after doing all that, then I am not sure what else to suggest other than contacting GS and see if they are getting  bug reports from other iPhone users.   Good luck!  Let us know if it gets resolved. 

Share this post


Link to post
10 hours ago, HoochDog said:

It's been a couple of days.  Can anyone confirm this behavior or is it just me?  This one won't crash the app :D, so feel free to test.

I can confirm. I don't have much experience with drafts but I followed your steps. After I officially posted the log the app said I had no drafts. However it now shows as a draft on the map and there's no image to be seen even though the draft had an image. 

 

  • Upvote 1

Share this post


Link to post
10 hours ago, outdoorsoccer said:

I have iPhone and was able to load an image to my draft log with no problem. Just added photos to 3 drafts today.  Have you tried restarting your phone?  Or logging out and back into the app?   Or deleting the app and reinstalling?  If you still are having trouble after doing all that, then I am not sure what else to suggest other than contacting GS and see if they are getting  bug reports from other iPhone users.   Good luck!  Let us know if it gets resolved. 


adding photos to drafts isn’t the issue. As noted in the steps and screenshots. When you come back later and post your log, it results in an uploaded image that is broken and not viewable. 

Share this post


Link to post

I found this thread because a similar issue was raised in a swedish facebookgroup. The best idea there is that this might be related to the standard format of the iphone's camera that changed a while back and that the official app might be handling this format differently (maybe something changed in a update of the app?). I don't have a iPhone so I can't test this to see if it helps, but here are some article about the thing with suggestions for how to change the format in settings or use different ways to convert the picture to a format that should work in the app: https://www.techgeekandmore.com/change-default-image-format-iphone-ipad/ and https://www.iosappweekly.com/change-photo-format-on-iphone-jpeg-png-tiff-heic/

Share this post


Link to post
3 hours ago, Pleu said:

 this might be related to the standard format of the iphone's camera that changed a while back and that the official app might be handling this format differently  


Good theory but I already save photos in high compatibility, jpeg mode. 
functionality is still broken. 

image seems to upload in draft. 
when you access draft, you can see a thumbnail of the image. 
When you turn off draft and save it. Image is broken. 

 

DAE0E8F9-E479-4944-ACD2-CEE20AD477D3.jpeg

E8EEFFF0-23C5-4D9A-8D21-D799EC20D846.jpeg

  • Helpful 1

Share this post


Link to post

I’ve done some more experimenting. Title of this thread should say “posting draft images is broken”

 

scenario 1) broken

attach image with iPhone app in draft. Come back to iPhone app and save log. 
 

scenario 2) broken

create draft log with image in iPhone app that rhymes with hashly (don’t know if I’m aloud to say). Access that draft log in iPhone app. See image. Save log. No images show up in log.  Not even broken ones. 
 

scenario 3) WORKS

create draft with image in iPhone app. Complete draft and post it using the website. 
 

this third scenario works. So as a workaround for now, if your draft has an image, complete the draft on the website. 
 

I’d still prefer the posting draft loses images bug be fixed though. 

Edited by HoochDog
Typo
  • Helpful 1

Share this post


Link to post
22 hours ago, HoochDog said:

iPhone app that rhymes with hashly (don’t know if I’m aloud to say)


Cachly should be allowed, they use the official API so they are "good guys". :) I think it's only unathourized apps that are not allowed.

You did some good testing, I hope HQ can check on this because there seem to be a bug in how the drafts are handled. 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  
Followers 3

×
×
  • Create New...