Jump to content

Error en Urwigo


javilo99

Recommended Posts

Buenas,
Estás creando un Wherigo, ¿verdad? ¿Cuándo te sale el error? Cuando abres el proyecto con urwigo o cuando una vez abierto intentas compilar (Build -> Compile)? Me imagino que en el segundo caso. Ha empezado a salir el error a partir de algún momento en concreto? Quiero decir, al añadir alguna imagen o vídeo, o usar timers o inputs, o creando expresiones lua propias?
Yo cuando testeaba mis cartuchos se me creaban carpetas del estilo "run-84ebe95d-1878-4c50-8dd5-e60db5e04e6e" que parecen similares a las que te salen al inicio del error. Estas carpetas son en teoría temporales y cuando algo salía mal no se borraban solas. Dentro solo había 3 ficheros: cartidge.gws, cartidge.gwl y cartidge.gwc. Estas carpetas las puedes borrar si dentro solo encuentras esto. A lo mejor el problema va en esta línea...

A veces algún problema que tenía, era que las imágenes y documentos que usas en el Wherigo, no los podía editar ni tener abiertos con otro programa mientras el urwigo estuviera funcionando. Reconoces el fichero "l1.PNG" que sale en el error?
Y ya por último, en el Urwigo en la caja inferior "Error list" no te sale nada, ¿verdad?
Tampoco sé mucho más.. espero que te puedan ayudar más en el hilo que has abierto en la sección de wherigos en inglés ;)

Link to post
44 minutes ago, SastRe.O said:

Buenas,
Estás creando un Wherigo, ¿verdad? ¿Cuándo te sale el error? Cuando abres el proyecto con urwigo o cuando una vez abierto intentas compilar (Build -> Compile)? Me imagino que en el segundo caso. Ha empezado a salir el error a partir de algún momento en concreto? Quiero decir, al añadir alguna imagen o vídeo, o usar timers o inputs, o creando expresiones lua propias?
Yo cuando testeaba mis cartuchos se me creaban carpetas del estilo "run-84ebe95d-1878-4c50-8dd5-e60db5e04e6e" que parecen similares a las que te salen al inicio del error. Estas carpetas son en teoría temporales y cuando algo salía mal no se borraban solas. Dentro solo había 3 ficheros: cartidge.gws, cartidge.gwl y cartidge.gwc. Estas carpetas las puedes borrar si dentro solo encuentras esto. A lo mejor el problema va en esta línea...

A veces algún problema que tenía, era que las imágenes y documentos que usas en el Wherigo, no los podía editar ni tener abiertos con otro programa mientras el urwigo estuviera funcionando. Reconoces el fichero "l1.PNG" que sale en el error?
Y ya por último, en el Urwigo en la caja inferior "Error list" no te sale nada, ¿verdad?
Tampoco sé mucho más.. espero que te puedan ayudar más en el hilo que has abierto en la sección de wherigos en inglés ;)

Sí, el error me sale al intentar compilar...

 

Al añadir una serie de fotos, pero nunca me había dado mi error.

 

Cuando intento compilar me sale una carpeta del tipo "run-84ebe95d-1878-4c50-8dd5-e60db5e04e6e", pero no hay nada dentro, la aplicación reconoce como si ya hubiera creado ese archivo .gwz o hubiera crado un archivo para probar (run)

 

Sí claro, ese archivo es una foto que he añadido recientemente...

 

No, en la lista de errores no me sale nada...

 

A lo mejor es porque el tamaño de las últimas fotos es muy grande?

 

Gracias y Saludos!

Link to post
16 hours ago, javilo99 said:

He creado un nuevo archivo con una de las fotos (en concreto l1.png) y puede funcionar sin problema....

Las imágenes en wherigos a veces dan problemas.
Yo para evitar, te recomiendo que te montes unos "estándares", los que mejor te vayan (yo me basé en hilos como este:

)
Iconos: Siempre 32x32 y png.

Imágenes de áreas o personajes: 690x390 (o 230x130; me guío por la proporción) y .png
Audios: convertirlos todos .wav
Video: Nunca he usado videos en Wherigo, así que no puedo decir nada.
Teniendo en cuenta que el Wherigo se va a ver en una pantalla de smartphone o como mucho iPad (es decir, pantallas pequeñas) tampoco es necesario que las imágenes tengan mucha resolución. Así además te ahorraras en kilobytes.

Yo con les wherigos que he creado (que son unos 4, tampoco son muchos), usando esta guía no he tenido problemas. Cuando en el Wherigo empiezan a haber imágenes que son png, otras jpg, otras jpeg..., creo que ahí es cuando empiezan a haber errores. Unificarlo a uno de solo me ha sido útil. No digo que sea el mejor método ni que tenga que ser así obligatoriamente, pero sí el que menos problemas me ha dado.

Link to post
On 9/25/2020 at 11:39 AM, SastRe.O said:

Las imágenes en wherigos a veces dan problemas.
Yo para evitar, te recomiendo que te montes unos "estándares", los que mejor te vayan

Ya me lo recomendaron, probablemente sea problema del tamaño de las imágenes...

 

Si lo consigo solucionar os digo algo

 

Gracias!

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...