Jump to content

Alternatives to GSAK

G & E
Followers 2

Recommended Posts

I've used GSAK for just about as long as I've been geocaching.  In fact I use it for more than just geocaching.  I create waypoints for locations to photograph and set them up similar to geocaches.  They are set up with the syntax of GC"myname"number".  This allows me to have my notes handy such as what is at the location and anything else that may be helpful.  The method had worked well with my old 60 series GPS.  I then bought a Etrex Touch which only lasted about 3 years.  Now I have a Montana 800 and I have a unique problem.   My export of Geocache like waypoints goes well, In fact I can import it to Basecamp to verify that it's complete.  However when I'm out in the field many of these photo subject locations simply don't appear.  It's as if they were never exported.   I've tried different settings in GSAK but nothing changes.   If none of these created caches appeared I would understand but when only certain ones don't appear I'm at a loss to understand why.   I use a webcam symbol to identify them from actual geocaches.   I'd prefer to get GSAK working right but if not, I may have to change to some other database software to export them.   What do others use?  Any thoughts on GSAK that could cause this?   

Link to comment

What did the people on the GSAK forums say?

Did you use a GSAK export or through a macro (garminexport?)?


I've used a similar method to export a "cache" where waypoints were locations we wanted to visit during our holidays. This worked as expected on an Oregon 600 and 700. I always export with the GarminExport macro as GGZ with waypoints send as POI.



Link to comment

I went to the GSAK website and was told to use the macro "Edit Cache Id"  I did that because the cache id, which is a hidden number, for certain caches must have somehow been duplicated.    However that macro didn't fix anything.  I allowed it to change the cache id and then tried to do the export.   Same issue as before.    There's got to be another solution. 

Link to comment

So I may have found a work around but it's awkward to say the least.  Here are the steps I've followed.

Delete files in GPS

  1. Folder GPS  “Send to GPS”
  2. Folder GPX  "Current"
  3. Folder GGZ  "Geocaches.ggz"  If this file exists 



File\Export\ export to c:Documents\GPS\geocaches


Open Easy GPS

Open file created by GSAK as shown above from C: drive

Send to GPS


Somehow the use of Easy GPS for the actual export seems to eliminate whatever safeguards were there to prevent duplication with actual Groundspeak geocaches.   This process is anything but elegant but it works.   On the GPS I no longer have the created geocache code such as GCglenA05 but if I go to the comments I can find it there.   Also where the code or symbol should be on the GPS I now get a question mark.   


If  you can find any shortcuts or redundant steps in the above process please let me know.   I'm just glad that it is functional again. 

Link to comment

I tried it without using the intermediary program which is Easy GPS in this case.  I agree it shouldn't be necessary but it is.  I don't know why but without it I get the same problem even after using that macro.  I would sure prefer using just GSAK so maybe I'm still doing something wrong.    I don't know what it could be.  Also, the macro only fixes one "geocache" at a time.  I can use it going forward and if it worked I could use it and go through the database one by one to fix all known duplications but at this time I don't know of the problem caches until I try to look for them.   It's a dynamic database so I'm constantly taking a few out and adding a few.     


On the GPS I find the waypoints under geocaches.   Do you think it makes a difference if I use the export vs the send to GPS actions?   Also the send to GPS uses the GGZ folder while the Export uses the GPX file type.   I don't know why one is different than the other. 


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Followers 2
  • Create New...