Jump to content
Sign in to follow this  
Followers 6
sloth96

API Authentication issues

Recommended Posts

gsak users are complaining about authentication issues on their forum and on facebook.  Project-gc.com is also having problems as well and posted on facebook about it.  It appears to have happened around 7AM ET.

Share this post


Link to post
It affects to all apps/programs that uses the Api. 

Share this post


Link to post

With different security settings and network caching some people seem to not be having problems. It has not hit the apps on my android device.   cachetur.no seems to be able to pull from the API.

 

Commentary on facebook seems to suggest it is an expired certificate somewhere. 

  • Upvote 1

Share this post


Link to post

+1.  Sadly, on a weekend when there's no frog handy to jump on the reset button.

GSAK unhappy.  Can't get a token.

If I were setting up a cache run for today, I'D be really unhappy.

 

 

Share this post


Link to post

Just tried to refresh a cache in GSAK and I needed to get another token. After logging in and clicking "agree" I get an error too.

 

I'm sorry, there has been a problem getting authorization from Geocaching.com

 

Share this post


Link to post
19 minutes ago, on4bam said:

Just tried to refresh a cache in GSAK and I needed to get another token. After logging in and clicking "agree" I get an error too.

 


I'm sorry, there has been a problem getting authorization from Geocaching.com

 

Same problem here.

 

Share this post


Link to post

I may be mistaken, but I seem to remember this issue cropping up exactly one year ago. If so I wonder is it's got something to do with the date?

Share this post


Link to post

Geocaching HQ engineers are aware of this issue.

  • Helpful 1

Share this post


Link to post
13 minutes ago, Keystone said:

Geocaching HQ engineers are aware of this issue.

Good, but are they fixing it? ;)

 

Long weekend over here, GC broken... bad combination.

 

 

Share this post


Link to post

You're quite welcome, on4bam.

 

I'm posting again to report that API functionality appears to be normal again, at least for me, and at least when using GSAK and Project-GC.

  • Upvote 1

Share this post


Link to post
Posted (edited)

The security verification of HTTPS (the S) was broken for me, it's back and now verified by "Sectigo Limited"

Everything works as expected.

 

 

 

Edited by Mausebiber

Share this post


Link to post

It is nice that things are back to normal.  I learned somethings about the existing trust hierarchy today. It is more fragile that expected.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  
Followers 6

×
×
  • Create New...