Jump to content
Sign in to follow this  
Followers 1

Garmin 60csx not recognising the SD card

Recommended Posts

I found out my old 60cs was no longer supported, so I went out and bought a 60csx on ebay. Basecamp recognises the GPS and I can add waypoints, however, the unit only has 64mb of internal memory so I need to use an SD card. Basecamp does not appear to see the SD card. I have tried 3 SD cards ranging from 256mb - 4gb. I have tried FAT and FAT32. I have tried Mac and PC. 

Garmin Mapsource see's the unit but tells me it is not supported. I hope this doesn't mean that one of the best GPS's ever made is now unable to receive maps.

I'd hate to have to use one of the newer stupid touch screen devices.


Any ideas?

Share this post

Link to post

Upgrading from a 16 y/o model to a 14 year old model isn't much of an update.  :-) . You're trying to bridge a couple of generations so it's not impossible that a Mapsource new enough to run on a current OS doesn't still support a GPS that old and so on.

As is covered in the FAQ at the top of this group, waypoints on the SD card of that device aren't a thing, for either read or write. The SD card really is used for maps and storing recorded tracks on that model, not much else.

We'd really need better hints on what software you were using, exactly the steps you took, any errors or other messages displayed on the computer or the GPS and such. Version numbers, the OS used, and details really matter.

GPSBabel for both MacOS and Windows still supports that model and both the .loc and .gpx files used by this site. On both OSes, use "-o garmin" and a device "file" of "usb::".  "The bit thing I remember weird with that generation was that you really had to have the Garmin driver for Windows software to see the device. "gpsbabel -i gpx -f pocketquery.gpx -o garmin -F usb:" should copy the PQ to the device on any of the OSes.

Share this post

Link to post
Posted (edited)

You need to connect the GPS in "mass storage" mode to see the card in Basecamp or Mapsource.  Look in the "interface" settings on the GPS.


As above, the card is only for maps and custom POIS.

Edited by Red90

Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  
Followers 1

  • Create New...