Jump to content
Sign in to follow this  
Followers 5
MysteryGuy1

Issues With Cache Map

Recommended Posts

Does anyone else have this problem?  I go onto the cache map and place the pointer over various caches and nothing happens.  It's supposed to display the cache details, and provide a link to cache page.  Sometimes the pointer appears as a tiny hand and won't do anything.  Is this a glitch with the site?  I've had it happen on multiple computers.

  • Upvote 1

Share this post


Link to post

Happened here this afternoon too. Zooming in/out  makes no difference.  Win 10 + FF69 64bit. I just used GSAK to have an overview of the area of interest, no big deal.

 

 

 

Share this post


Link to post
49 minutes ago, MysteryGuy1 said:

Does anyone else have this problem?

 

Today it was really bad. Normally one zoom level will correct the problem but now I tried several times until I was able to open the cache info.

Share this post


Link to post
5 minutes ago, arisoft said:

 

Today it was really bad. Normally one zoom level will correct the problem but now I tried several times until I was able to open the cache info.

On my Ipad it is not posible at the moment to work with geocaching.com.

Share this post


Link to post

Yep, same problem here, this is very annoying if you had to prepare for almost 100 caches.

As others wrote. Sometimes zooming helps, sometimes not. F5 also. But geocaching.com had this problem in the past already.

So I wonder why this happens again and again. this remebers at Windows, right?

Share this post


Link to post
12 minutes ago, joemanzh said:

So I wonder why this happens again and again. this remebers at Windows, right?

 

Not at all... My Windows XP has worked already over 15 years without problems because no updates :D

 

Share this post


Link to post
2 minutes ago, joemanzh said:

So I wonder why this happens again and again. this remebers at Windows, right?

 

I have met this issue in Firefox both in Windows and Linux. It exists in the Browse Map for a long time but it seems to be more annoying since yesterday.

Share this post


Link to post

This issue has been around for years, since the beginning of the map.  Clearly it's something we'll just have to get used to, like having a permanent limp from a car accident.

 

I suspect the problem is with connectivity to the servers on "bad days", and with JavaScript code either not doing any error handling, or doing it incorrectly.


The rest of the map is brilliant (save for the Google-vs-Leaflet picker), so this bug is an oddity.

Share this post


Link to post

Yes, same problem. Found no solution to this unfortunately. Zooming in and out doesn't work, neither does reloading.

 

So we basically have a message centre that often doesn't send messages, and a cache map that doesn't work.

  • Upvote 1

Share this post


Link to post

OMG, I didn't expect that someone feels concerned about my joke about windows. Reasons to start a war because of nothing. As usual. Stay calm, folks.

Share this post


Link to post
48 minutes ago, joemanzh said:

OMG, I didn't expect that someone feels concerned about my joke about windows. Reasons to start a war because of nothing. As usual. Stay calm, folks.

You didn't indicate in any way that it was a joke. A joker smiley would have helped. ;)

  • Upvote 1

Share this post


Link to post
13 minutes ago, PA-20 said:

When is geocaching.com going to address this problem? 

We don't know, but it was first reported 9 hours ago and it's a weekend.

Share this post


Link to post

Same issues over the last couple of days for both my wife and me... she runs Firefox and Windows 10 pro, I run Chrome and Windows 10 pro and another machine running Win 7 pro and IE 11.  Doesn't matter which mapset we use, either...

Share this post


Link to post

Same here. On IPad today not workabele. On win10, chromebrowser. Sometime f5 will works for a minute or so, But very quick it wil stop working again.

Share this post


Link to post

On the computer, I can't click on the map at all to get it to work. I can't see the name of the caches to open them up. So how can I do puzzles? I can't. It won't let me Search maps either. Something is really, really wrong.

Why haven't we been told anything about this, such as it's a known problem and it's being worked on? How can I cache if I can't check the caches?

Share this post


Link to post

Okay, it appears that I can click on the caches on my pocket query map, although this is a clumsy method; appearing that I will need to make pocket queries of any area I want to see the caches.

Share this post


Link to post

I've been having increasing difficulties with the icons on the maps for about the last 2 weeks or so.  Increasing or decreasing the size sometimes works, but usually for only a couple of icons on the map.  It's pretty hit and miss.  I've tried several computers and my phone.  It definitely is not a device problem, it's a site problem.

 

I use maps for everything.  Not being able to reliably look at the caches on the map is  crippling to me for the way I set up my plans, and also while I'm out caching.  I suppose that I could go through the tedious work of creating a PQ, but that could literally add hours to my trip planning.  I like to scan around the map and check out the caches in maybe 6-7 completely different areas before I decide what I want to do for a weekend.  Once I decide on an area I suppose a PQ would be helpful, but I shouldn't have to do that.

 

Map problems seem to be an ongoing issue with this site.  I should think that maps would be a top priority for the site.  Why can't they get it right?

  • Love 1

Share this post


Link to post

Just tried for myself:

Defeult Search Map: Cache links all seem to be working OK, I tried zooming in and out, and also re-centring the map, each time hovering over a cache icon changes from the default pointer to a hand, and clicking the icon brings up the cache details in the side bar.

 

Browse Map: Functionality seems to work or not randomly. Again I zoomed in and out and recentred the map, every time hovering over most of the caches doesn't change the default pointer to a hand so can't click on them. On those where the pointer changes to a hand I can click on them and get the popup box and then click the cache details; on those where the pointer doesn't change then I can't click on them. From the testing I've done I can't see any correlation between those that work and those that don't, but it is the case that the majority of the caches on the map DONT work.

 

Firefox & Chrome on Linux.

 

 

Share this post


Link to post

Further to last night's post... the point and click function seems to work on the "search" map but not the "browse" map. This is a problem for a couple of reasons. First, the "search" map is cumbersome to use, but most importantly, it doesn't offer the Leaflet maps... OSM, Esri Topo, etc... [:(]

  • Upvote 4

Share this post


Link to post
3 hours ago, bd's said:

Map problems seem to be an ongoing issue with this site.  I should think that maps would be a top priority for the site.  Why can't they get it right?

 

Basing on the common observation that the search map is "working" as always and the browse map is "working" worse and worse it looks like it is an expected state of facts for the site developers. Don't they just try to strongly suggest the search map is the only one, whatever lots of this forum users are saying? <_<

  • Upvote 1

Share this post


Link to post
36 minutes ago, rapotek said:

site developers. Don't they just try to strongly suggest the search map is the only one, whatever lots of this forum users are saying? <_<

Yes, but the "search map" is real scrap, especially when moving the displayed section more or other caches are not loaded automatically. This is scrap.

 

Groundspeak, it's great if you invent new "features", but please don't make the existing functions worse!

Share this post


Link to post
9 minutes ago, Flachmann said:

Yes, but the "search map" is real scrap, especially when moving the displayed section more or other caches are not loaded automatically. This is scrap.

 

Groundspeak, it's great if you invent new "features", but please don't make the existing functions worse!

strongly agree. but Groundspeak communicate!

Share this post


Link to post

I agree yesterday and today the 'old map view' is terrible for accessing cache info and the new search map has been complete and uter $^!#@ since day one

Share this post


Link to post

the workings of Groundspeak is coming close to me dropping caching. all new features introduced without checking what the community wants are too tiresome.

  • Love 2

Share this post


Link to post
14 minutes ago, GrateBear said:

Working just fine for me on a MacBook Air.

 

I can confirm, it looks like most icons now respond correctly and changes cursor to pointer. Zoom in and out helps for the others (FF, Ubuntu). Has someone in HQ looked here possibly?

Share this post


Link to post
5 hours ago, stonehengeII said:

it doesn't offer the Leaflet maps... OSM, Esri Topo, etc... [:(]

  ^^

This!

Share this post


Link to post

Nope, still not working for me. I need the browse map to prepare a travel abroad as I easily want to look at all multies and mysteries and see which caches are close to certain roads - which works best with with open streetmal default.

Share this post


Link to post

I've had the same problem for last two days. I thought it was just my computer having a hissy fit until I read all the above.  Somebody fix it please.

  • Upvote 1

Share this post


Link to post

I'm having similar problems with my Samsung Android tablet.   Touching the cache icon often does nothing. Changing zoom level works eventually, sometimes after numerous changes. 

Share this post


Link to post

I had this problem yesterday as well.  It often happens where changing a zoom level or 2 fixes it, but this time it was every zoom level and no matter if I refreshed.  Very annoying as I just wanted to open a specific cache's page (that i was looking at on the map).  Luckily I knew the cache name so I could Google it instead.

 

Seems this problem has been around for a very long time.  I experience it more often on the phone (Samsung S8) but that's because I'm using the phone more often I suspect.  Yesterday it was on the Windows PC (Win10 and Firefox).  Very annoying.

Share this post


Link to post

I'll add a "me too". I have noticed if in frustration I walk away from the computer. When I come back quite a while later, I'll be able to click on the caches. I've noticed a similar problem with the search map but the delay is significantly smaller. My big problem with the search map is the disappearing map tiles. 

 

Another issue I have with maps is when using the Geocaching map with topo lines they come up in meters despite my settings being imperial.

 

And just a tip for everyone reading this thread, Project GC's Live map functions much more smoothly. Of course it runs off their database so there is lag in new caches appearing and archived caches disappearing.

Share this post


Link to post
1 hour ago, HikingSeal said:

Another issue I have with maps is when using the Geocaching map with topo lines they come up in meters despite my settings being imperial.

 

That would require Groundspeak (or their map provider) to generate and store two sets of map tiles for the entire world.  Ain't going to happen.

 

Try Esri WorldTopoMap.  It shows feet instead of metres.

Share this post


Link to post

Browse Map seems to be working for me now (using Chrome on Windows 7). Previously I could only click on certain caches and zoom level made a difference on what caches I could highlight and click on. 

 

It seems to be working on all caches at all zoom levels.

Share this post


Link to post
2 hours ago, Highlands_Guy said:

Browse Map seems to be working for me now (using Chrome on Windows 7). Previously I could only click on certain caches and zoom level made a difference on what caches I could highlight and click on. 

 

It seems to be working on all caches at all zoom levels.

 

Yes, seems like it. I was also just asked to confirm cookies again. Using Win10, Firefox latest.

Share this post


Link to post

I"m using Chrome Version 77.0.3865.90 (Official Build) (64-bit) on a W10 system and since the latest update of Chrome I've had problems with the Geocaching map in the map views that include only three map layers: Geocaching, Google Road Map, and Google satellite.  It used to be that the Geocaching map would turn blank when zooming in and out.  It would appear and disappear at various increments.  Now the Geocaching layer is totally blank except to the geocaches.  This problem doesn't appear in Firefox 69.0.1 (64 bit).

 

But it works in Chrome when I select "search geocaches" or "browse geocaches" in the map view.  Then I get all of Leaflet map layers and they all work fine, including the Geocaching map layer.  That's not a good solution because you see every cache in the map's scope and not those in a specific list or pocket query.  If they can't fix this then It might be a little better if GC.com let you pick the default map layer for maps and even better if they allowed you to use the Leaflet map set for all maps.

Edited by Nothereeither

Share this post


Link to post

Ok, and the bug is back. I can't open anything from the map. Zooming in and out might, or might not help. Can't we have a totally simple most basic static html website? Then there's a chance that things don't break so quickly.

Share this post


Link to post

Same here. Though now the problem seems to be local. Like I can click one cache at all zoom levels, and another one 200m away not regardless of what I do.

Share this post


Link to post

Looks like this problem is back. If I zoom in and out the problem might be fixed, or not.

  • Upvote 1

Share this post


Link to post
5 hours ago, terratin said:

Looks like this problem is back. If I zoom in and out the problem might be fixed, or not.

 

This has been an ongoing issue for years. From what I've seen, I suspect it's related to part of the map page not loading fast enough. This could be caused by your local connection, the load on the server, or both. I find I have better luck if I don't use the default "Geocaching" map style.

  • Helpful 2

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  
Followers 5

×
×
  • Create New...