Jump to content
Sign in to follow this  
Followers 3
Seawind

Garmin 66 STILL Crashing

Recommended Posts

I've had my new Garmin 66st for just over a month now and really like it...when it isn't crashing!  

 

I check for updates very often and it is running 3.1 and all the latest optional updates, including the chipset.

 

But, it experiences a "soft crash" about once every hour.  This is usually during a "Find" operation.  The screen slowly fades away and then I have to turn the unit back on.  Very annoying, but not too serious.

 

Much worse are the "hard crashes".  Yesterday, I powered the unit back on (after using it for about an hour).  Nothing but a blank screen, and then some sort of "Resetting" message flashed by.  Many minutes later, it came up, factory fresh.  All my settings and files were gone.  This was right in the middle of a cache run, which I had to cancel.

 

Are these still common issues?  A friend with the same unit is experiencing very similar problems.

 

It's too late to send it back to Amazon!  I'm sort of tempted to return to my solid 64 and try the 66 again in a few months to see if there have been any more updates.  But...I really like it in almost every other respect!

 

I'm using a Garmin rechargeable battery pack (new), which seems to hold the charge well.

 

Any advice greatly appreciated.

 

Share this post


Link to post

I would be calling Garmin customer support direct. Talk through the problem with them.  

I had a problem after  6-8 weeks and the unit was replaced. That was 9 months ago 

Since then all OK 

I guess you have a12 month warranty anyway 

 

Share this post


Link to post

I have the exact same issue and this is a replacement unit, no better than my first. Garmin acts like I'm the only one so please do contact them. They have not been very helpful in solving any of my issues. I do love the unit and will keep plugging away... but those hard crashes are very destructive!

Share this post


Link to post

My GPSMAP 66 almost never crashes... What are you doing different than me?

 

How are you loading geocache data to the device?

Share this post


Link to post

I use GSAK.  The exact same file in my 64 works great, in fact the 64 hasn't crashed for a very long time.

 

Today, I saved a waypoint using the 66, then tried to select it to navigate back to on the return trip.  Crash!  The screen slowly dims and the power goes off.  It comes right back up, though.  Then, could select the point and navigate, no problem.  It very routinely crashes about once an hour, but only after running for about that long - never early on during a session.

 

It's the crashes where everything is wiped that are the worst, and those are rare, but can ruin an entire day!

 

Share this post


Link to post

Have you tried a different set of batteries? Do you use the same battery pack in your  64 as well?

 

My 66s only crashed two or three times in nine months now, quite randomly. I never had any problems.

Share this post


Link to post

Just adding to and expanding Atlas Cached's point...

Using tips from this and other forums.,

I NEVER NEVER load caches or  third party maps on to the device, always onto an SD card 

 

Inter alia it gives you another avenue to recovery if the device fails?

It has always worked for me and the  66 runs well ( as did my previous 6x series units)

Share this post


Link to post

I started out with my usual PQs (which are duplicated on my eTrex 20 - that doesn't crash with the same files) on the internal memory, and had plenty of soft and hard crashes, and for a long time I have only loaded maps and PQs to the SD card. It continues to crash with the same files that doesn't give the eTrex 20 a problem. I used regular batteries, then Eneloops, and now the Garmin internal battery - none affected the rate of crashes.

 

I have multiple friends, some using GSAK to load a GGZ file rather than GPZ, with the 66s, and they have the exact crashes that I do. I try to get them to contact Garmin, but I think they see me wasting my time on that and don't feel compelled to do the same. 

 

I'm glad I can take out the SD card, reboot, and reindex those files on the road, but it takes serious time, and I despise having to remove a tiny SD card with wet/dirty hands in the middle of the woods or a river. If I don't have caches in the device, it isn't much use to me, so I don't care too much if it runs smoothly that way. The fact that the eTrex 20 can handle the same exact files tells me that the 66s should have no issue either.

Share this post


Link to post
3 hours ago, RecipeForDisaster said:

I started out with my usual PQs (which are duplicated on my eTrex 20 - that doesn't crash with the same files) on the internal memory, and had plenty of soft and hard crashes, and for a long time I have only loaded maps and PQs to the SD card. It continues to crash with the same files that doesn't give the eTrex 20 a problem. I used regular batteries, then Eneloops, and now the Garmin internal battery - none affected the rate of crashes.

 

I have multiple friends, some using GSAK to load a GGZ file rather than GPZ, with the 66s, and they have the exact crashes that I do. I try to get them to contact Garmin, but I think they see me wasting my time on that and don't feel compelled to do the same. 

 

I'm glad I can take out the SD card, reboot, and reindex those files on the road, but it takes serious time, and I despise having to remove a tiny SD card with wet/dirty hands in the middle of the woods or a river. If I don't have caches in the device, it isn't much use to me, so I don't care too much if it runs smoothly that way. The fact that the eTrex 20 can handle the same exact files tells me that the 66s should have no issue either.

 

Can you share one or more of those GPX files for testing?

Share this post


Link to post

I ran the Garmin Updater this morning on the 66st.  It showed a Chipset update to 2.70, which was not there two days ago.  When I first got the unit a month ago, I ran a chipset update.  I'm wondering if this is a new update, or if the last hard crash/factory reset of the unit erased the original update.

 

Update applied and I plan to test the unit again today.  Here's hoping!

 

Regarding the GGZ files, I load the exact same files to the 64, which has never crashed that I can remember, and has many hundreds of hours of use.

 

 

Share this post


Link to post

I took the 66 out for an extensive test run yesterday - 18 caches and some waypoints in very challenging signal conditions (heavy tree cover and canyon walls).

 

It went three hours of flawless operation and then crashed just minutes from the end.  That was, by far, the longest it has gone without crashing in over a month of heavy use.

 

Two things were different:  First, the chipset update, and second, an operational change.  With the 64, I'm used to flying over the buttons when moving from one cache to the next and never wait for the device.  I was doing the same with the 66, but noticed there is a 2-3 second "Calculating" step with each new cache selection.  This time, I gave it plenty of time to complete that step before continuing to the next screen (the Compass screen, which is what I navigate with).

 

When it did finally crash, the "Calculating" message did not display.  Rather, it froze and then the screen very slowly faded out until the unit was off.  I turned it back on and was able to continue with no evident damage.

 

As a programmer, this behavior looks to me very much like the unit is building up overhead, either in memory or a file, then reaches a point of capacity, and crashes.  It has never crashed within the first hour of use, but only after one to three hours of heavy use.

 

An encouraging session, in any case.

 

Share this post


Link to post

I can often get mine to crash hard while navigating on road with guidance, when I deviate from the route. I get frequent crashes when searching for a POI by name, too. Sometimes, it's seemingly for no reason,

 

I always give it time to "think" before pressing more buttons. I'm very gentle with it because I'm hoping to avoid crashes as much as possible. I have no mobile internet, so losing data really stinks, even if I can reindex the files from the SD card. Doing that in the woods or on the river, especially since it takes so long, is no fun.

Share this post


Link to post

Others have said the 2.70 GPS chipset update was bad. Maybe it’s specifically bad if Expedition mode is used.

 

It’s a shame there have been no updates at all for a couple of months now. I guess they are busy with the even newer models.

 

 

Share this post


Link to post
9 hours ago, _Art_ said:

Others have said the 2.70 GPS chipset update was bad. Maybe it’s specifically bad if Expedition mode is used.

 

It’s a shame there have been no updates at all for a couple of months now. I guess they are busy with the even newer models.

 

 

 

They are very busy producing ten thousand different watch variations for..... I dont know who.

Share this post


Link to post

I have found a tactic which seems to totally prevent crashes of the 66:  During a long day of caching, turn the unit off and back on at least once an hour.  That has worked for me several times now, including on a 10-hour trip yesterday, during which I had no problems whatsoever.

 

To me, this pretty much proves the "garbage collection" idea - the assumption that the unit is building up data in memory or storage, and when that reaches capacity, it crashes.  Turning off and on appears to initiate a clean start.  

 

All theory, but I have little doubt that it would have crashed multiple times yesterday otherwise. 

 

I plan to call Garmin soon and discuss this idea with them.

 

Hope this helps other users!

 

Share this post


Link to post

6 months ago after reading this thread I bought a 64S on sale instead of the 66S despite all its added bells and whistles.

Coming back, I don't regret it. Besides the 66 is so much more bulky.

 

For geocaching a smartphone is easier anyway BUT I WOULD NEVER rely on a smartphone into the wild ! I carry both  now.

Share this post


Link to post
1 hour ago, Suscrofa said:

Besides the 66 is so much more bulky.

 

So..... That extra one tenth of an inch, or two percent increase in size really crowds you, huh?

 

8^)

Share this post


Link to post
On 9/11/2019 at 1:26 PM, Geoticca said:

Garmin does not provide any downgrade from 2.70 o 2.60 - info from garmin hotline :-(

If you still want to back up a version of chipset firmware on your 66, you can find 2.60 here >> https://www.gpsrchive.com/GPSMAP/GPSMAP 66/index.htm

Not sure why you'd want to do that, though.

 

Edited by ecanderson

Share this post


Link to post

I had to wrap the 2.60 GPS chipset update in a 2.70 GCD container to downgrade the chipset firmware.

It doesn’t accept older firmware versions like it does with the normal device firmware.

Someone complained it made expedition mode play up. I don’t use it so don’t know,

but I was suspicious that 2.70 was not available to everyone for a long time.

 

Share this post


Link to post
On 9/21/2019 at 1:05 AM, Seawind said:

I have found a tactic which seems to totally prevent crashes of the 66:  During a long day of caching, turn the unit off and back on at least once an hour.  That has worked for me several times now, including on a 10-hour trip yesterday, during which I had no problems whatsoever.

 

To me, this pretty much proves the "garbage collection" idea - the assumption that the unit is building up data in memory or storage, and when that reaches capacity, it crashes.  Turning off and on appears to initiate a clean start.  

 

All theory, but I have little doubt that it would have crashed multiple times yesterday otherwise. 

 

I plan to call Garmin soon and discuss this idea with them.

 

Hope this helps other users!

 

I’ve always had it in my head that it’s watchdog timer expiry.

Especially since I can have it crash drawing a map in seconds if I provoke it.

 

Share this post


Link to post
6 hours ago, Atlas Cached said:

What are the 'new bugs'?

I'm guessing that Geoticca he was just conjecturing that, perhaps, there's an off chance that the 4.10 code won't be bug free. I'm happy to hear you think otherwise.

 

I can't judge: Garmin Express still says my 66st is up-to-date with 3.40.

 

Share this post


Link to post
3 hours ago, dprovan said:

I'm guessing that Geoticca he was just conjecturing that, perhaps, there's an off chance that the 4.10 code won't be bug free. I'm happy to hear you think otherwise.

 

I can't judge: Garmin Express still says my 66st is up-to-date with 3.40.

 

 

Let me know if you want 4.10 now....

Share this post


Link to post
42 minutes ago, Atlas Cached said:

Let me know if you want 4.10 now....

I'll take it when it's available. Is it available now or not?

Share this post


Link to post
42 minutes ago, dprovan said:

I'll take it when it's available. Is it available now or not?

I updated to version 4.10 on March 17 via Garmin Express. 

Share this post


Link to post
1 hour ago, dprovan said:

I'll take it when it's available. Is it available now or not?

 

Have you tried Garmin webupdater yet?

Share this post


Link to post
3 hours ago, Atlas Cached said:

Have you tried Garmin webupdater yet?

Dunno what that is. Shouldn't I trust Garmin Express? Why does it update some people and not others? It's still telling me my 3.40 is "up to date" even though it updated luvvinbird. Doesn't Garmin like me?

Share this post


Link to post
10 hours ago, dprovan said:

Dunno what that is. Shouldn't I trust Garmin Express? Why does it update some people and not others? It's still telling me my 3.40 is "up to date" even though it updated luvvinbird. Doesn't Garmin like me?

 

WebUpdater often finds updates Express does not. Express has a number of issues that can prevent some users from seeing available updates.

 

The GPSrChive > GPSMAP 66 > Firmware page has the current update and information on how to install it manually if you do not want to wait on express.......

Share this post


Link to post
On 3/20/2020 at 9:23 AM, Henne1312 said:

Updated my 66s today via Wi-Fi

I was curious about this since, as it happens, my 66st has been connected to WiFi the whole time we've been having this conversation, yet it's gotten no update that way, either. It was also plugged into USB, although I use the "spanner" mode and had told it not to go into storage mode, so I was assuming it would do anything it would do when it wasn't plugged in, yet after 2 days: nothing. When I restarted under battery power, it very quickly found the update over wifi, so now I have the new bugs, too! (Sorry, I can't tell you what they are yet.)

 

When I reconnected to USB, now all updated already, Garmin Express immediately told me there was a new update available through WiFi, so did I want to update? Very amusing. I connected up but, of course, nothing new was there since it's already on 4.10 now.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  
Followers 3

×
×
  • Create New...