Jump to content
Sign in to follow this  
Followers 2
rassilon256

GPS readings in app not updating

Recommended Posts

Hopefully there’s already discussion of this I just couldn’t find.

 

I’m at a Mega with four lab caches, in preparation for which I downloaded the app on iOS 12.2 over a month ago and downloaded the most recent update when it came out.

 

When I arrived today the app still said that I was 22km away (about the distance to my home). After relaunching, turning location services and all connectivity options off and on, and restarting the phone, I had to delete and reinstall the app before it would work. Then I completed a 5 stage Lab without issue and 9/10 stages of another. Data reception was poor and I wanted to be elsewhere so I left and returned two hours later. The app now says I’m 449m south of the first stage and 179m north of the final stage, no matter what I do. Despite this, the dot on the map indicating my location is always accurate.

 

The Geocaching app and Google Maps are both working fine and I’m using Chrome to post this so there isn’t an issue with the phone and GPS or data.

 

Two questions:

Is there a solution to this?

If I delete and reinstall the app again will I lose my progress on the Labs I’ve done/ partly done?

  • Helpful 1

Share this post


Link to post

If you head to https://labs.geocaching.com/ and log in - you can click on the down arrow in the top right.
Click on View Logs
That will show you the progress you've made with Adventures (and Lab caches).

 

If you have completed several stages/stops in an Adventure - you'll see them in that list.
That will give you peace of mind before you experiment with your phone - you won't lose those completed stages/stops.

 

If there is a bug in the app (or an incompatibility with that version of iOS) - hopefully HQ can address it.

 

You could ask someone who has a different device to accompany you to that location; load the app on their device.
You can then log in with your Player account on their device - and complete the Adventure in the meantime.

Share this post


Link to post
10 hours ago, rassilon256 said:

When I arrived today the app still said that I was 22km away (about the distance to my home). After relaunching, turning location services and all connectivity options off and on, and restarting the phone, I had to delete and reinstall the app before it would work. Then I completed a 5 stage Lab without issue and 9/10 stages of another. Data reception was poor and I wanted to be elsewhere so I left and returned two hours later. The app now says I’m 449m south of the first stage and 179m north of the final stage, no matter what I do. Despite this, the dot on the map indicating my location is always accurate.

This is exactly the same problem, which two cachers, who wanted to play my own ALC today, reported to me. They had to give up, because the app insisted that they were 24km away from location even though they were dead on at GZ.

So there is definitely a new bug in the app, and a rather severe one to boot. Better fix it asap... ;) .

 

Share this post


Link to post

I had time to play around a bit...

  • I can totally reproduce the problem. Displayed distance to my own ALC (and all others as well) stays constant, even though my phones geo-location is active and shows my actual position (e.g. in Google Maps).
  • Restarting the app, logging out and back in, or restarting the phone has no effect at all.
  • Deinstalling and reinstalling the app seemed to solve the issue. Indicated distance was responsive again. Alas, it didn't last long. When I closed the app and reopened it, the distance was again "frozen".

As a result, the app is currently completely unusable.

  • Upvote 1

Share this post


Link to post

His happened on both our iDevices yesterday in London, UK. Even though our position on the map was right on top of GZ, compass said we were over 400metres away. Logging out then in didn’t work. Checked location services on. Compass and maps working in Cachly, GC app. Shutting down app, shutting down phone, didn’t work. Uninstalling  app then reinstalling app worked. A very expensive fix using data in field while trailing overseas. Unfortunately this only worked for the 1st three labs because we made the mistake of opening another application and our position returned to being fixed elsewhere 

Very unsatisfactory . At least when you can’t find a geocache you can log a dnf giving CO feedback

  • Upvote 1

Share this post


Link to post

The first two photos show my app map this morning from my hotel room with the same wrong distances as yesterday. The next two photos show correct distances after uninstall/ reinstall. I have uninstalled the app a number of times since Monday 

F9F31F6F-C243-4838-B721-7F7310E5BF55.png

E0AD5E2D-595E-4888-BCFF-763B83B00A89.png

C941AC3F-12E6-4595-ADED-57591FF47B70.png

6EFED5F3-F8F1-45FD-8E39-15FC2EC8DA2D.png

Share this post


Link to post

Currently at the OzMega in Wollongong, and I've personally told a dozen people how to clear data, login again and itll work again (android, iOS is reinstall as far as I can see). The mega has patchy mobile reception, so it's impacting people's experiences with the app. (Download times and having to reinstall continually)

 

I had to do it every waypoint in a 10 point AL today. It's pretty average software. I know it's Beta - but it seems to be pushed into prod without real thought as to how it's going to frustrate the average catcher when it goes pear shaped

  • Upvote 1

Share this post


Link to post

Likewise @andrewbt, I've been at the OzMega and had to uninstall/reinstall several times on iOS while several people I saw using Android had to go through that routine. Very frustrating, especially in bad reception areas where it takes a while to download the app again.

 

That said, I completed three labs in the last two days and though it is a major issue this has been the only bug I've found. There are other things I don't like about the app but they're all features. They didn't impact play (except needing data access to return every answer), and if Groundspeak keep getting feedback they'll be able to improve the features.

Share this post


Link to post

I didn't have that issue with the prior version of the Adventure App.  Maybe those communication or feedback features and something with the map they added caused the new problem. 

I think I like the old version of the app better, and will stick with it until they force me to upgrade to the problem-laden version.

Share this post


Link to post

I had the issue yesterday when attempting to do the new labs in Derbyshire. The app thought I was still at home, almost 20 miles away. I’ve looked again today at the ones at Ironbridge. The app now thinks I’m in Derbyshire but I’m actually at work in Rutland, about 70 miles from the caches.

C8EA5493-DB4D-40AA-9D7E-FD15FF6DCF5C.png

Share this post


Link to post

Hi,

Sorry to hear about the bug. We're testing out a fix over the air.

Follow these steps to get the latest version with the fix:

  1. Ensure that the app is closed and is not running in the background
  2. Open the app and wait a few seconds (This downloads the fix)
  3. Close the app and ensure that it's not running in the background
  4. Open the app again (This starts the app with the fix)

If this resolves the issue then we'll ship this fix in the next version deployed to the app store.

 

Thank you

  • Upvote 1

Share this post


Link to post
1 hour ago, syntaxerror said:

Hi,

Sorry to hear about the bug. We're testing out a fix over the air.

Follow these steps to get the latest version with the fix:

  1. Ensure that the app is closed and is not running in the background
  2. Open the app and wait a few seconds (This downloads the fix)
  3. Close the app and ensure that it's not running in the background
  4. Open the app again (This starts the app with the fix)

If this resolves the issue then we'll ship this fix in the next version deployed to the app store. 

 

Thank you

Can't say if it works.

 

Because the distance is only shown with km precision, and I don't want to drive around right now, I tested it with a GPS spoofing app. I noticed, that the distance freezes as soon as I activate GPS spoofing. I.e. my position which determines the distance is fixed at the first location I select, but I can't change it after that. It remains constant at that point even after I switch off the spoofing. It jumps back to the real distance only after stopping/restarting the Adventure Lab app. Also, when I start the app with GPS spoofing active, I don't get any location at all. It looks a bit like you're trying to implement GPS spoof detection, and accidentally messed up real GPS usage ;) .

Share this post


Link to post

I hope they can keep the spoof blocker working, and get the location corrected.

Share this post


Link to post

I ran a test with "live GPS" on my way to work this morning. As far as I can tell the app seemed to work. I could put it in the background, bring it up again, and it continued to update the distance to the ALC's location.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  
Followers 2

×
×
  • Create New...