Jump to content
Sign in to follow this  
Followers 2
TeamCatalpa

App won't navigate.

Recommended Posts

I just updated the gecaching app because it no longer had the blue dot to indicate my location.  It would navigate and everything else worked, but there was no way to plan which way to go when I had no icon on the map.

Well, now the new version with the trippy satellite zoom in thing (which I really don't like!) won't navigate at all!  No matter how far I drive, the app stubbornly remains right where I started.  I tried to find a cache the other day and couldn't get it to work at all.  Fortunately I had cgeo in my phone, so I was eventually able to find it.  But I have trouble with cgeo, it's not intuitive for me and I get confused a lot when I try to use it.  So for those times when I have an unexpected minute to play and don't have my garmin with me, I like to use the regular app.

I uninstalled, reinstalled, rebooted my phone, everything I could think of, but the app just won't work.  There's very little help in the app; hardly anything available in settings to customize it.

Does anyone have some advice?  I'm using an Honor 6x.

Thanks.

Share this post


Link to post

I wonder if it could be related to your version of Android.  What are the versions you get when clicking on the menu, then "Version Info"?

 

I used the regular app just yesterday without problems, besides the coords seeming more 'off' than when I use my handheld GPSr.  On the Map view, I see a blue dot that shows my current location. If I select a cache and then click "Navigate", then it shows the arrow pointer and a blue line from my position to the cache.

Share this post


Link to post

It's on Android 7.0.  And yeah, I get the arrow pointer and a blue line, but that's it.  I started with 3.5 miles to the cache, drove to the cache site, and the app still said 3.5 miles.  It didn't navigate at all, just kept saying 3.5 miles.  I tried with several different caches, and clicking start or navigate brings up the aerial view and the pointer line, but then it just sits there and never moves.

Share this post


Link to post

Are your location services (including GPS) enabled and does the geocaching app have permission to use it?

  • Upvote 1

Share this post


Link to post
On ‎4‎/‎25‎/‎2019 at 7:21 PM, TeamCatalpa said:

I'm using an Honor 6x.

 

There are topics around here about Huawei phones in particular showing blank screens or no caches, and it was some king of Google Play thing.  Maybe a new glitch has appeared.  And according to this, you're behind on the updates.  You should be at Android 8.0, maybe.

 

But I also like StefandD's suggestion to check the App permissions.

 

 

Edited by kunarion

Share this post


Link to post

Yes, I did check that location was on and that the app had location permission.  🙄

 

I checked out that other link, but my phone's model number is not included and it's as up to date as I can make it.

 

The app was fine until it stopped showing the blue dot, and ever since I downloaded the latest version, it's useless.  Today I tried to look at a couple of new ones that were published and the map won't even display properly.  I don't think it's the phone, since everything else, include cgeo, is working.

Share this post


Link to post

Nope, the app is useless.  I've tried everything short of doing a factory reset on my phone (which I'm not going to do) and it won't navigate.  Thankful  to have cgeo!  Had a chance to grab a cache during lunch today and the official app wanted no part of it.  I don't normally carry my GPS with me while working, so would have been really bummed to have a few minutes and not be able to cache.  

Share this post


Link to post

Let's focus on diagnosing, and hopefully fixing, the problem with the official app, and stop the repeated mentions of unauthorized applications.  Thanks.

Share this post


Link to post

It's not a problem with the official app. All apps use underlying Android technology to get location data... not the app itself. Groundspeak app is using the recommended way by Google to get location data, c:geo does not. There is something else going on.

Edited by SpiritGuide

Share this post


Link to post

Well,  yes,  it is a problem with the "official" app.  It just doesn't work on my phone since the last update.  It used to work,  and everything else on my phone checks out just fine, but the "official"  app will no longer navigate.  It would be nice if the non-samsung phones were considered when writing app updates; there's a lot of androids out there and many of them are used for caching.  Hopefully the "official"  app will be fixed and useful again some day.

Share this post


Link to post
4 hours ago, TeamCatalpa said:

Well,  yes,  it is a problem with the "official" app.  It just doesn't work on my phone since the last update.  It used to work,  and everything else on my phone checks out just fine, but the "official"  app will no longer navigate.  It would be nice if the non-samsung phones were considered when writing app updates; there's a lot of androids out there and many of them are used for caching.  Hopefully the "official"  app will be fixed and useful again some day.

Is it a Samsung vs the world issue? Or is it the version of Android that your phone is running?

 

I recently upgraded my phone, because my old phone was running KitKat (Android 4.4.x) and apps were refusing to upgrade, and apps that relied on server connections were refusing to run. My new phone runs Pie (Android 9.x) and the apps are happily running and upgrading again.

Share this post


Link to post

Hi there,

 

I just installed the Geocaching app on my Moto X4 with Android 9 (initially it had Android 8, but I upgraded months ago). When I click the GPS icon on the map, the app just keeps "thinking" ad infinitum. I authorized the app to use my location (and checked an double checked). I have several other apps that use my location and not one of them has this problem (and this I also double checked).

Share this post


Link to post

Yeah, it seems like there's some sort of glitch in the "official" app. My phone is up to date, but the app won't work.  All the other apps work, so I'm just not able to use my bought and paid for Groundspeak app..

Share this post


Link to post
1 hour ago, TeamCatalpa said:

bought and paid for Groundspeak app.

 

Uh...  Years ago there was a paid app from Groundspeak.  It no longer works, even if you still have it.  The current app is free, and paying for premium membership is optional.

 

This seems to be a discussion about the current app.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  
Followers 2

×
×
  • Create New...