Jump to content
Sign in to follow this  
Followers 2
De Zuidjes

No HTTPS in the GPX download file or pocket query

Recommended Posts

 

I noticed when I make a pocket query and then a download of this query does not send the URL in the file as HTTPS.

The same when I download the gpx file from the geocache page.

 

Sample of the file:   

    <name>GC29M3R</name>
    <desc>Op Fietse! # 06 - Diphoorn by MetSKIK, Multi-cache (1.5/1.5)</desc>
    <url>http://www.geocaching.com/seek/cache_details.aspx?guid=ebfce1b5-cce7-4654-af50-fedce8364c4b</url>
    <urlname>Op Fietse! # 06 - Diphoorn</urlname>
    <sym>Geocache Found</sym>
    <type>Geocache|Multi-cache</type>
    <Groundspeak:cache id="1723378" available="False" archived="True" xmlns:Groundspeak="http://www.Groundspeak.com/cache/1/0/1">
      <Groundspeak:name>Op Fietse! # 06 - Diphoorn</Groundspeak:name>
      <Groundspeak:placed_by>MetSKIK</Groundspeak:placed_by>
      <Groundspeak:owner id="3367808">MetSKIK</Groundspeak:owner>
      <Groundspeak:type>Multi-cache</Groundspeak:type>
      <Groundspeak:container>Micro</Groundspeak:container>
      <Groundspeak:attributes>
        <Groundspeak:attribute id="13" inc="1">Available at all times</Groundspeak:attribute>
        <Groundspeak:attribute id="15" inc="1">Available during winter</Groundspeak:attribute>
        <Groundspeak:attribute id="19" inc="1">Ticks</Groundspeak:attribute>
        <Groundspeak:attribute id="32" inc="1">Bicycles</Groundspeak:attribute>
        <Groundspeak:attribute id="1" inc="1">Dogs</Groundspeak:attribute>
      </Groundspeak:attributes>
      <Groundspeak:difficulty>1.5</Groundspeak:difficulty>
      <Groundspeak:terrain>1.5</Groundspeak:terrain>
      <Groundspeak:country>Netherlands</Groundspeak:country>
      <Groundspeak:state>
      </Groundspeak:state>
      <Groundspeak:short_description html="True">&lt;img src=
"http://img.geocaching.com/cache/865799d3-1c44-44b2-ae94-36d8f56050ef.jpg"

 

When I look at a new geocache file (GC82TBD), the same problem.

Only the url has been changed to https the other url's not.

 

<gpx xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" version="1.0" creator="Groundspeak, Inc. All Rights Reserved. http://www.Groundspeak.com" xsi:schemaLocation="http://www.topografix.com/GPX/1/0 http://www.topografix.com/GPX/1/0/gpx.xsd http://www.Groundspeak.com/cache/1/0/1 http://www.Groundspeak.com/cache/1/0/1/cache.xsd" xmlns="http://www.topografix.com/GPX/1/0">
  <name>Cache Listing Generated from Geocaching.com</name>
  <desc>This is an individual cache generated from Geocaching.com</desc>
  <author>Account "Majonicada" From Geocaching.com</author>
  <email>contact@geocaching.com</email>
  <url>http://www.geocaching.com</url>
  <urlname>Geocaching - High Tech Treasure Hunting</urlname>
  <time>2019-01-26T20:44:48.2431012Z</time>
  <keywords>cache, geocache</keywords>
  <bounds minlat="50.934283" minlon="3.161" maxlat="50.934283" maxlon="3.161" />
  <wpt lat="50.934283" lon="3.161">
    <time>2019-01-23T08:00:00Z</time>
    <name>GC82TBD</name>
    <desc>In Memory Of Pandarijntje by Majonicada, Traditional Cache (1/1)</desc>
    <url>https://www.geocaching.com/seek/cache_details.aspx?guid=a5a309d6-fc65-4526-b792-854a03355e7f</url>
    <urlname>In Memory Of Pandarijntje</urlname>
    <sym>Geocache</sym>
    <type>Geocache|Traditional Cache</type>
    <Groundspeak:cache id="7061009" available="True" archived="False" xmlns:Groundspeak="http://www.Groundspeak.com/cache/1/0/1">
      <Groundspeak:name>In Memory Of Pandarijntje</Groundspeak:name>
      <Groundspeak:placed_by>Majonicada</Groundspeak:placed_by>
      <Groundspeak:owner id="18808114">Majonicada</Groundspeak:owner>
      <Groundspeak:type>Traditional Cache</Groundspeak:type>
      <Groundspeak:container>Micro</Groundspeak:container>
      <Groundspeak:attributes>
        <Groundspeak:attribute id="14" inc="0">Recommended at night</Groundspeak:attribute>
        <Groundspeak:attribute id="8" inc="1">Scenic view</Groundspeak:attribute>
        <Groundspeak:attribute id="1" inc="1">Dogs</Groundspeak:attribute>
        <Groundspeak:attribute id="6" inc="1">Recommended for kids</Groundspeak:attribute>
        <Groundspeak:attribute id="15" inc="1">Available during winter</Groundspeak:attribute>
        <Groundspeak:attribute id="24" inc="1">Wheelchair accessible</Groundspeak:attribute>
        <Groundspeak:attribute id="32" inc="1">Bicycles</Groundspeak:attribute>
        <Groundspeak:attribute id="25" inc="1">Parking available</Groundspeak:attribute>
        <Groundspeak:attribute id="41" inc="1">Stroller accessible</Groundspeak:attribute>
        <Groundspeak:attribute id="53" inc="1">Park and Grab</Groundspeak:attribute>
      </Groundspeak:attributes>
      <Groundspeak:difficulty>1</Groundspeak:difficulty>
      <Groundspeak:terrain>1</Groundspeak:terrain>
      <Groundspeak:country>Belgium</Groundspeak:country>
      <Groundspeak:state>West-Vlaanderen</Groundspeak:state>
      <Groundspeak:short_description html="True">
</Groundspeak:short_description>

 

 

It seems that old geocaches are not provided with a new URL with HTTPS

Share this post


Link to post

Part of that looks to have been entered by a human.  Machine fixing that to work well in a XHDR/CORS environment could be challenging.

You'd make a better case for you wish if you offered ways it's wrong, examples how it would look after, what that change/fix would enable that let you find caches you can't now, etc.

 

Share this post


Link to post

So why is this an issue? I'm sure there is already URL rewriting going on to replace http with https so that's where you'll go anyway.

  • Upvote 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 2

×