Jump to content
Sign in to follow this  
Followers 3
Funky_Boris

Message center generates mail with wrong subject/content

Recommended Posts

I have come across a peculiar bug. When I click the "Message this owner" link on top of a cache description, I get redirected to the message center (which is what to expect) and a new conversation with that user us commenced with a prefix "Regarding <GCcode>: <Title> – ". When I then use it to send a message, I get a mail saying that I got a new message from myself:

 

"Geocaching: Funky_Boris, you have a new message from Funky_Boris!"

 

The message body then starts with "Funky_Boris has sent you a new message." followed by my message. Underneath there is more:

"Visit the Message Centre to view and reply to this message.

View Funky_Boris’s profile"

 

I have not gotten any replies from any of the messages sent in this manner which prompts the question of whether the messages have even been delivered. When I open the message centre they seem attached to the correct conversation with the intended recipient. I certainly get a reminder that I have sent a message to myself.

 

Perhaps someone from Geocaching HQ should see if they can reproduce the bug and fix it if that is the case?

  • Upvote 1

Share this post


Link to post
1 hour ago, Funky_Boris said:

I have come across a peculiar bug. When I click the "Message this owner" link on top of a cache description, I get redirected to the message center (which is what to expect) and a new conversation with that user us commenced with a prefix "Regarding <GCcode>: <Title> – ". When I then use it to send a message, I get a mail saying that I got a new message from myself:

 

"Geocaching: Funky_Boris, you have a new message from Funky_Boris!"

 

The message body then starts with "Funky_Boris has sent you a new message." followed by my message. Underneath there is more:

"Visit the Message Centre to view and reply to this message.

View Funky_Boris’s profile"

 

I have not gotten any replies from any of the messages sent in this manner which prompts the question of whether the messages have even been delivered. When I open the message centre they seem attached to the correct conversation with the intended recipient. I certainly get a reminder that I have sent a message to myself.

 

Perhaps someone from Geocaching HQ should see if they can reproduce the bug and fix it if that is the case?

 

You can try sending me a message. :-)

Share this post


Link to post

I have exactly the same problem :

 

I receive by e-mail messages that others users send to me (great !) but also a copy of all messages I sent to others users... (not great !)

 

Example :
t image.png.91daeca4ace6e63c14dcc0032821450e.png

Edited by @rthur
typo

Share this post


Link to post
1 hour ago, @rthur said:

I receive by e-mail messages that others users send to me (great !) but also a copy of all messages I sent to others users... (not great !)

 

I want all of them. For me it is a great feature.

Share this post


Link to post

@Funky_Boris - Thank you for bring this up because it could be more clear. The email that you are receiving is a copy of your own message. This happens if you have selected the option in Message Center to "forward messages to email" (see attached). When that feature was added we re-used the existing email template which is causing your username to be added twice because you are both the sender and the receiver of the email.

 

"Geocaching: {receiving_username}, you have a new message from {sending_username}!"

MessageCenter.png

  • Helpful 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 3

×