Jump to content
Sign in to follow this  
Followers 3
Pontiac_CZ

please restore blue selections in FF and Safari

Recommended Posts

Please deactivate CSS ::selection pseudo element with {text-shadow: none;} on logging page, it is higly inconvenient to make a selection without actually seeing it.

  • Upvote 4

Share this post


Link to post

Or more generally, don't break things that are part of the normal user interface. For example:

 

 

  • Upvote 1

Share this post


Link to post

Yes. And I've opted to add my own custom CSS to give some more contrast for highlighted/selected text throughout the entire site. Highlighted text, link text - both seem to be inconsistent across the site, but most noticeably annoying on the logging page.

  • Upvote 1

Share this post


Link to post

And I thought it was just some unknown browser setting I had inadvertently clicked.

Share this post


Link to post

Hello, anyone from the support team listening ? Please disable this feature, it's still there!

Edited by Pontiac_CZ
wording

Share this post


Link to post
5 hours ago, barnold said:

Also the selection is missing in the message centre

I have to add, of course, that this occurs in Firefox.

in Chrome there seems to be no problem. Selections are clearly marked, as it should be.

Share this post


Link to post

It's good to see that it isn't just me. I was thoroughly confused when I found that I apparently couldn't select anything on the logging page anymore. I now see that it does select, but the selection formatting change isn't being displayed, so there's no indication that the selection is succeeding. I use Firefox almost exclusively for caching on my home computer.

  • Upvote 1

Share this post


Link to post
1 hour ago, The A-Team said:

It's good to see that it isn't just me. I was thoroughly confused when I found that I apparently couldn't select anything on the logging page anymore. I now see that it does select, but the selection formatting change isn't being displayed, so there's no indication that the selection is succeeding. I use Firefox almost exclusively for caching on my home computer.

 

Same here! 

I recently muddled through logging 136 caches, and the inability of seeing what I tried to select was very frustrating. Why can't someone fix this issue, or at least acknowledge that they are now aware of the issue?

  • Upvote 1

Share this post


Link to post
1 hour ago, K13 said:

...or at least acknowledge that they are now aware of the issue?

They generally don't acknowledge or otherwise discuss issues, because that leads to expectations that the issue will be resolved. Based on past performance, it's also unlikely that we'll see any notification that the issue has been resolved. We'll probably know when (if?) this issue has been resolved when we try to select something and it works as expected.

  • Upvote 1

Share this post


Link to post

I use greasemonkey and have already added a bunch of custom scripts to "fix" the website to my liking, and this :selection thing with the 'new' pages was a recent "fix".

I just added a "::-moz-selection,::selection { background: #DDF; }" clause to the global css to be thorough. Very annoying.  (make the colour whatever you want; high contrast color foreground and background)

Edited by thebruce0

Share this post


Link to post

For those experiencing this issue, can you tell me what version of Firefox or Safari you are using? Also, what OS/version you're running. I'm able to see text selection styles in both Safari and Firefox. Additionally, the ::selection pseudo element with text-shadow: none is not a new change. We've had that style in place for over a year.

Screen Shot 2018-09-14 at 11.10.36 AM.png

Screen Shot 2018-09-14 at 11.10.46 AM.png

Screen Shot 2018-09-14 at 11.11.25 AM.png

Edited by Sassy Bandit

Share this post


Link to post

Hitting Ctrl-A on that same page (same effect as blocking with the mouse) "highlights" all the text - verified by pasting whatever's on the clipboard into Notepad. In doing so, I noticed the highlighting appears when the page body no longer as the focus (different window selected, or even the address/search entry boxes in the browser frame)

 

Highlighted:

image.png.3d47cc140c2efcdf1956d8bd0456318a.png

 

Highlighted with body not having the focus:

image.png.6563d6c54d9e70f61f264a6727174cb4.png

 

I'm using Firefox 63.0b2 64-bit Dev edition.

 

If I turn on my custom CSS, this is what I get, all the time I select text, the only difference being I force a background colour on the pseudo-element:

image.png.4f520cd02e3b04eb2c76b78e75905eff.png

 

This strangeness of the ::selection happens on all the 'new' website page and not their old versions (new dash, new logging, new drafts, new lists, message center, likely some others too)

Edited by thebruce0

Share this post


Link to post

Using FF 62.0 in Win 10

When I select text, I cannot see that it is highlighted, as others have reported.  I can Ctrl-C copy it and paste it elsewhere.  However, while it is highlighted (invisibly), when I type a characte, it is inserted into the visible string instead of replacing the selected text as it should if the text were correctly selected.

Edited by GeoTrekker26
fix typo

Share this post


Link to post

I'm seeing the problem on Firefox 62.0 running on 64-bit Windows 10 Home (version 1803 build 17134.285). In the screenshot below I've "highlighted" all the log text, and if I press Del the whole text disappears so internally it's selected it, it's just not showing.

 

Highlight.png.e964603ddf248c0d021809e0033bfb35.png

Share this post


Link to post

Problem with FF v 62 64-bit as reported above.

 

There is a problem to mark a text when you can't see it highlighted in PM. You can still copy all the text and paste it to your notepad, or if you are lucky you can copy a part of a text do you need. Other option is to use Chrome. 

 

Please fix it.

Share this post


Link to post

Firefox v62 64 bit with no add-ons enabled on Windows 10 Pro build 17134.228

 

There's also some strange things happening with the Personal Cache Notes field on the cache page. Previously I could click anywhere in the field to edit it, but now I have to click on the text already there to open the edit box

Edited by reybr
Added information

Share this post


Link to post

Seems to be working as expected for me, FF 61.0.1 (64-bit)  on Linux. I don't have any custom CSS or any greasemonkey scripts active for the logging pages.

 

 

image.png.a952447b19ac57026073972fdad4dcd9.png

Share this post


Link to post

I should add this highlighting issue has been around for quite some time. I lived with it until recently when I implemented my CSS fix.

Share this post


Link to post

This triggered some memory circuits...  Yes!  Some time ago I had troubles in Firefox with things not displaying properly, colors white on white or something like that.  According to my notes, setting layers.offmainthreadcomposition.enabled=false in about:config fixed things up, and then I forgot all about it.

 

This advice comes with no warranty, of course.  But it might help.  Good luck, and let us know.

Share this post


Link to post

FF 62.0 x64 on Windows 7.

 

I confirm thebruce0 investigation - I press CTRL + A, the selection has been made but not highlighted. Then I click into the address box and voila - the highlighting appears.

Share this post


Link to post

I only started seeing this within the last couple of weeks, so it may be something slightly different than what thebruce0 and Viajero Perdido have seemingly been experiencing for a while. I'm currently running FF Quantum 62.0 64-bit on Win10 1803.

 

Interestingly, I realized I still had an older version of FF (56.0.2) installed on my work system. I tested with that and selection worked as expected. I then updated that to the latest version (62.0), and it started experiencing the same issue. This is a completely stock and uncustomized installation, so there's no chance of any about:config changes or extensions being the problem.

 

I was also able to replicate the issue in BrowserStack. FF 61 didn't have the issue, but 62 does.

Share this post


Link to post

Found this thread after coming to the forums to see if this issue had been reported yet.

I've been mostly offline for the past month and just noticed this as I started working through my Drafts a couple days ago.  I'm experiencing the same behavior that barefootjeff described (quoted below).  I'm also seeing this behavior (selected text not visibly highlighted) when editing the "About" section of my Profile.  I do not see this issue when using the 'old' logging page.

 

Firefox Quantum 62.0 (64-bit) - no add-ons or scripts

Windows 10 Pro

 

On 9/14/2018 at 4:30 PM, barefootjeff said:

I'm seeing the problem on Firefox 62.0 running on 64-bit Windows 10 Home (version 1803 build 17134.285). In the screenshot below I've "highlighted" all the log text, and if I press Del the whole text disappears so internally it's selected it, it's just not showing.

 

Highlight.png.e964603ddf248c0d021809e0033bfb35.png

 

Edited by noncentric

Share this post


Link to post

I use Firefox 62.0 and can't see which part of the text I have selected on the site of Geocaching.com. The cursor won't move over the text. Other sites don't have that problem, the selected text is than higlighted.

Share this post


Link to post

I saw the other similar post, and although I don't use Safari, and don't currently have Firefox installed I guess this is related and a suitable place to reply. :)

 

Wow, that selection thing is very naughty!  I tried Chrome, IE11, and Edge, with somewhat varied results. Basically when I try to select something in "Recent Activity" for example in the New Dashboard and can't consistently do so.

 

Here in the bottom log I was able to highlight and copy the exact text I want.  But after I expanded that top log (by clicking "More"), I get the elastic disappearing blue selection bar, and nothing is selected when it snaps away again.  I can at times right click and "Select All" of that log, not just the text I need.  I'll give you one guess why I opt out. B)

 

Untitled-d1.jpg

 

 

Edited by kunarion

Share this post


Link to post

I've also noticed this issue on GeoTour pages. For example, if I try to select anything on this page (ANYTHING, including header, footer, images, text, even anything inside the embedded map), I don't get the expected highlighting.

 

This seems to be an easy issue to replicate, so hopefully the developers will be able to figure out why it's happening and fix it.

Share this post


Link to post

I started another thread before I realized that this one existed so I'll move the conversation here. I can also confirm the text is being selected as I can paste after making the invisible selection. There appears to be inconsistency with this, on the example that The A-Team gave I cannot make a selection, but it works fine for me on the log pages where others above are reporting problems. Now that I know text is actually being selected I can make it work but this is sure annoying. FireFox 62.0.2 on Windows 10 64 bit.

Share this post


Link to post

I received an answer from Geocaching.com:

Hello D-

Thank you for contacting Geocaching HQ.

It appears that this is a specific issue with Firefox 62.0, and the Firefox team is looking into it from what I can tell. In the meantime, downgrading to Firefox 61.x will fix the issue. Instructions on how to do so can be found here.

Best regards,

 

Martin
Community Management Lead
 

2WQi4rq.png

B60NbjH.png

Share this post


Link to post
On 9/21/2018 at 9:47 PM, B&B Joy said:
It appears that this is a specific issue with Firefox 62.0, and the Firefox team is looking into it from what I can tell.

If that's the case, then hopefully that means it will be fixed in the near term.  It's a bit annoying to work around, but not so bad for me to downgrade my FF for just this issue.  I'll just use Chrome to work through my Drafts until it's fixed.

 

It's odd that I see it consistently on the new logging page, new list page, new dashboard page, profile update page, and message center.  But I've never seen it on the old logging page, list detail pages, old dashboard page, or cache pages.  It seems like something about the 'new' formatted pages doesn't agree with FF 62.0

 

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  
Followers 3

×