Jump to content
Sign in to follow this  
Followers 2
Artemis&Apollo

Garmin Drive 50LM, Symbols Not Showing on Map

Recommended Posts

I recently bought a GARMIN DRIVE 50LM to replace my GARMIN NUVI 54 (power jack not working).  I use this extensively for Geocaching (driving to the caches). I keep the GPSr loaded with around 300 local caches, saved as SAVED/FAVORITES.  I then scan the map to see where I want to go caching and use the map to determine my route from cache to cache (favorites/waypoints).  The problem I have with the DRIVE 50LM is that the map symbols go away:

  • If turn off the GPSr (hold power button until it says “Turn off the device?”) the symbols disappear from the map.  They remain in the saved list but they do not show on the map.  It is essential, to me, that I see the symbols on the map.
  • Also, If I turn off “Up Ahead Places” the symbols also disappear from the map.  I’m not interested in the up-ahead function when I am Geocaching because it just clutter’s the map.

It doesn’t matter how the favorites are saved.  It happens when I load them through 3rd party software (my normal way) and it also happens if I SAVE an address or any provided POI.

Can someone help me with these problems?  I can’t image that Garmin would build a GPSr with maps and symbols but not show the symbols on the map.  I must have something configured wrong.

Share this post


Link to post

I know that garmin changed some of the inner workings when they switched from the Nuvi to the Drive series. I might be able to help you come up with an alternative solution though.

First, Do you use a hand-held Garmin GPS for geocaching? If so which one?

Share this post


Link to post

One option you can take is to install a routable map on your GPS and create a profile with settings specifically for driving to geocaches. When you get to the cache, switch to your regular geocaching profile which does not route along roads to make the find. I do this with my Oregon 600, though the process is made a little easier in that the Oregon has a Nuvi-like dashboard. It won't be as pretty as what you were used to, but it does get the job done, and you only need to manage caches on one device - the device which was designed to handle geocaches.

Second option is to navigate to a geocache using your phone, utilizing data stored for offline use.

Share this post


Link to post

I don't have the Drive, but I do have the higher-end Driveluxe 50 (2016 model).

Share this post


Link to post

Is there anyone with a Garmin Drive-series gps that is willing to run a test?  Here is what I see and I'm wondering if others do to.

  1. I add and save an address (I use my home address, where I'm currently at)
  2. I VIEW MAP from the main screen and see the green heart symbol on the map.
  3. I Turn Off the gps (holding the power button until it says "Turn off the device?"
  4. I turn the gps back on and VIEW MAP from the main screen and the symbol is gone. The saved location is still in the list but it is not on the map.

For 10 years I've used the nuvi map to choose my route from cache to cache.  It's like looking at a pocket query map. 

I talked to Garmin support and they said that the symbol did not go away from the map for them.  They suggested a exchange the device I just bought.  I did and the 2nd Garm Drive 50 does the same thing.

I would appreciate it if someone could run the above test for me and let me know what you see.and which model you were using. 

Share this post


Link to post

I don't have a Drive series (sorry), but I'm guessing there's a setting somewhere. For example, do you have your map detail set to most? Do the icons appear if you zoom in on the map? Do they appear if you go into pan/search mode rather than follow mode (ie, touch the screen and drag the map a bit.) 

I apologize if my questions may be frustrating for you, but it's good to eliminate the usual suspects. 

Share this post


Link to post
On 4/11/2018 at 7:51 PM, Mineral2 said:

I don't have a Drive series (sorry), but I'm guessing there's a setting somewhere. For example, do you have your map detail set to most? Do the icons appear if you zoom in on the map? Do they appear if you go into pan/search mode rather than follow mode (ie, touch the screen and drag the map a bit.) 

I apologize if my questions may be frustrating for you, but it's good to eliminate the usual suspects. 

They appear when I first add them (via save address, save one of there POIs, or load via a GPX file).  As long as I don't power OFF the device they remain visible.  When I power OFF the device they go away.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  
Followers 2

×
×
  • Create New...