Jump to content

Updating Wherigo Cartridge


Recommended Posts

I am trying to correct an error in my Wherigo cartridge.  'Quilt Trail'   I have uploaded changes but the only cartridge that can be downloaded is the original.  How do I replace or update it?   Also, I now  have multiple versions in history - how do I delete the ones that are unneeded?

The end result is that cachers keep finding errors when they play my Wherigo cartridge.




Link to comment

I believe you created a completely new listing on the site instead of uploading a new version.  Please check your steps:

  • Go to the cartridge page link listed in your geocache listing.
  • Click the upload GWZ file link on the left side.
  • Upload your new version using that page.  Don't forget to tell what you changed in that box and then post an owner maintenance log on the geocaching listing.

To verify you did it right, on your cartridge page, go to the release notes link on the left side.  You should see that day's date and what you said changed.  Currently, the last time you uploaded something for that cartridge was in March of this year.

  • Helpful 1
Link to comment

Well, I'd rather you hide those interim versions.  What happens if someone searches Wherigo.com by your user name in order to download the cartridge?  For example, this search returns six Quilt Trail results.  We would guess the one with the icon is the right cartridge to download.

To hide a cartridge, just uncheck the "Make this cartridge available in the directory" check box on the cartridges' edit details pages.  It'll only take a minute or two of your time to help prevent someone from wasting half an hour of their time due to downloading the wrong cartridge.

Link to comment

Depending on the builder app you used, you'd open the cartridge file, find your question, and edit the list of answers you have. Then, if you edited the correct answer's text, you would have to edit the if/then statement that validates the correct answer. 

After that, you would need to generate the GWZ file and upload it as a new version to your cartridge listing on Wherigo.com, then post an owner maintenance log on your geocache listing. 

If you mentioned the builder you used, you can receive a more detailed answer. 

Hello from Prince Edward Island in Canada!

Link to comment
8 hours ago, The Cooke Family said:

I use the kit for my cartridge and have just uploaded an updated version of the cartridge due to an error on the original. Will the update go out to everyone who has already downloaded the carttridge or do I have to inform them of the update



You'll have to inform them.


Wherigo cartridges are not linked to the Wherigo.com repository, regardless the Wherigo builder used to create them.

Link to comment

I used your Wherigo kit to create GC593PK . It worked fine until about 2 years ago and then one zone's question almost always could not be answered. It showed an error. Our message was to check their spelling and try again.


The question was at zone 4 (The Museum). The question was What was the original use for the building? Goldsboro _____ ______ ( 2 words) Answer is: Woman's Club


We downloaded the newer version of Wherigo and tried to play the Wherigo again today. No luck at the museum.


I am now using a Mac and can't find the original cartridge to update it. I no longer have the Windows computer I probably created it on.  We've archived the cache but would really like to fix it and reenable it. 


If I could fix the question I would change it to: What is this building used to today? One word. Answer: Museum


*** We created this under our name 2 jolly but let njms1 adopt it. njms1 is our original caching name. We were looking for things to do during Covid and decided to play our own Wherigo's and that's when we understood the problem other cachers had. 


Thanks for any suggestions.




Link to comment

Try removing the apostrophe from the requested answer.  I bet that's it.


The apostrophe is an interesting character.  Some phones replace the standard apostrophe character with another one entirely.  It's not just a font thing: it's a different character code entirely.


I know about this because my mother's geocaching user name uses an apostrophe.  When I was helping her sign in to the geocaching app on her phone a couple years ago, I noticed the phone kept replacing the apostrophe character with another one.  To get it so she could log in, I had to pull up her profile in a web browser, copy her user name, and paste it into the app's login box.  Honestly, I never connected that to what would happen with Wherigo when someone tests for an apostrophe in their answer.

Link to comment
Posted (edited)
46 minutes ago, Ranger Fox said:

When I was helping her sign in to the geocaching app on her phone a couple years ago, I noticed the phone kept replacing the apostrophe character with another one. To get it so she could log in, I had to pull up her profile in a web browser, copy her user name, and paste it into the app's login box.


Likely irrelevant by now, but if it's an iPhone, one can long-press on the single quote/apostrophe button to choose the desired quote symbol.


Incidentally: the Adventure Lab app is smart and normalizes all the weird quotation symbol variants to (what a programmer would call) the single quote character (ASCII 39).

Edited by Hügh
Link to comment

Hugh’s suggestion worked. Holding the apostrophe key down gave us 4 choices. We tried them all but only the one on the far right worked. We got to the last zone of our Wherigo and found the location had changed and the answer wasn’t available. 

So, I’m glad the mystery of why this didn’t work is solved and I learned a new trick. The Wherigo will stay archived. Thanks Ranger Fox and Hugh for responding.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...