Jump to content

Hand tool in the map

Followers 16

Recommended Posts

hi there,

I don't understand everything you write about overlays and servers but I do also encounter this error. It just started today. from one moment till the other i was not able anymore to click on the chache symbols in order to open them or geht the tiny window as preview. First i thought maybe restarting Chrome Browser would help but it didn't.

From reading your posts here I do not seem to be the only one.


Win . 7, 64bit

Google Chrome Browser (latest version up to date from today - this post date)

language: german

Filter settings on map: none

standard settings for map - I never bothered about the map since it seems to be very accurate. Is it google's map?


Thanks for any help or input on this issue,


happy hunting,

Petzikuss (Vienna / Austria)

Link to comment

It is really curious. I had the Problem one week ago for about one day, next day (saturday) it was working sometimes and from sunday it was fine until today. Now i have the same issue again with the hand tool, no browser (IE, FF48.01., Iron,..) show any Information if i move over to a cache.


I guess it is a hint to tell me we should go out gehaching only during the week ?

Link to comment

Wondering if Groundspeak is searching in the right spots...

Based on all the evidence it clearly has nothing to do with browser/os or user action.

It could be reproduced in many ways, even by simply loading the tiles via cURL.


The .info tile needs the .png to be loaded first. Once that is done .info will respond with data for a some time and then it will go back to 204.

Assuming this is either cached and evicted based on time or cache size there are simple reasons why heavy load could cause the issue.


Maybe you want to check what can cause the .info tile to respond with 204 DESPITE the .png request run before it?


I had offered it before, happy to assist on how to reproduce this.

Link to comment

Maybe you want to check what can cause the .info tile to respond with 204 DESPITE the .png request run before it?


We are aware of this information from our own investigation as well as via input from you and others. So far, it had not been sufficient to produce a resolution.

Link to comment

... it did not work also for me on all of my browsers (IE, FF, Chr) 15 Min. ago, so I was searching for this topic, suddenly it works again on all my browsers just refreshing them.

Wondering what happened in the meantime. Btw: It's 15:32 Central Europe Summer Time when writing this post.

Edited by remix007
Link to comment

OK - might be a complete tangent and even if related might not suggest anything even slightly useful to resolving any onging map issues but...


I've been logging some finds today and I've noticed, intermittently of course, that some of the cache pages are taking forever to fully download and the delay seems to be - according to my browser status bar:


waiting for maptiles.geocaching.com

Link to comment

Happens to me, too. Right from the start, after a search, or after opening a bookmark.


My guess at the cause:

- one library / software version of some critical map component has not been properly updated on a subset (but not all) of GC servers


Really annoying. I have to go to Google now and find the name of the cache (using city name and such) I want to log.


edit: Firefox, latest version, from the Netherlands

Edited by BigFurryMonster
Link to comment

We believe that we finally identified the issue causing the unresponsive map problems. We released a fix on Friday. Are any of you still experiencing issues with clicking map pins?


What I see is, overall, an improvement.


I can pan and zoom around the map now without it freezing i.e. for some reason the map used to stop responding to mouse clicks after clicking a few caches within a small radius and I had to F5 refresh my web browser to get things moving again.


At the moment I can always click on a cache, no matter how many times I've panned / zoomed, without the need for an F5 refresh - which is good :)


What I do notice though is a brief pause between click and the display of the information - not so much that it causes an issue, just that there's a tiny lag there which I don't remember being there before.

Link to comment

In my case, on Mac OS X 10.11.6, with Firefox 48.0.1, independent of the type of map selected, I get frequent hangs and a warning message after a while (see below). The issue is severe though, as the apparent not-running of the script makes the browser hang completely, so I can't use it in the mean time. I usually end up having to force quit the app and start Firefox again. It's very annoying. Ihe beach ball keeps spinning all the time until the warning comes up after a minute or two or zo. I've had this issue intermittently for weeks now, and apparently it's not solved as I'm having it again now.



Edited by NLBokkie
Link to comment

Issues again this morning with not being able to select caches from the map - has been on again, off again for past 2 hr.....

I believe the recent "hand" issue was on top of the intermittent "can't click on caches" issue that has been present since this version of the map was released many years ago. The issue of sometimes being unable to click on caches in a portion of the map is well-known, but the Groundspeak developers haven't been able to fix it. I expect it will never get fixed and we'll just have to wait for the next version of the map, which will likely be built on different software/technologies and hopefully won't have the same problem.

Link to comment

Having the same issue here also. Tried it on three devices, iPad Air 2, Windows 10 work laptop and my personal laptop with windows 7 all running latest updates for their OS. Tried all the latest released of Chrome, IE and Firefox. Have attempted clearing browser history and even reset browsers to deafult with no success.


It had started yesterday evening for me when I kept getting kicked out of the website and would have to log back in again which continued to happen for about 30 minutes and then when I finally got the website to stay logged in it wouldn't let me click on any caches on the map. I have also changed the map providers in case it was an issue with that but still no joy.

Link to comment

Just in case it helps: the live map requires that the PNG for a given tile is requested before the JSON information for the same tile is. Hasn't the backend software changed somehow and the timings are not set right? Couldn't the backend be confused and think that at the time the JSON information is requested the PNG hasn't yet? It might be a race condition.

Link to comment

When I bring up a map of geocaches in either Chrome or Firefox, I am unable to select a cache. The zoom and moving around on the map works.

The hand grab icon (not the select icon) is there when I hover over a cache, but when I click on a geocache it won't bring up the description. The map is locking up as well.

It's an intermittent problem, but occurs more often than not and doesn't appear to be fixed.


How did you navigate to the map? Directly? From the search page map preview? From a PQ map preview?

--From a cache page map or from the search page map preview


Which map layer are you using? Google Maps? One of the Leaflet layers? (If so, which?)

--Google Maps - but tried Leaflet with same problems


Does the bug only occur after certain actions on the map (e.g. zooming, panning)? Or are you unable to open caches as soon as you open the map?

--Only occurs when trying to click on the cache icon in the map to bring up the description


Which browser version and OS version are you using?

--Chrome Version 53.0.2785.116 m (64-bit)

--Windows 10 Home Version 1511 OS Build 10586.589

Link to comment

Although it looks like this issue is being analyzed, I am also reporting that I cannot open caches on the map. I tried different map options, restarting the computer, tried opening in Edge and Safari with same results. I really depend on these maps when planning an outing and it looks like there won't be any geocaching done today. :anitongue::surprise:

Link to comment

Wanted to check out a few caches to grab while on atrip tomorrow but nothing I do will let me view the caches from the map. Tried Chrome, Firefox & Edge, tried different zoom levels, different maps on the leaflet options etc. The hand tool just will not work so effectively no 'active' map.


Haven't tried the PQ method mentioned by some but the caches I have loaded in GSAK work fine if I open GSAK map view.

Link to comment

Hello! An errant deployment yesterday appears to have locked up the resources on several servers including the location where the data is stored for the map pins. The deployment was quickly rolled back, but we are still tracking down the resources that were locked. We hope to have the issues resolved for everyone soon. Thanks!

Link to comment

If I go through the map, I've found I have the same problem at present. But if I then click on Pocket Queries in the panel, and select one of my PQs, I can click on the icon and select the cache.


Thank Optimist..... this is a good workaround - got me out of a pickle last night...... cool.gif

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Followers 16
  • Create New...