Jump to content
Sign in to follow this  
Followers 1
jellis

Need help

Recommended Posts

I've already built two Wherigos using RangerFox kit with no problems. I built another one the same way as the other two but it is not working the same. They are all Questions & Answers. The first two are flawless and cachers love how easy it works. But I went to test my third one and there is a problem that when you enter the zone for the questions it only goes straight to the multiple choice answers. What do you think happened?

Share this post


Link to post

Did you use Kit to make the third or did you begin to branch out and used another builder.

 

If it's the latter, there's something Kit does in the background for people. Let's say you wanted to show a message, then ask a question. In Kit, you tell it that and that's what will happen. However, what Kit actually does in the background is it hooks your question up to an event that happens when the player clicks to dismiss the message. Wherigo is very literal (and that's a good thing, actually). If you tell it to display a message and then ask a question, it will display the message and then, a tenth of a millisecond later, it will ask the question. Wherigo won't wait. So, in other builders, you need to look for something along the lines of setting an action to occur when the player clicks the button on the message.

 

One thing you could do if you're using Urwigo or Groundspeak's builder is you could export one of your other cartridge's GWZ from Kit and import it into the other builder. You can see how Kit wired the cartridge and learn from it.

Share this post


Link to post

Did you use Kit to make the third or did you begin to branch out and used another builder.

 

If it's the latter, there's something Kit does in the background for people. Let's say you wanted to show a message, then ask a question. In Kit, you tell it that and that's what will happen. However, what Kit actually does in the background is it hooks your question up to an event that happens when the player clicks to dismiss the message. Wherigo is very literal (and that's a good thing, actually). If you tell it to display a message and then ask a question, it will display the message and then, a tenth of a millisecond later, it will ask the question. Wherigo won't wait. So, in other builders, you need to look for something along the lines of setting an action to occur when the player clicks the button on the message.

 

One thing you could do if you're using Urwigo or Groundspeak's builder is you could export one of your other cartridge's GWZ from Kit and import it into the other builder. You can see how Kit wired the cartridge and learn from it.

I used your kit on all three. I double checked on the first two to be sure I was doing the same thing on the new one. But it's not acting the same. Most of it is running like the other two except about the questions not showing.

I am doing a message in the ZONE, then a different message in the ACTION before the QUESTION. First try I forgot the message in the ACTION so I thought that was the problem so I went back and added the message in the ACTION before the QUESTION. I deleted the old cartridge from my iphone and added the updated version. And it still was doing it except the first try a split second I saw the question and the updated I didn't see anything.

Share this post


Link to post

Should I just scrape it and redo the whole thing and see if it still does it?

Share this post


Link to post

Okay I tried to make a new one and having the same issue. Next I will have to try copying one I know one that worked and just changing the stories. Wish I can get help why one works and this one doesnt

Share this post


Link to post

Thanks to the cacher who was helpful and patient enough to find out why it was not working for me. We figured out the problem and now I only need to test it one more time before I release it.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  
Followers 1

×
×
  • Create New...