Jump to content
Sign in to follow this  
Followers 4
Jiver78

Bug when using search filter "notes"

Recommended Posts

Wenn I start a seach using the filter "personal note" the results include caches even though I already deleted the note there.

  • Upvote 1

Share this post


Link to post

How soon after removing the notes did you run the search?

 

The "youngest" deleted note is 2 days ago.

The "oldest" note was deleted in begin of april, I suppose.

Share this post


Link to post

There are definitely some bugs going on here. I've notified our engineering team. Thanks!

Share this post


Link to post

Faszinating...

 

I just recognized that a cache with a note deleted today is not displayed in my search.

 

After adding a new note to all caches, that had a deleted note, and deleting this new note all this caches didn't appear in my search results anymore.

Share this post


Link to post

I announced it already half a year ago:

http://forums.Groundspeak.com/GC/index.php?showtopic=338747&st=0&p=5618720&fromsearch=1entry5618720

 

And it still appears regularly:

I search for caches with an individual note and caches appear in the result list which *had* a personal note, but that was deletet long time (months) ago.

 

Interestingly for all caches shown, notes were added end september / begin of october 2016.

 

After adding a new note and deleting it again, the caches disappear in the list of results.

Edited by Jiver78

Share this post


Link to post

Bug still not solved.

 

Actually I get around 10 caches as results when searching for caches with a personal note. Except two of them, all had notes that were deleted weeks ago.

Share this post


Link to post

Today: a search for my caches with a personal note.

The result shows 106 Caches.
Nearly all of them had a personal note once, but deleted weeks to months ago.
All others had a note that is already deleted. Weeks to monthes ago.

(I use the personal note to add comments while I'm on tour. At home all notes are copied to GSAK and deleted on GC.com)

Share this post


Link to post

I can confirm that the issue exists when I spoof log in as you and run the query. I can also confirm that the issue goes away when I add a new note to these caches and then delete it.

What method are you using to add these notes and delete them? Are you using the API, or making the changes via the web?

Share this post


Link to post

add:
I added and deleted new notes in some of the "false positive" listed caches yesterday, so they weren't listed in the results anymore.
Today this caches are back in the list...

Am I the only one with this bug?

Working with GSAK, Win10 and Firefox. But notes I only edit via the website.

Edited by Jiver78

Share this post


Link to post

I can confirm this bug. Searching for "with personal note" found also caches with a "empty" personal note, that I have delete before. The most I have delete a year ago. I tested it today, when I set a personal note in the WebUI, after a few seconds I can found this cache, when I'm searching "with personal note". When I delete the note, after a few seconds it will be found again. After a few minutes, it will not be found. But when I filter to "with personal note" and the cachetype, it will be found again. And after this it will be found also when only search for "with personal note".

Share this post


Link to post

Happy new year, dear bug...

Can I set a NA for the filter "Has Personal Geocache Note"?

NMs doesn't change the status...

Share this post


Link to post

Still problems? It seems like deleting the Personal Cache Note on a cache page doesn't change it to an empty state. When filtering caches which have a Personal Cache Note it also returns caches with Personal Cache Notes I've previously deleted. I'm using Edge on Windows 10. As an example GC7GWR1. I deleted the Personal Cache Note a month ago.

Share this post


Link to post

Oh, I missed the second birthday of reproting this bug....

 

Actually I have about 100 caches with deleted personal note, that are still found when searching caches with the filter "has a individual note"... but it looks like nobody at Groundspeak cares

 

Addendum: looks like the old "workaround" works: adding a new text to the empty note and deleting it again. I will check this tomorrow again. But I'm not willing to do that with 100 caches...

Edited by Jiver78
addendum

Share this post


Link to post

And even with the new API this problem still exists, Hey guys at Groundspeak, what's going on with this problem? You are not able to solve this problem ?

I realized that it happens with a lot of changed notes (>10.000). When I checked it with an account that has only about 1.000 changed notes, the problem does not appear.

Share this post


Link to post

I used the new API call:

gcapi2("geocaches/search?q=hn%2Bpd:[2014-01-01,2014-12-31]&lite=yes&take=100&sort=id&fields=referenceCode")

Edited by Megalodon
info added according API

Share this post


Link to post

I wouldn't have thought this would be a big deal to sort out. As far as fixing the root cause, I wouldn't expect it to take long to figure out which piece of code is failing to clear the flag (it should be in the part dealing with the note deletion). Once that's dealt with, a script doing something like the following could clear up all of the existing instances of the issue:

if($hasNote AND $noteContents == NULL){
	$hasNote = FALSE;
}

I guess the devs have been tasked to work on new features like the new map/search rather than deal with longstanding issues with existing features like this.

  • Upvote 3
  • Love 1

Share this post


Link to post

I think The A-Team is right, but the task to do is not that complicated, I think. Mayby a develloper from Groundspeak can answer ?

 

Share this post


Link to post

I see, nothing getting better here... and even if I delete all the notes, the variables in the database are not reset ?

 

Can please somebody of the programmers respond ?

What for am I paying 30€ per year ? The boxes taht have been put by my friends?

Share this post


Link to post

Just today I remind me this error with too many finds for changed notes, but which are NOT changed any more still exists.

It's a month ago now, how about asking the guys at Groundspeak to fix this issue, it's not that hard to fix, I think, is it ?!

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 4

×