Jump to content
Sign in to follow this  
Followers 11
Forest-Ghost

Wherigo.com downloading unavailable?

Recommended Posts

Has anyone else been having trouble downloading from the Wherigo.com website? I can no longer download any cartridges from the phone or computer. Wherigo.com gives this error when downloading:

 

Error During Upload

 

System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> Attempted to read or write protected memory. This is often an indication that other memory is corrupt. at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall) at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters) at Wherigo.GSPCartridgeService.CartridgeService.GetCompiledCartridgeWithMetaData(GWZMetaData gwzMetaData, String CartridgeFileName, String CartridgeId, Int64 PlayerId, String PlayerName, DeviceType deviceType, String CompletionCode) at cartridge_download.btnDownload_Click(Object sender, EventArgs e)

Share this post


Link to post

I experience the same. I'm happy to see that I'm not alone.

Edited by thopepasa

Share this post


Link to post

I have been having issues uploading a new cartridge as well. I get the following error message.

 

Attempted to read or write protected memory. This is often an indication that other memory is corrupt.

Share this post


Link to post

The same issues,

 

No chances to download any cartridge and no chances to upload a new one (that is going to be published next Thurdsday..).

 

I told the incident to the admins. opening a bug report.

Share this post


Link to post

The good news is it's now a little past 8AM Seattle time. They'll get in, they'll read email, they'll notice something burning... and...

Share this post


Link to post

I hope they fix it soon. I'm having the same issue. There are a half dozen or so wherigos where I am I'd like to tackle and I only have a couple days to do them before I move on to another country. :(

Share this post


Link to post

Someone kicked the server. It's business as usual now.

I rebooted it right around noon PDT. I don't have much experience with supporting Wherigo, so I'm not sure that we'll get far assessing a root cause. Prior to this, it appeared that server had been operating without issue since at least late March.

Share this post


Link to post

I had no problem uploading a cartridge earlier today.. however whenever I try making changes to my listing I get a page that says, "An Error Has Occurred

Your request has resulted in an error. Please return to this site's home page to continue". Same error happens when I try this using a computer or my smartphone. B)

Share this post


Link to post

Trying to load cartridge from link of Geocaching app on my smart phone (worked year ago when tried) I get an error message "Connecting Error". If I chose the option to open browser from Wherigo.com I get "Couldn't establish a secure connection" error message. I have tried same on another phone and on a tablet with same results. I can log on and download on my laptop computer. Any ideas of what to try??

Share this post


Link to post

Trying to load cartridge from link of Geocaching app on my smart phone (worked year ago when tried) I get an error message "Connecting Error". If I chose the option to open browser from Wherigo.com I get "Couldn't establish a secure connection" error message. I have tried same on another phone and on a tablet with same results. I can log on and download on my laptop computer. Any ideas of what to try??

 

Try a different browser.

Share this post


Link to post

Trying to load cartridge from link of Geocaching app on my smart phone (worked year ago when tried) I get an error message "Connecting Error". If I chose the option to open browser from Wherigo.com I get "Couldn't establish a secure connection" error message. I have tried same on another phone and on a tablet with same results. I can log on and download on my laptop computer. Any ideas of what to try??

Yes, you'll have to use another browser for now. I think Chrome is the most sensitive to this issue. The problem is the Wherigo.com SSL certificate (a certificate is necessary when establishing a secure connection to a site--it's HTTPS) is using an outdated cipher and the browser can't guarantee your connection will be secure. To fix it, all Groundspeak should need to do is update their SSL certificate. I notified Groundspeak of this in late June (related thread). I wonder if switching contacts for system-level issues would make a difference? I'll try that this week.

 

Could you please share with me the phone, OS version, and browser app you're using? I can include that in the steps to reproduce.

Share this post


Link to post

Trying to load cartridge from link of Geocaching app on my smart phone (worked year ago when tried) I get an error message "Connecting Error". If I chose the option to open browser from Wherigo.com I get "Couldn't establish a secure connection" error message. I have tried same on another phone and on a tablet with same results. I can log on and download on my laptop computer. Any ideas of what to try??

Yes, you'll have to use another browser for now. I think Chrome is the most sensitive to this issue. The problem is the Wherigo.com SSL certificate (a certificate is necessary when establishing a secure connection to a site--it's HTTPS) is using an outdated cipher and the browser can't guarantee your connection will be secure. To fix it, all Groundspeak should need to do is update their SSL certificate. I notified Groundspeak of this in late June (related thread). I wonder if switching contacts for system-level issues would make a difference? I'll try that this week.

 

Could you please share with me the phone, OS version, and browser app you're using? I can include that in the steps to reproduce.

 

I have just started using a Samsung S3. I only see one browser. OS is android Ver 4.4.2. I also still have my old phone, a Motorola Razer Nax with OS android Ver 4.1.2. My Motorola has two browsers. The crome will log onto Wherigo.con but will not download a cartridge.

Share this post


Link to post

I have just started using a Samsung S3. I only see one browser. OS is android Ver 4.4.2. I also still have my old phone, a Motorola Razer Nax with OS android Ver 4.1.2. My Motorola has two browsers. The crome will log onto Wherigo.con but will not download a cartridge.

 

You can use Firefox (easy to switch between PC and phone tablet if used on both) or Dolphin (fast and lean).

Share this post


Link to post

I have just started using a Samsung S3. I only see one browser. OS is android Ver 4.4.2. I also still have my old phone, a Motorola Razer Nax with OS android Ver 4.1.2. My Motorola has two browsers. The crome will log onto Wherigo.con but will not download a cartridge.

 

For me the Chrome (v44.0.2403.133) is working just fine (login+download). Phone is S2 with Android 5.1.1 (cm 12.1).

Share this post


Link to post

Tracker1944, can you please try to download cartridges again? I emailed Moun10bike at Groundspeak and he got someone to address this issue. It looks like replacing the security certificate did the trick, at least in my testing.

 

I'll send a message to Tracker1944 in case he is not watching this thread. I'd really like some confirmation from someone who has encountered this issue.

Share this post


Link to post

Thanks for the efforts however. Still get the same errors using the "standard" browser. I did download the chrome browser and this works. Have to download one place and then move file to WhereYouGo folder using the file utility. But that is no big deal now that I can get the cartridges downloaded. using chrome.

 

Tracker1944, can you please try to download cartridges again? I emailed Moun10bike at Groundspeak and he got someone to address this issue. It looks like replacing the security certificate did the trick, at least in my testing.

 

I'll send a message to Tracker1944 in case he is not watching this thread. I'd really like some confirmation from someone who has encountered this issue.

Share this post


Link to post

Okay, so at least you can work with it. I'll need to get an Android device later to test if Groundspeak keeps delaying on the Wherigo Foundation stuff.

Share this post


Link to post

It looks that today the problem is back.

No chance uploading or downloading any cartridge.

 

[b]Error During Upload[/b]

[size=2]System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> Attempted to read or write protected memory. This is often an indication that other memory is corrupt.   at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)   at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)   at Wherigo.GSPCartridgeService.CartridgeService.GetCompiledCartridgeWithMetaData(GWZMetaData gwzMetaData, String CartridgeFileName, String CartridgeId, Int64 PlayerId, String PlayerName, DeviceType deviceType, String CompletionCode)   at cartridge_download.btnDownload_Click(Object sender, EventArgs e)[/size]

 

Share this post


Link to post

I sent a message to get them to restart the server. They've been responsive from previous experiences, so it shouldn't take too long.

Share this post


Link to post

I see. I finally began doing some work and encountered it myself. I sent an email to the person who handles outages. Expect it to work in about twenty minutes.

Share this post


Link to post

Has anyone else tried downloading a Wherigo cartridge? I tried downloading via both my Android phone and my laptop (Firefox), but both ways I get the error message noted in the OP.

Share this post


Link to post

Has anyone else tried downloading a Wherigo cartridge? I tried downloading via both my Android phone and my laptop (Firefox), but both ways I get the error message noted in the OP.

Same here, I tried IE11 as well.

Share this post


Link to post

I sent the usual email. Expect it up in around fifteen minutes. They're usually pretty good about acting when they receive the email, though I'd also prefer a reply notification.

Share this post


Link to post

I sent the usual email. Expect it up in around fifteen minutes. They're usually pretty good about acting when they receive the email, though I'd also prefer a reply notification.

Yep - seems to be working now. Thanks!

And I agree about email acknowledgement. I don't miss the days when I'd send an email to a co-worker only to wonder whether they had read it and whether they were going to fulfill the request in the email.

Share this post


Link to post

Just encountered this problem for the first time. This thread is helpful.

Share this post


Link to post

Looks like we have the Problem again. I tried different Browsers but none worked on IOS and Android. Rangerfox, may you help US please? We are currently on holiday and wanted to do some Wherigo here. :-(

 

Thanks!

Share this post


Link to post

Looks like we have the Problem again. I tried different Browsers but none worked on IOS and Android. Rangerfox, may you help US please? We are currently on holiday and wanted to do some Wherigo here. :-(

I sent the message on Sunday evening in the US. I was returning from a cache run, so couldn't check email until I was in an airport.

 

I'll have to get with Groundspeak and see what's going on again. They said the issue shouldn't be happening as much as it once was, but it looks like whatever fix they initially made didn't hold out.

Share this post


Link to post

I'm going to be selfish this time. Instead of emailing Groundspeak right away, I'm going to take some time to create a program that might be able to detect this problem and email Groundspeak when it detects the issue. The goal is to reduce the length of downtime in the future through automated monitoring.

 

So I apologize: the downtime today will be extended by an hour or so to give me an opportunity to create this.

Share this post


Link to post

I finished the core testing on the application, so I sent the email. I must now create the rest of the application and host it somewhere as a scheduled task. Finishing the application to my quality level and learning the proper way to host it on Azure will take me several hours. I'll let everyone know when it is complete.

Share this post


Link to post

I completed the monitoring application. I had to put it somewhere, and creating another server would have cost me more money, so I added it as a special page in Kit. I then added a job that would call the page every half hour, causing it to check Wherigo.com for the cartridge compile issue. If it finds the issue, it will send me a text message. I had originally wanted to send Groundspeak an email, but I noted that as my intention in the email I sent when I asked for the server to be rebooted. In the reply, I was asked not to send automated emails to that address. Thus, I'll have it text message me and I'll send the email manually. Here we go, 3AM messages!

 

I was also told they'd be restarting the Wherigo.com server more frequently. If anyone has issues uploading a cartridge because the server suddenly stopped responding, please let me know. I'm not sure how frequently restarting the server would impact how the site responds for everyone. So please do let me know if you experience any issues.

Share this post


Link to post

I completed the monitoring application. I had to put it somewhere, and creating another server would have cost me more money, so I added it as a special page in Kit. I then added a job that would call the page every half hour, causing it to check Wherigo.com for the cartridge compile issue. If it finds the issue, it will send me a text message. I had originally wanted to send Groundspeak an email, but I noted that as my intention in the email I sent when I asked for the server to be rebooted. In the reply, I was asked not to send automated emails to that address. Thus, I'll have it text message me and I'll send the email manually. Here we go, 3AM messages!

 

I was also told they'd be restarting the Wherigo.com server more frequently. If anyone has issues uploading a cartridge because the server suddenly stopped responding, please let me know. I'm not sure how frequently restarting the server would impact how the site responds for everyone. So please do let me know if you experience any issues.

 

It seems not to work again ...

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  
Followers 11

×
×
  • Create New...