Jump to content

Geocaching Blog doesn't work properly with HTTPS


capsai
Followers 1

Recommended Posts

It sounds like you might have to write a rule within the add-on for those problematic URLs.

 

The authenticated-by-a-certification-authority SSL certificates aren't free. Non-implementation of https on servers that don't process confidential information might be a financial decision by Groundspeak.

 

EDIT: The issue might not be financial. Examination of the certificate issued at their web store shows it is a wildcard certificate which means they could theoretically deploy it on any server whose URL ends with .geocaching.com (unless they bought a wildcard certificate with a limited number of subject names). The issue could be technical/administrative; when you add another subject name to the certificate and re-key it, that new cert has to be reinstalled on all the servers on which it is currently in use.

Edited by frinklabs
Link to comment

After stumbling across this post and error, I end up discovering it's linked to other errors I've been experiencing on the site. The HTTPS Everywhere add-on has geocaching.com set enabled by default and when enabled the site is not redirected to SSL, but certain things within the page appear to be redirected to SSL and then silently stop working.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 1
×
×
  • Create New...