Jump to content

Garmin Oregon 6xx - v4.10

Followers 2

Recommended Posts

Firmware v4.10 change log:


Fix intermittent geocaching ‘Next Stage’ issue


Fix Cyrillic N/E/S/W direction characters in waypoint position editing


Fixed issue with barometer when auto calibration is turned off.


Fixed missing ascent, descent, and elevation statistics when reviewing certain tracks.


Fixed possible shutdown when using custom waypoint symbols.

Link to comment

I think 4.0 was to fix the custom waypoint symbol issue some have reported. The rest is icing on the cake. There seems to have been some tweaking behind the scenes as well. The GPS chip firmware has also been updated. Garmin seems to have improved position calculation by cutting back on the processing of weaker signals. I'm not sure of the exact method but improvements have been observed. Tested all day and no issues to report. Updating to 4.10 is definitely recommended!

Link to comment

Garmin Express found 4.1 for my 600 & I added it.


Now immediately after a GSAK GGZ export the 600 reboots & comes back without any geoccaches :P


I use the garminexport.gsk macro with ggz as the type & about 10000 caches in the filter :(


I'll look for the 4.0 gcd and see if going back cures this.

This export method was working in 4.0 ;)


EDIT: I couldn't find the 4.00 GCD, so I tried the export macro again & it was 3rd time lucky.


Other symptoms are that the USB mode did reset a couple of times before I tried the first exports.

Maybe these were 'local' PC related issues.

& not the GPSr

Edited by kevenh
Link to comment

I upgraded my Oregon 600 to 4.10 with no glitches at all.


I've been watching the Oregon 6xx wiki and haven't noticed others having trouble with the upgrade, so kevenh's problem may well have been PC related. Overall, people are reporting increased accuracy after the upgrade (myself included). Also, the freezing issue with custom icons seems to be fixed and the unit is more stable.


The 'Next Stage' function seems to work now, according to reports. The Trackback feature doesn't work as it does on the 60CSx, however and the odometer is still goofy.

Link to comment

I upgraded from 3.30 to this new version and encountered some problems using the "nüvi" mode for street navigation with CN Europe 2014.40.


1. It takes way too long (30 - 40 sec) to recalculate a new route when leaving the recommended route. Usually this is done in 5 - 10 sec.

2. When driving ahead after a turn the distance indicator (top left display) for the next turn stays 30 - 40 sec at 0m before it changes to the real value.

3. Auto Zoom doesn't work like before. Even when staying for many kilometers at the main road the map doesn't zoom out after a turn.

4. I had the issue a couple of times that the unit hung up (45 -60 sec) during boot process while loding photos, waypoints ect. (only 5 private photos in the photo folder)


I did a hard reset but that didn't circumvent the issues.

All problems discribed above didn't happen whith 3.30 FW.

All other things working fine so far (I'm not using the Oregon for Geocaching).


Seems that Garmin again fixed some issues while adding new ones.


Would be nice if somebody could test the "nüvi" mode to confirm the issues or not.



Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Followers 2
  • Create New...